


Introduction
LiPowerline offers a complete and intuitive solution for power line inspection and analysis from LiDAR point
clouds. It includes a powerful toolset for automatically classifying power lines, towers and vegetation and
effectively detecting a range of user-defined danger points such as vegetation overgrowth and tree fall.

LiPowerline is able to segment individual sections of the corridor based on the location of each power tower and
process all segments simultaneously.

After segmenting the corridor, LiPowerline utilizes our proprietary machine learning algorithms to automatically
classify power lines and towers. The conditional classification algorithm then allows for the ground point, building
and noise classification. Users are also given the option to manually edit the automatic classification results.

LiPowerline also has the ability to vectorize insulators and power lines, the results of which, can then be used to
simulate and predict how environmental variabilities, such as strong wind, ice coverage and high temperatures,
may affect the safety of electricity transmission.

Performing individual tree segmentation will allow users to simulate tree future growth and extract both identified
and potential danger points.

Crucial risk and analysis information is then automatically generated as an assessment report, allowing for a
precise understanding of the asset.

Specifically, LiPowerline has the following modules:

Data Management: The module provides management tools for point cloud and raster data, which include
format conversion, point cloud de-noising, normalization, raster band calculation and so on.

Statistics: Based on the number, density and elevation of LiDAR points, statistics can be calculated for data
quality evaluation.

Classify: The module provides various classification methods for point cloud classification including ground
classification, ground key point classification, interactive classification, machine-learning-based classification
(for building, vegetation, and custom classes) etc.

Power Line: The module supports automatic point classification(power line, tower, and ground), real-time
analysis of the powerline corridor condition and generate user-defined reports.

Get Started
Please refer to Installation and License to install the software. The usage is described in Tutorials.



Installation
Download the latest version of LiDAR360 Suite from the GreenValley International official website before
installation.

System Requirements

RAM: at least 8G or more.
CPU: Intel® Core™ i5/i7; Dual-core processor.
Display Adapter: NVIDIA graphics card recommended, video memory no less than 2GB.
Operating Systems: Microsoft Windows 7 (64-bit), Microsoft Windows 8 (64-bit), Microsoft Windows 10(64-
bit), Microsoft Windows Server 2012 and higher.

Note: Please enable high-performance graphics mode for running the software. On Windows 8 and
Windows 10 if the software is installed on the system disk, you need to set it up to run as an administrator.

Setup

1. Run the LiDAR360 Suite Setup Wizard.
2. Click Next button in the Welcome Interface.
3. Click I Agree button to continue if you accept the License Agreement.
4. Choose the installation path (or use default path), then click Install button.
5. Click Finish button after installation.

License Manager

There are two licensing approaches to activate LiPowerline, by license dongle or license code. For license
dongle, users must not format, delete, or copy the license dongle.

1) License dongle

Properly insert a license dongle to USB port to activate LiPowerline.

2) License code

License code would be generated based on activation information given by LiPowerline users. After purchasing a
license code, please follow the following steps to activate LiPowerline.

1.Run the software.

2.Click Help > Activate License, the License Manager window will pop up.

3.Under General Information tab, fill in your name and company name, select the modules you want to activate,
and then click Copy.

4.Email the copied information to info@greenvalleyintl.com.

5.There are two licensing modes: single use licensing and concurrent use licensing. After receiving the activation
key, activate or revoke the license using online or offline mode.

Single Use Licensing

Activation/Update

https://greenvalleyintl.com/
mailto:info@greenvalleyintl.com


Online Activation/Update: When connecting to the internet, under the “Single Use Licensing” tab, enter
the authorization key, select “Online”, and click “Activate” to activate or update. Activation information,
such as expiration date, will displayed below. Under “General Information” page, you may also check the
expiration date for each individual module. If you need to set up proxy to connect to the internet, click 

 to use proxy, and set up the address, port, user name, and password.

Offline activation: Step 1: Select “Offline” under the “Single Use Licensing” tab; Step 2: Click “Generate
Request File” button to generate the request file (.req); Step 3: Use a computer that can connect to the
internet to browse to https://user.bitanswer.cn, enter the authorization key to log in, click “Update”,
upload the request file (.req), and download the generated upgrade file (.upd); Step 4: go back to the
License Manager interface, click “Apply Promote File” and select the downloaded .upd file.

https://user.bitanswer.cn


Revoke

To unbind an activation key from a computer, user could revoke the activation key online or offline. After
the authorization key is revoked, it can be reused on the same computer or a different one.

Online Revoke: In “Single Use Licensing” tab, enter the authorization key, select “Online”, and click
“Revoke” to revoke the key. If you need to set up proxy to connect to the internet, click  to use proxy
and to set up the address, port, user name, and password.



Offline Revoke: Step 1: Select “Offline” under the “Single Use Licensing” tab; Step 2: Click “Generate
Revoke File” button to generate the request file (.req); Step 3: Use a computer that can connect to the
internet to browse to https://user.bitanswer.cn, enter the authorization key to log in, click “Update”,
upload the request file (.req), and download the generated upgrade file (.upd); Step 4: go back to the
License Manager interface, click “Apply Promote File” and select the downloaded .upd file.

Delete

To delete authorization information from the computer, right-click on the authorization key and select
“Delete Key”. After being deleted, the same activation key can only be used on the same computer.

https://user.bitanswer.cn


Concurrent Use Licensing

Install enterprise activation tool on the server to activate the key online or offline. Other users can use the
activation windows to input the server's IP address to activate the software. The default port is 8273. Click
"Apply".

6.Click the help button  on the License Manager interface to view the license manager user guide.



Note: If any of the software instance (i.e. LiDAR360, LiMapper, LiGeoreference, LiPowerline) is being
opened while updating the license in License Manager, please restart the software to make the license be
effective.

Note: If an user would like to move a key from one computer to another, he/she should revoke first, then
activate on the other. If the license code has been deleted, the user should reactivate on the same
computer first, then revoke and activate this key on the other computer.

Note: Please contact info@greenvalleyintl.com for inquiry and purchase.

Languages

Currently, the supported languages are English and Chinese. You can switch the menu language in the following
way:

1. Click Display > Language > English/Chinese in the menu bar.
2. Language change needs a restart to be effective. Click Yes in the pop-up dialog to restart the software

immediately, or click Cancel and restart later.

mailto:info@greenvalleyintl.com


Tool Reference
This chapter describes the usage of menu bar, toolbar, project management windows and toolbox of LiPowerline
in detail.

Project Tools

Color Tools

Viewing Tools

Operation Tools

Setting Tools

Measure Tools

Model Tools

Profile Tools

Select Tools

Rectify Tools

Project Management Window

Viewers

Display

Data Management

Statistics

Classify

Power Line



Project Tools
Add Data

Add and Merge Point Cloud Data

Delete Data

Export Data

Exit



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from
software (e.g. provided by LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to
produce X, Y, and Z point data. The intention of the data format is to provide an open format that allows different
LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do
some initial settings as shown in the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID,
Generating Software, File Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each
point record. LiPowerline imports all the point attributes by default.

Brief: One of the most useful features of LiPowerline is its ability to interface with data in many file
formats. You can import point clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.), tables,
images (JPG, TIF), models (OSG, LiModel, LiTin) or vectors into LiPowerline. It allows you to visualize,
animate and edit your point cloud as well. Point cloud data will be converted into LiData file at the first
time being added. LiData file is the LiPowerline native file format for point cloud and optimized for
viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.



You can search the coordinate system much more quickly by using regular expressions. For example, the
WGS 84 coordinate system will be displayed instantly when you input EPSG code of WGS 84 system as
shown in the figure below:

You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate
System. Recently used coordinate reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for
current point cloud data only. Apply All means all the point cloud data share the same configuration during
the LiPowerline's running and it won't show this configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z
coordinates and other attributes such as color and normal. These attributes can be simply arranged in one line for
each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do
some initial settings as shown in the figures below:



3. LiPowerline can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by
setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for
spreadsheets and databases. CSV format was used for many years prior to attempts to describe the format in a
standardized way in RFC 4180. The lack of a well-defined standard means that subtle differences often exist in
the data produced and consumed by different applications. These differences can make it troublesome to
process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format
is similar enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do
some initial settings as shown in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The
CSV table contains the ID of each tree, the x, y coordinate locations, the tree height, the crown diameter, and
the crown area properties. The data type could be Point or Circle. If Point type was selected, you should
specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.



Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D
scanners. It is a format for storing graphical objects that are described as a collection of polygons. A PLY file
consists of a header, followed by a list of vertices and then, a list of polygons. The header specifies how many
vertices and polygons are in the file. It also states what properties are associated with each vertex, such as (x, y,
z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary
version for compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII
text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do
some initial settings as shown in the figure below:

3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose
None.

5. Click Apply when you complete your configuration.

Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In
its simplest form, a raster consists of a matrix of cells (pixels) organized into rows and columns (grid) where each
cell contains a value representing information. The geographic location of each cell is implied by its position in the
cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no geographic coordinates are stored.
Due to the nature of the data storage technique data analysis is usually easy to program and quick to perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually
more aesthetically pleasing (traditional cartographic representation). Since most data is in vector form and no
data conversion is required. Accurate geographic location of data is maintained.



1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiPowerline stores triangulated regular network models generated by
DEM or DSM. LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiPowerline directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Add and Merge Point Cloud Data

Steps

1. Click tool botton  to open the Add and Merge Data window.

Bounding boxes of point clouds are displayed in the left area. Bounding box of the selected point cloud is
highlighted in red.

2. Select LAS or LiData as your data type.

3. Click  to add LAS/LiData file(s).

4. Click  to remove LAS/LiData file(s).

5. Click  to remove all file(s).

Brief: Merge two or more point clouds in LAS/LAZ or LiData format to one single point cloud in LiData
format.



Delete Data

Steps

1. Select the data item you want to remove in the tree widget to active the Remove button .

2. Click  .

Note: In some cases, it is not allowed to remove data from LiPowerline when it is busy running some
critical functions.

Brief: Remove data.



Export Data

Steps

1. Select the point cloud data you want to export in the tree widget on the left.

2. Move the mouse to that item and right click.

3. Click Export to show the Export Point Cloud window.

4. Input file path and name:

5. Set file type:

Brief: As described in Import section, you can easily move data into and out of LiPowerline. You can
currently export point clouds from LiData to many other formats (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ,
PTS, CSV etc.).



6. Click Save .



Exit
Brief: Exit the software.

Steps

1. (Optional) Click File > Exit to quit.

2. (Optional) Use the hotkey Alt+F4 to quit.



Color Tools
With tools in this section, LiPowerline allows you to visualize vast amounts of point cloud or DEM using the best
data representations for your analysis. You can change the coloration of the point cloud displaying by class( or
intensity, GPS time, return of number etc.). You can also enhance the render effect using visualization tools such
as EDL, PCV and Glass which are intuitive and helpful for quality check.

Display by Height

Display by Intensity

Display by Class

Display by RGB

Display by Return

Display by Time

Display by Blend

Display by Tree ID

Display by Mix

Display by Dangerous Tree

Display by EDL



Display by Height

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Elevation", as shown below.

3. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the elevation range of the point cloud data. At
the same time, the data is displayed by elevation in the scene. The visual effects are better with EDL mode,
as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The elevation values of point cloud data are
mapped to several uniformly varying color intervals, so as to display the variation of elevation values
more intuitively.



Display by Intensity

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Intensity. The color indicator of the window will generate the

corresponding gray color bar according to the intensity range of the point cloud data. At the same time, the
data is displayed by intensity in the scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The intensity values of point cloud data are
mapped to several uniformly varying color intervals, so as to display the variation of intensity values
more intuitively.



Display by Class

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar to pop up the dialog "Display by Class", as shown below.

3. Select the appropriate color for each class and click the "OK" button. The color indicator of the window will
generate the corresponding color bar according to the class attribute of the point cloud data. At the same
time, the data is displayed by classification in the scene. The visual effects are better with EDL mode, as
shown below.

Brief: This tool is used for displaying point cloud data. The classes of point cloud data are mapped to
discrete color values, so as to distinguish different classes of point cloud data more intuitively.



Note: This tool only works with point cloud data.



Display by RGB

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. The data is displayed according to its own RGB values in the scene, as

shown below.

Note: This tool only works with point cloud data contains RGB attributes.

Brief: This tool is used for displaying point cloud data. The point cloud data is displayed according to its
own color value.



Display by Return

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Return to pop up the dialog "Display by Return", as shown below.

3. Select the appropriate color bar for each return number and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the return number attribute of the point cloud
data. At the same time, the data is displayed by return number in the scene. The visual effects are better with
EDL mode, as shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The return numbers of point cloud data are
mapped to discrete color values, so as to distinguish different return numbers of point cloud data more
intuitively.



Display by Time

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Time to pop up the dialog "Display by Time", as shown below.

3. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the GPS time range of the point cloud data. At
the same time, the data is displayed by time in the scene. The visual effects are better with EDL mode, as
shown below.

Note: This tool only works with point cloud data.

Brief: This tool is used for displaying point cloud data. The GPS time values of point cloud data are
mapped to several uniformly varying color intervals, so as to display the variation of GPS time values
more intuitively.



Display by Blend

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. (Optional) Process the point cloud data by PCV.
3. Click Tool > Colorbar >  Display by Blend to pop up the dialog "Display by Blend", as shown below.

4. Select the appropriate color bar in the combo box and click the "OK" button. The color indicator of the
window will generate the corresponding color bar according to the elevation range of the point cloud data. At
the same time, the data is displayed in the scene according to the elevation values and intensity values. The
visual effects are better with EDL mode, as shown below.

Brief: This tool is used for displaying point cloud data. Consider the elevation attribute and intensity
attribute, the point cloud data is mapped to several uniformly varying color intervals, so as to reflect the
comprehensive variation of elevation/intensity more intuitively, and display the feature class and
boundary more explicitly.



Note: This tool only works with point cloud data. The visual effects will be better after PCV process for the
point cloud data.



Display by Tree ID

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. If the point cloud data contains tree ID attribute, then the data will be

displayed by tree ID in the scene. The visual effects are better with EDL mode, as shown below.

Note: This tool only works with point cloud data after individual tree segmentation.

Brief: This tool is used for displaying point cloud data after point cloud segmentation. The tree ID's of
point cloud data are mapped to discrete color values, so as to distinguish different trees of more
intuitively.



Display by Mix

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click Tool > Colorbar >  Display by Mix to pop up the dialog "Display by Mix", as shown below.

3. Select the attribute for display.
4. Select the appropriate color bar in the combo box.
5. Check the classes and return numbers for filtering.
6. Click the "OK" button. Then the color indicator of the window will generate the corresponding color bar

according to the selected attribute range the point cloud data. The data will be filtered by the specified
attributes first and then be displayed by the specified attributes in the scene. The visual effects are better
with EDL mode, as shown below.

Brief: This tool is used for displaying point cloud data. Different attributes of point cloud data are
mapped to several uniformly varying color intervals, at the same time different ways of attribute filtering
are supported, so as to display the variation of a certain attribute of the filtered point cloud data more
intuitively.



Settings

Display By: The selected attribute will be mapped to specified color range.
Height(Default): The elevation attribute of the point cloud data.
Intensity: The intensity attribute of the point cloud data.
Time: The GPS Time attribute of the point cloud data.

ColorBar: The color bar supports several uniformly varying color intervals for color mapping.
Filter by Classification: List all the classes users can choose to filter the point cloud data.
Filter by Return Number: List all the return numbers users can choose to filter the point cloud data.

Note: This tool only works with point cloud data.



Display by Dangerous Tree

Steps

1. Click the window that loads the point cloud data with the left mouse button and set it as the active window.
2. Click  in toolbar at the left side of the software UI. In the popup menu, click the  button, if the point

cloud contains the information of Tree ID and the clearance distance, the dangerous trees will be displayed
by tree ID. The visual effects are better with EDL model, as shown below.

Note: This tool only works with point cloud data.

Description: Used to display the dangerous tree in the segmented point cloud. By mapping the Tree ID
of the dangerous tree and the attribute of clearance distance to different color values, intuitively
distinguish the different dangerous in different colors.



Display by EDL

Steps

1. Click the window that loads point cloud data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. The visual effects of the point cloud data in the scene will be improved

with EDL mode. The following picture shows the comparison before and after using EDL display mode.

Note: This tool only works with point cloud data.

Brief: This tool is used to display the point cloud data and enhance the visual effects of the contour
features using the Eye Dome Lighting (EDL) mode. EDL is a shading technique that works with other
display mode (e.g. display by height, display by intensity) to improve the depth perception in 3D point
cloud visualization.



Viewing Tools
Set current active window to some view.

Top View

Bottom View

Left View

Right View

Front View

Back View

Front Isometric View

Back Isometric View

Set View Mode

Pick Rotation Center



Top View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to top view. View data from +z to -z direction. View plane: x-y plane.



Bottom View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief：Set camera to bottom view. View data from -z to +z direction. View plane: x-y plane.



Left View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to left view. View data from -x to +x direction. View plane: y-z plane.



Right View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to right view. View data from +x to -x direction. View plane: y-z plane.



Front View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to front view. View data from -y to +y direction. View plane: x-z plane.



Back View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera to back view. View data from +y to -y direction. View plane is x-z plane.



Front Isometric View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief：Set camera position to front 45 degrees of X-Y plane.



Back Isometric View

Steps

1. After clicking this button, current active window will be shown:

Note: This tool is only for viewer in 3D mode, and it does not reset the center position of the viewer. If you
need to reset to the default view, please click Full Extent.

Brief: Set camera position to back 45 degrees of X-Y plane.



Set View Mode

Steps

1. After clicking this button, the option of projection mode is popped up. If Orthogonal Projection is selected,
current active window will be set in orthogonal projection. If Perspective Projection is selected, current active
window will be set in perspective projection.

Settings

Shortcut Key：F3

Note: This tool is only for viewer in 3D mode.

Brief: Select projection mode(orthographic/perspective).



Pick up Rotation Center

Steps

1. Click button on left toolbar, move moust on the viewer currently activated. And the mouse cursor
changes into , pick up a point and this point will become new rotation center. Then the cursor will restore
as arrow shape. Press "Shift" to reset rotation center.

Note: This function is only avaliable in 3D viewer.If users want to cancel current rotation center, please
click Top View, Bottom View, Left View, Right View, Front View, Back View or Global View.

Description: Pick up rotation center in 3D viewer.



Operation Tools
The operation toolbar contains tools to control view operations.

Full Extent

Pan

Go To



Full Extent

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. All the data in the active window will be scaled automatically to cover the

entire window, as shown below.

Note: When there are multiple windows, this tool only works on the active window.

Brief: This tool is applicable to all data types supported by LiPowerline. It makes all the data cover the
entire window in top view and provides full view of all the data.



Pan

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar. Drag the left mouse button over an area to pan the data.

Note: When there are multiple windows, this tool only works on the active window. If using the right click
and drag, there is no need to select the pan tool.

Brief: This tool is applicable to all data types supported by LiPowerline. It's used to change the focus
area of the data. The right mouse button can be used together with this tool.



Go To

Steps

1. Click the window that contains data with the left mouse button and set it as the active window.
2. Click the button  on the toolbar and the mouse pointer turns to . Select a particular point in the scene.

The attributes of this point will be shown in a label. At the same time, the "Go To" dialog pops up, as shown
below.

3. If "Pick Point" is checked, the focus point is selected by mouse click. Otherwise, the coordinates of the focus
point are selected by manual input.

4. Set the time to go to the selected point.
5. Click the "OK" button. The label will disappear, and a red dot will start to flash.
6. When it is focused to the selected point, the red dot disappear, as shown below.

Brief: This tool is applicable to point cloud data, raster data and model data. It's used to focus to the
selected point.



Settings

X: X component of the coordinate.
Y: Y component of the coordinate.
Z: Z component of the coordinate.
Time: Time to go to the selected point.
Pick Point (Optional): If "Pick Point" is checked, the focus point is selected by mouse clicking.

Note: When there are multiple windows, this tool only works on the active window.



Setting Tools
Basic settings for viewers.

Capture Image

Cross Selection

Window Linkage

Rolling Screen

Configure Point Size and Type

Display Options

Camera Setting

As 2D

As 3D



Capture Image

Steps

1. Click this button, open save file dialog, default file name is window name, click "OK" to save file.

Brief: Save the view in current window as a JPG file.



Cross Selection

Steps

1. Click Tool >  Cross Selection to open the dialog shown below:

2. Click button  to reset ROI.
3. Click button  to export point cloud inside the ROI to a new LiData File.
4. Click button  to exit cross selection.
5. The whole display effect is shown below. Drag the blue, green ,or red rectangular interactor in the viewer to

adjust the size of the ROI. Drag the blue, green ,or red spherical interactor to adjust the orientation of the
ROI.

Brief: Cross select partial point cloud using ROI. This function can be used for flood analysis and other
applications.



Settings

Prerequisite: Current viewer contains point cloud.
Show ROI：Show or hide ROI.
ROI：Adjust the minimum and maximum X, Y, Z of the ROI.
Shift ROI：+X, +Y, +Z means to move the ROI to the X, Y, Z positive direction for a default distance. -X, -Y,
-Z means to move the ROI to the X, Y, Z negative direction for a default distance.

Note: This function is for all point clouds in the current viewer.



Window Linkage

Steps

1. Click Tool >  Window Linkage to open the dialog shown below:

2. The windows list contains all windows in LiPowerline, double-click a window that needed to linkage, or select
the window then click button  to add the window. Also, user can click button  to add
all windows to linkage windows list. The linkage windows list all windows under linkage, double-click a
window to remove, or select the windows and then click button  to remove. Also, user can click
button  to remove all linkage windows.

3. If "Cross Line" is checked, cross line will be displayed in the linkage windows. The following figure shows if
the cross line is checked:

Brief: Enable windows linkage of multiple viewers.



Note: If the current window contains raster data, it will be displayed in 2D. If the linkage windows contain
3D window and 2D window, the windows will be displayed in 2D mode.



Rolling Screen

Steps

1. Click Tool >  Rolling Screen to open the dialog shown below:

2. 
i. Current files list contains files in current viewer. Double-click a file that needs to be added to rolling

screen, or select files and then click , or click button  to add all files to rolling
screen files. The rolling screen files list contains files in rolling screen, double-click a file to remove, or
select files and then click button  to remove, or click button  to remove all files.

3. Click "OK". In the viewer, press the "Shift" button on the keyboard then drag. The window is shown below:

Settings

Brief: Enable rolling screen for current viewer.



Prerequisite: An active viewer.

Note: This function cannot be apply to the profile window. Click this button again to exit.



Configure Point Size and Type

Steps

1. Click this button to open the dialog shown as below:

2. Configure point size and type.

Settings

Circular Points: Determine point type. If checked, point will be rendered as circle, otherwise, point will be
rendered as square.
Fixed Size: If checked, point size would be fixed. User can adjust point size using the slider below (range 0-
50 pixels).
Point Autosize: If checked, point size is auto changing based on the depth of the viewer.

Note: This function is global. If user wants to configure a single point cloud, just right-click it, select
Configure Point Size and Type from the context menu.

Brief: Configure point size and type.



Display Options

Steps

1. Click this button to open the dialog shown as below:

2. Click "Colors" page to set background color:

Brief: Configure background color, label properties and lights.



3. Click "Labels" page to set label color and size:

After creating any tag, user can move it by dragging. Push "Delete" key on the keyboard to delete selected
tags.



4. Click "Light" page to set the direction of light. Light settings only effect on model files (LiModel, LiTin, OSGB,
etc.).

5. Click "Default All" to restore all settings to default values.



Camera Setting

Steps

1. After clicking this button, the dialog shown below would pop up:

2. Adjust camera rotation using sliders.
3. Click  to pick a point as rotation center.

Brief:Camera settings for current active 3D window.



Settings

Prerequisite: Current active window must be in 3D mode.
Current mode: Show projection type of current active window, including perspective projection and
orthogonal projection.
X: Camera rotation around X axis.
Y: Camera rotation around Y axis.
Z: Camera rotation around Z axis.
Rotation Center: Rotation center, which could be picked from viewer.
Camera/Eye Center: Non-editable, computed using rotation.
Field of view: Field of view, default 30 degree.
Distance: Distance to viewpoint. Non-editable.



As 2D

Steps

1. After clicking this button, current active window will switch to 2D mode, as shown below:

Note: If current active window contains raster data, it can only be set to 2D mode. After removing raster
data, it can be set to 3D mode.

Brief: Switch current active window to 2D mode.



As 3D

Steps

1. After clicking this button, current active window will switch to 3D mode, as shown below：

Note: If current active window contains raster data, it can only be set to 2D mode. After removing raster data, it
can be set to 3D mode.

Brief：Switch current active window to 3D mode



Measure Tools
The measure tools are used to measure geometric information about the data.

Pick Point

Multi Pick Point

Length Measurement

Area Measurement

Angle Measurement

Height Measurement

Volume Measurement

Density Measurement



Pick Point

Usage

Click Tool > Measure > Pick Point

Steps

1. Click a valid point in the scene and a label that displays the point attributes will pop up. If the point belongs to
point cloud data, then the label will show the position, intensity, return number, classification and GPS time,
as is shown below. If the point belongs to raster data, then the label will show the position, stretched RGB
value and pixel value.

Click the right mouse button, two context menus will pop up. The menu "Clear Measure" is used to clear the
selection result. The menu "Quit Measure" is used to exit the pick point function.

Note: This tool only works with point cloud data, raster data and model data. It's available in the profile
window too.

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data, the
attributes that can be queried contain position, intensity, return number, classification and GPS time. For
raster data, the attributes that can be queried contain position, stretched RGB value and pixel value.



Multi Pick Point

Usage

Click Tool > Measure >Multi Pick Point

Steps

1. Left-click the points in the scene and the selection results are marked by labels. At the same time, a table
that contains the attributes of the selection points will pop up, shown as follows. The attributes of point cloud
data shown in the table contain index, position (XYZ), classification, return number, GPS time and intensity.
The attributes of raster data shown in the table contain index, position (XY) and band value. The total
number of the points is updated real-time above the table.

2. The "marker size" is used to set the point size of the marker in the scene. The "start index" is used to set the
start index of the selected points.

3. Double-click a row of the table, the scene will go to the position of the corresponding point automatically.
4. Select a row of the table by left-clicking and click the button  to delete the point.
5. The selection set can be exported as *.txt format. Click the drop-down menu  to pop up "Select Format"

dialog, as shown below. If the selected points belong to raster data, then the menu "Save 2D points" is
available. If the selected points belong to 3D data, then the menu "Save 3D points" is available. If the
selected points contain 2D data and 3D data, then the menu "Save all points" is available.

Brief: This tool is applicable to point cloud data, raster data and model data. For point cloud data, the
attributes that can be queried contain position, intensity, return number, classification and GPS time. For
raster data, the attributes that can be queried contain position, stretched RGB value and pixel value.
Different from the pick point tool, this tool allows querying multiple points at the same time, and the
selection set can be exported in *.txt format.



6. Click  to pop up the export dialog. Input the output path, and check the attributes that need to

be exported. Click "OK" to complete the export. Click "Cancel" to cancel the export.
7. If the selected points have not been saved before quiting this tool, a message box will pop up as follows.

Click "Save" to save the points. Click "Discard" to cancel the selections.

Settings

X: X component of the coordinate.
Y: Y component of the coordinate.
Z: Z component of the coordinate.
Classification: The class attribute of point cloud data.
Return: The return number attribute of point cloud data.
Time: The GPS time attribute of point cloud data.
Intensity: The intensity attribute of point cloud data.
Index: The index of select point.
BandValue: The band value of raster data.
Output Path: The path of the output file.

Note: This tool only works with point cloud data, raster data and model data. If the center of rotation needs
to be changed, hold down the the Ctrl key and select the center of rotation with the left mouse button. This
tool is available in the profile window too.



Length Measurement

Usage

Click Tool > Measure > Length Measurement

Steps

1. Left-click at least two points in the scene and the corresponding polyline will be rendered real-time. The
measurement result is displayed in a label as follows. Double-clicking the last point will stop the
measurement process, and the distance value will continue to be displayed in the label.

Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The menu
"Quit Measure" is used to exit the measure tool.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is only
available before the measurement is stopped. This tool is available in the profile window, too.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the
distance between two consecutive points.



Area Measurement

Usage

Click Tool > Measure > Area Measurement

Steps

1. Left-click at least three points in the scene and the corresponding polygon area will be rendered real-time.
The measurement result is displayed in a label as follows. Double-clicking the last point will stop the
measurement process, and the measurement result will continue to be displayed in the label.

Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The menu
"Quit Measure" is used to exit the measure tool.

Note: This tool only works under orthogonal projection. The "Back One Point" is only available before the
measurement is stopped.

Brief: This tool is applicable to all data types supported by LiPowerline, which calculates the projected
area within the polygon region. Current window will switch to Orthogonal Projection automatically for 3D
data.



Angle Measurement

Usage

Click Tool > Measure > Angle Measurement

Steps

3D View：

1. Select the reference point of angle measurement by left-clicking.
2. Select the measurement point by double-clicking. The pitch angle between the reference point and the

measurement point will be rendered in the scene and the measurement result is displayed in a label as
follows.

2D View：

1. Select the first point of angle measurement by left-clicking.
2. Select the second point of angle measurement by left-clicking.
3. Select the third point of angle measurement by double-clicking. The projection angle of the three points

on the horizontal plane will be rendered in the scene and the measurement result is displayed in a label
as follows.

Brief: This tool is applicable to point cloud data, raster data and model data, which calculates the angle
of pitch between two points in 3D view and calculates the projection angle of three points on the
horizontal plane in 2D view.



Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The
menu "Quit Measure" is used to exit the measure tool.

Note: This tool only works with point cloud data, raster data and model data. The "Back One Point" is only
available before the measurement is stopped. The tool is available in the profile window too.



Height Measurement

Usage

Click Tool > Measure > Height Measurement

Steps

1. Select the reference point of height measurement by left-clicking.
2. Select the measurement point by double-clicking. The relative height difference between the reference point

and the measurement point will be rendered in the scene and the measurement result is displayed in a label
as follows.

Click the right mouse button, three context menus will pop up. The menu "Back One Point" is used to go
back to the previous step. The menu "Clear Measure" is used to clear the measurement result. The menu
"Quit Measure" is used to exit the measure tool.

Note: This tool only works with point cloud data and model data. The "Back One Point" is only available
before the measurement is stopped. The tool is available in the profile window too.

Brief: This tool is applicable to point cloud data and model data, which calculates the relative height
difference between two points.



Volume Measurement

Usage

Click Tool > Measure > Volume Measurement

Steps

1. It is suggested to adjust the window to top view before the tool is used. Select at least three points to
generate the reference plane for volume calculation by left-clicking. Select the last point by double-clicking.
The border of the selected region will be rendered in red and the dialog "Volume Measure" will pop up.

2. Set the cell size.
3. Set the reference plane of volume measurement. The options include minimum value, mean value and

customr value.
4. Click the "Compute" button to generate the measurement result. The corresponding volume will be rendered

in the scene, as shown below.

Brief: This tool is applicable to point cloud data and model data, which calculates filling, cutting and total
amount relative to a reference height. It's commonly used in volume measurement of coal pile and hull.



5. Click the "Export" button to export the result in *.pdf or *.txt format.

Settings

Cell Size: It defines the smallest unit size for calculation. The smaller the value is, the more accurate the
calculation is.
Basic Height: It defines the reference plane to calculate filling and cutting.

Minimum (Default): Use the minimum height of the selected points as the height of the reference plane.
Mean: Fit the best plane according to the selected points.
Customr: This value is specified by the user.

Note: This tool only works with point cloud data and model data in 3D view.



Density Measurement

Usage

Click Tool > Measure > Density Measurement

Steps

1. Active window is adjusted to orthogonal projection automatically when this tool is started. Then the dialog
"Density" pops up.

2. If the option "Width" is checked, the width value can be manually input, and the height value will be set to the
same as the width value, then the area value will be decided by "Width" and "Height". The measurement
region can be selected by left-clicking.

3. If the option "Width" is unchecked, the width value and the height value will be decided by the size of the
rectangle that is drawn interactively by left-clicking the upper left corner and the lower right corner. The area
value will be decided by "Width" and "Height". The rectangle will be rendered in the scene and the
measurement result is displayed in a label as follows.

Settings

Width: It defines the width of the reference rectangle.
Height: It defines the height of the reference rectangle.
Area: It defines the area of the reference rectangle.

Note: This tool only works with point cloud data and model data under orthogonal projection.

Brief: Point density is an important metric to measure the quality of point cloud data. The average
number of points per square meter can be counted with this tool.



Model Display
Set the display mode of models in current active window.

Show Model

Show Triangle

Show Point



Show Model

Steps

1. Click this function, the models in the current active window will display in model, as shown in the figure
below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief：Set model files in the current window to display in model type.



Show Triangle

Steps

1. Click this button, the models in current active window will display as triangle mesh, as shown in the figure
below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to triangle mesh mode.



Show Point

Steps

1. Click this button, the models in current active window will display as points, as shown in the figure below:

Settings

Shortcut key：Press the "W" key to switch the display mode between model, triangle and point.

Note: The model types for this function includes LiTIN, LiModel, IVE and other model types.

Brief: Switch display mode of models in current window to point mode.



Profile Tools
On orthographic projection top view mode, users can draw a rectangle area by Profile and display the side view
of the area in an independant viewer. Or users can launch Profile tool directly in 3D viewer. There are different
tools in the profile viewer to help browsing, measuring or modifying the data. e.g. modify class information of the
point cloud in the rectangle area.

2D profile viewer is as picture below:

3D profile viewer is as picture below:

Limited by auto classification algorithm, manual editing is necessary for higher accuracy. In this case, Profile tools
are helpful.

TIN Tools

Auto Hide



Views

Select Profile Area

Fixed Buffer

Move Profile Selection Area

Rotate Profile Selection Area

Expand Profile Selection Area

Measurement Tools

Manual Classification

Profile and TIN Tools

To build triangulation model.Triangulaltion model will change in real time when users are editing point cloud data
class, to help users see the effect of editing.

Note: Users can adjust brightness to improve TIN display effects.

Please refer to TIN Tools for detailed information.

Profile and Angle/Height Measurement Tool

Angle Measurement, Height Measurement and Pick Point are available in Profile window.

Profile and Strip Alignment

When doing strip alignment, users need to check data misalignment among strips caused by Heading/Pitch/Roll
angles.

For example, the picture below shows the data misalignment before doing strip alignment.



During the strip alignment process, users can check alignment effect by setting different parameters in profile
window.

When users are happy with alignment effect in profile window, the point cloud can be transformed according to
the current parameters and written directly to disk.

Besides, users can use measurement tools in profile window to help adjusting Heading/Pitch/Roll angles. Please
refer to Strip Alignment for detailed information.

Profile and ALS Editing

After activating ALS editing, current point cloud viewer will turn into 2D viewer. To check if seed points are at the
correct location, users can use profile tools and rotate point cloud in the profile viewer.



Note: General profile toolbar is not available in the profile window under ALS editing.

Profile and TLS Editing

After activating TLS editing, current point cloud viewer will turn into 2D viewer. To check if seed points are at the
correct location, users can use profile tools and rotate point cloud in the profile viewer.

Note: General profile toolbar is not available in the profile window under TLS editing.

Profile and Powerline

In powerline module, users need to classfy point cloud into different classes, such as tower, conductor,
dangerous point, vegetation etc. Limited by auto classification algorithm, manual editing is necessary for higher
accuracy.

After cliping and classifying the powerline data, users can check and modify classification result in profile window.



Auto Hide
Hide Profile Toolbar.

Steps

1. (Optional)Click to hide profile toolbar automatically.
2. (Optional)Click to fix toolbar.

Note: When Auto Hide function is prohibited, the toolbar will be floating on the top of profile window. In
contrast, the toolbar will hide after a few seconds and appear again when cursor moves to the top. This
function is especially suitable for small screen and tight space.



View

Steps

1. By default, the profile window shows the front view of selection area. Users can click drop-down menu  to
change the view.

2. (Optional)Click to choose front view.

3. (Optional)Click to choose back view.

4. (Optional)Click to choose left view.

5. (Optional)Click to choose right view.

Note: If users are interested to view selection area from other view, they can click  to activate rotation
function in profile window. After activation, users can rotate the selection area by any random angle.

DescriptionUnlike general 3D viewer, the profile window does not support rotation by default. There are
four views can be chosen: front view, back view, left view and right view.



Profile Tools
LiPowerline provides multiple profile tools for different scenarios.

Fixed Buffer

Move Selection Area

Rotate Selection Area

Expand Selection Area

Note: Above settings are available for mixed use.



Fixed Buffer
To draw a selection area with fixed buffer in profile window.

Steps

1. Set fixed buffer size in Buffer column. For example: 11.6274m

2. Tick the circle on the left.

3. Move mouse to the main window, zoom and pan to target area. Left click to pick up the first end point, move
mouse, and left click again to pick up another end point. Two end points are used to decide profile direction.

4. End selection.



Move Selection Area
According to the direction and width of current selection area, move forward or backward.

Steps

1. Move mouse to the main window, zoom and pan to target area. Left click to pick up the first end point, move
mouse, and left click again to pick up another end point. Two end points are used to decide profile direction.

2. Move mouse to decide buffer width, double click to finish drawing.

3. (Optional)Click  to move selection area forward.

4. (Optional)Click to move selection area backward.



Rotate Selection Area

Steps

1. Move mouse to the main window, zoom and pan to target area. Left click to pick up the first end point, move
mouse, and left click again to pick up another end point. Two end points are used to decide profile direction.

2. Move mouse to decide buffer width, double click to finish drawing.

3. Set Angle value(degree, -360~360).

4. Click  and rotate.

Description: Rotate Selection Are in profile window.



Measurement Tool

Steps

1. Left click to pick up the first end point.

2. Move mouse and double click to pick up another end point.

Description: Different from the general measurement, the default is the orthogonal projection in the
profile window. After clicking two points, users can easily calculate the horizontal and vertical distances
in the current view. When rotation function in the profile window is not enabled, the frustum axis is
always vertical to the Z axis and parallel to the horizontal plane. The vertical and horizontal distances
under this condition can be very useful in some scenarios. For example, users can use this information
for parameter estimation before strip alignment.



Manual Classification

Steps

1. Click to set From Class and To Class.

Points to be classified only come from ticked From Class. For example, if users merely want to classify
ground points from unclassified points, they can only tick Unclassified in From Class. And all selected
unclassified points will turn into ground points.

1. (Optional)Users can set sequence of drop-down menu in different scene. Go to main menu Display->Class
Setting Options to change class priority list.

Description: Most of the tools provided by the profile window are integrated on the toolbar. These tools
can be used for manual classification.



By default, the classes are arranged in the LAS white paper. Users can also select a class and click the
button on the right side of the interface to adjust the order: Up Down Top Bottom Users can
also double click the class and rename it(Not including specific classes 0-8).

1. Choose a suitable selection tool and classify manually:

Polygon: Suitable for random polygon or complex concave polygon. For example, a tree or a building.
Use Parity Ruleto check if the feature is selected.

Rectangle: Suitable for features with simple shapes. Compared to polygon selection, the edges of a
rectangular selection can only be parallel to the corresponding edges of the window.

Circle: Circle selection is convenient for some circumstances. For example, a circle pool.

Above Polyline: Point clouds above the polyline will be selected.

Below Polyline: Point clouds below the polyline will be selected.

https://en.wikipedia.org/wiki/Even%E2%80%93odd_rule


2. (Optional)Press hot key Ctrl+Z to undo last operation. Or click  to clear all temporary operation.

3. After all class modifications are done, click  to save the modification.

4. Clip Profile Automatically: The point cloud data is automatically cliped based on the starting tower number
and the ending tower number. The previous/next span tool can clip the entire tension section directly; the
previous/next tower will only clip the next section. Use this tool to quickly improve editing efficiency.

Note: Manual check is necessary after automatic classification to guarantee the accuracy. Normally,
manual check is carried out in the profile window. Under some circumstances, generating TIN for selection
area can help class modification.



Select Tools
Select and save point clouds in interest area.

Polygon Selection

Rectangle Selection

Sphere Selection

Subtract Selection

In Cut

Out Cut

Save Cut Result

Cancel Selection



Polygon Selection

Usage

Click Tool > Cut Point Cloud > Polygon Selection

Steps

1. Click the Polygon Selection button to activate this function (Click again if you want to deactivate it).

2. Add polygonal vertices by left click. At least 3 vertices are needed to form a closed loop.

3. (Optional) Delete added vertices in reverse order by right click, if some of them are unwanted.

4. Left double click to add the last vertex. The selected points in the polygon area are highlighted.

Brief: Select point cloud data in polygon area.



5. (Optional) Combine multiple selections.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points
are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Rectangle Selection

Usage

Click Tool > Cut Point Cloud > Rectangle Selection

Steps

1. Click the Rectangle Selection button to activate this function (Click again if you want to deactivate it).

2. Add the first vertex by left click. Then move cursor to adjust rectangle size.

3. (Optional) Delete the first vertex by right click, if it's unwanted.

4. Left double click to add the second diagonal vertex. The selected points in the rectangle area are highlighted.

Brief: Select point cloud data in rectangle area.



5. (Optional) Combine multiple selections.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points
are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Sphere Selection

Usage

Click Tool > Cut Point Cloud > Sphere Selection

Steps

1. Click the Sphere Selection button to activate this function (Click again if you want to deactivate it).

2. Add the center point of sphere by left click. Then move cursor to adjust radius.

3. (Optional) Delete the center point by right click, if it's unwanted.

4. Left double click to confirm the radius. The selected points in the sphere are highlighted.

Brief: Select point cloud data in sphere.



5. (Optional) Combine multiple selections.



6. (Optional) Remove unwanted points from the selected, if Subtract Selection is active. The removed points
are no more highlighted.



Shortcut Key: Press Ctrl + Z to undo the selection operation.

Note: This function is only applicable to point cloud data.



Subtract Selection

Usage

Click Tool > Cut Point Cloud > Subtract Selection

Steps

1. Activate one of the geometric selection tools (Polygon Selection, Rectangle Selection or Sphere Selection)
before using Subtract Selection. Then please activate/deactivate Subtract Selection by left click.

2. (Optional) If Subtract Selection is inactive, multiple selections can be combined.

Brief: This function is effective on one of the geometric selection tools (Polygon Selection, Rectangle
Selection or Sphere Selection). If Subtract Selection is inactive, more points can be added to the
currently selected. If active, unwanted points can be removed from the currently selected.





3. (Optional) If Subtract Selection is active, unwanted points can be removed from the currently selected.





Shortcut Key: Press Ctrl + Z to undo the last operation.

Note: This function is only applicable to point cloud data.



In Cut

Usage

Click Tool > Cut Point Cloud > In Cut

Steps

1. Select points using Polygon Selection, Rectangle Selection or Sphere Selection. The selected points are
highlighted.

2. Click the In Cut Button. The result is shown in the following figure.

Brief: Cut point clouds after selection. The selected points are kept while the unselected are hidden.



3. (Optional) You can repeat this function several times to get the result you need.

Shortcut Key: Press Ctrl + Z to undo the cut operation. The corresponding selection is also cancelled.

Note: This function is only applicable to point cloud data.



Out Cut

Usage

Click Tool > Cut Point Cloud > Out Cut

Steps

1. Select points using Polygon Selection, Rectangle Selection or Sphere Selection. The selected points are
highlighted.

2. Click the Out Cut Button. The result is shown in the following figure.

Brief: Cut point clouds after selection. The selected points are hidden while the unselected are kept.



3. (Optional) You can repeat this function several times to get the result you need.

Shortcut Key: Press Ctrl + Z to undo the cut operation. The corresponding selection is also cancelled.

Note: This function is only applicable to point cloud data.



Save Cut Results

Usage

Click Tool > Cut Point Cloud > Save Cut Results

Steps

1. Click this button after successful cut operations(In Cut, Out Cut). An interface is shown as follows.

2. Select source point cloud files, from which new files are generated.

3. (Optional) Check/Uncheck the option "Merge files into one" according to demand.

4. Specify the output path. New file names are created based on the source file names and system time. An
example of new file name is "SourceFileName_CutResult_SystemTime.LiData".

5. After data saving, a dialog will ask if you want to add the new files to current project.

6. Click Yes or No according to demand.

Brief: Save results after cut operation as new point cloud files.



Cancel Selection

Usage

Click Tool > Cut Point Cloud > Cancel Selection

Steps

1. Click this button after selections(Polygon Selection, Rectangle Selection, Sphere Selection) or cut
operations(In Cut, Out Cut). All the selections and cut operations will be cancelled.

Note: This function is only applicable to point cloud data.

Brief: Cancel all the selections and cut operations.



Rectify

Usage

Click Tool > Rectify

Note: You have to create at least two display windows (except the profile window) before using this tool.

Steps

1. Create two display windows and load the reference data and the to-be-aligned data into separate windows.
Click the Rectify tool to open the following dialog.

Brief: This tool is used for coordinate rectification of to-be-aligned data with respect to reference data.
The two datasets can be "point cloud and point cloud", "point cloud and image", or "image and image".
At least 3 pairs of homologous points(or fitted spheres in point cloud) should be added in the datasets,
which are displayed in separate windows, before the calculation of transformation parameters. You can
evaluate the accuracy using the residuals of homologous points listed in the table window.



2. Select Reference window for the reference data and Alignment window for the to-be-aligned data. Then
click the Binding button. The following table window with a series of tools pops up.

3. (Optional) Click the Change Datum button to exchange the reference window and alignment window, if they
were mistaken.

4. (Optional) Click the Load Data button to load homologous points from existing file. Then you can skip the
manual measurement (steps 5, 6, 7).

5. Click Pick Point or Pick Registration Sphere to measure a pair of homologous points (or fit a pair of spheres)
in reference window and alignment window. If spheres are fitted, their centers are used as homologous
points.

6. Click the button Add Point to add blank row for a new pair of homologous points.

7. Repeat steps 5 and 6 to pick at least three pairs of homologous points (or spheres).

8. (Optional) If the option Predict is checked and there exist at least 3 pairs of homologous points, the
corresponding position in the reference window will be predicted after picking a point in the alignment
window.

9. (Optional) The user can exclude a pair of homologous points in the calculation of transformation
parameters: (1) Uncheck the row of the homologous points in the table; (2) Or click the Delete Point button
after selecting the corresponding row.

10. (Optional) The user can modify the coordinates of added homologous points: (1) Pick point again in the
alignment window and reference window after selecting a row of homologous points; (2) Or double click the
coordinates in a row, then input new values directly.

11. (Optional) The user can view each homologous point quickly for quality check: Double click a row in the
table to jump to the corresponding positions in the display windows.



12. (Optional) Click the Save Data button to save the homologous points to file.

13. Click the button Transform to calculate transformation parameters and generate aligned data.

Toolbar

Following functions are integrated in the toolbar.

 Save Data: Save homologous points to file.
 Load Data: Load homologous points from file (Please refer to File Format of Homologous Points).
 Change Datum: Exchange reference window and alignment window. The homologous points are also

exchanged.
 Add Point: Add blank row for a new pair of homologous points in the table.
 Delete Point: Delete selected row in the table.

Point Size (Default: "20"): Point size of homologous points in display windows.

Predict (Default: Unchecked): If this option is checked and there exist at least 3 pairs of homologous points, the
corresponding position in the reference window will be predicted after picking a point in the alignment window.

 Pick Point: Pick homologous points in reference window and alignment window.
 Pick Registration Sphere: If target ball is used for point cloud registration, this function can fit sphere

automatically after clicking the target ball in point cloud. The sphere center is used as homologous point.
R: Radius for sphere fitting. Please input the actual radius of target ball.

RMS: The threshold of root mean square error for sphere fitting. Please set larger value for point cloud of low
quality in case of fitting failure.

Transform: The coordinates are rectified based on homologous points. While processing image data, the
user can specify different methods, which include polygonal correction and polynomial correction. The polynomial
correction varies depending on N pairs of homologous points.

Polynomial Correction Condition

Primary Polynomial 3 <= N < 6

Quadratic Polynomial 6 <= N < 10

Cubic Polynomial 10 <= N



Project Management Window
The data list in the project is managed by layers and windows separately.

Layer Management

Point Cloud

Raster

Vector

Table

Model

Window Management

Note: The data loaded into the project can be displayed in single/multiple window(s), or not displayed at all.
Please drag data to a certain window for display.



Layer Management

Brief

The project layers manage the data in the software by group, whose types include Point Cloud, Raster,
Vector, Table, and Model.

Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII
File(*.txt,*.asc,*.neu,*.xyz,*.pts,*.csv);
Raster: Image File(*.tif,*.jpg);
Vector: Vector File(*.shp);
Table: Table File(*.csv);
Model: Proprietary Model File(*.LiModel), Proprietary TIN File(*.LiTin), OSG Model
File（*.osgb,*.ive,*.desc,*.obj);

In the project layers the user can remove data from the software, show/hide data in all windows by
checking/unchecking the box before data node (or data type node). The data can be dragged from data node to
different windows for display. The context menu (i.e. right-click menu) of data node, which differs depending on
data types, is mainly used for data query, display, statistics, export, and removal, etc.

Click the  button to show the project layers as follows:

Context Menu

Open the context menu by right clicking data type or data.

Context menu of point cloud
Context menu of raster
Context menu of vector
Context menu of table
Context menu of model

Note: The context menu of layer management is effective on all windows, while the context menu of
window management is only effective on specified window.



Point Cloud Context Menu

Brief

The context menus are used to for data import, removal, query, display, statistics, export, etc.

Data Type Context Menu

The user can open this menu by right clicking the point cloud data type.

Import Data: The point cloud data formats supported by LiPowerline include LiData (*.LiData), LAS (*.las,
*.laz), ASCII (*.txt, *.asc, *.neu, *.xyz , *.pts, *.csv) and PLY (*. ply). The LiData is the proprietary point cloud
data format, on which the point cloud processing are based. Other imported formats of LAS, ASCII and PLY
will be converted to LiData for subsequent processing. This function is the same as the tool  Add Data.
Remove All: Remove all the point cloud data from the project.

Data Context Menu

The user can open this menu by right clicking a point cloud data object.

Info: View the basic information of point cloud data as shown below. Click the Export button to export the
information as a *.txt file.

View Mode: Select the display mode of point cloud data between the following types.



Display by Height: The interface is shown as follows. The value range of display can be stretched by
minimum/maximum or standard deviation in order to improve the visual effects.

The curve can be saved in *.pdf format. Click the button "Save Curve" to pop up the following interface.
Set the width, height, resolution, output path of the curve and click "OK" button to save the curve to local
disk.

The visual effects are consistent with the tool  Display by Elevation.

Display by Intensity: The interface is shown as follows. The value range of display can be stretched by
minimum/maximum or standard deviation in order to improve the visual effects.



The curve can be saved in *.pdf format. Click the button "Save Curve" to pop up the following interface.
Set the width, height, resolution, output path of the curve and click "OK" button to save the curve to local
disk.

The visual effects are consistent with the tool  Display by Intensity.

Display by Class: This function is the same as the tool  Display by Class.
Display by RGB: This function is the same as the tool  Display by RGB.
Display by Return: This function is the same as the tool  Display by Return.
Display by Time: This function is the same as the tool  Display by Time.
Display by TreeID: This function is the same as the tool  Display by TreeID.
Display by Selected: Select user-defined color to display the point cloud data. The interface and the
visual effects are shown below.



Display by Blend: This function is the same as the tool  Display by Blend.

Display by Mix: This function is the same as the tool  Display by Mix.
Zoom to Layer: Calculate the bounding box of the current point cloud data. All the windows, in which the
data object is loaded, will show full extent of the bounding box.
Restatistics: Recalculate the Mean Z, Std Z, Mean Intensity and Std Intensity of point cloud data. This
function is used to repair older versions of LiData which may contain incomplete information.
Export: Export the point cloud data to LAS (*.las, *.laz), ASCII (*.txt, *.asc, *.neu, *.xyz, *.pts, *.csv) and PLY
(*.ply) format. This function is the same as the tool  Export.
PCV: Process the point cloud data with PCV to improve the visual effects.
Point Size: The point size of each point cloud data object can be set separately or set uniformly according to
the global settings. The shape of points can be set to circle or square. The interface is shown as follows.



For global point size settings, see the usage of the tool  Configure Point Size.
Remove: Remove the selected point cloud data from the current project. This function is the same as the
tool  Remove.

Settings

Display by Height:
Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum
pixel values, with the minimum and maximum pixel values as the endpoints for the histogram. For
example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values over
the entire histogram range, the brightness and contrast of the image are increased and features in
the image are easier to distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n)
value. For example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. If the value of standard deviation (n) is defined as 2, then the values beyond 2
standard deviation become 0 or 255, the remaining values stretch between 0 and 255.

Display by Intensity:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum
pixel values, with the minimum and maximum pixel values as the endpoints for the histogram. For
example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values over
the entire histogram range, the brightness and contrast of the image are increased and features in
the image are easier to distinguish.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n)
value. For example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. If the value of standard deviation (n) is defined as 2, then the values beyond 2
standard deviation become 0 or 255, the remaining values stretch between 0 and 255.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.

Point Size:



Circular Points (Optional): Set the shape of the point to circle or square.
Specified set (Optional): Set the point size of the specified point cloud data separately.
Use global set (Optional): Set the point size of the specified point cloud data with global settings.



Raster Context Menu

Brief

The context menus are used to for data import, removal, query, display, etc.

Data Type Context Menu

The user can open this menu by right clicking the raster data type.

Import Data: The raster data formats supported by LiPowerline include TIF and JPG. The function is the
same as the tool  Add Data.
Remove All: Remove all the raster data from the project.

Data Context Menu

The user can open this menu by right clicking a raster data object.

Info: View the basic information of raster data, including file path, description, X size, Y size, bands count,
pixel size, invalid value of each band, projection, etc. The interface is shown below.

Histogram: View the histogram of the raster data, where the values of each band can be stretched
separately. The raster data is displayed in gray color bar by default. Select an appropriate color bar in the
combo box. Click the button "Apply", the raster data in the scene will be rendered according to the above
settings, as shown below.



Select the stretch method and generate the corresponding histogram, as shown below.

The button "Default" is used to restore the default settings. The button "Recompute Histogram" is used to
calculate all the pixel values of the raster data again. The sampling points are 250000 by default. When the
pixel size of the raster data exceeds the value, the statistical results may be inaccurate, then this button is
needed. The histogram can be saved in *.pdf format. Click the button "Save Histogram" to pop up the
following interface. Set the width, height, resolution, output path of the histogram and click "OK" button to
save the result to local disk.



Zoom to Layer: Calculate the bounding box of the current raster data. All the windows, in which the data
object is loaded, will show full extent of the bounding box.

Zoom to Native Resolution (100%): Display the raster data in 1:1 ratio according to the resolution of the
raster data.
Remove: Remove the selected raster data from the current project. This function is the same as the tool 
Remove.

Settings

Histogram:
Stretch: The stretch methods of the histogram.

Minimum and Maximum (Default): Apply a linear stretch based on the minimum and maximum
pixel values, with the minimum and maximum pixel values as the endpoints for the histogram. For
example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. The values can be stretched linearly between 0 and 255. Distributing pixel values over
the entire histogram range, the brightness and contrast of the image are increased and features in
the image are easier to distinguish.
Percent Clip: Apply a linear stretch between the pixel values defined by percent clip minimum and
percent clip maximum. For example, the minimum and maximum pixel values of the image could be
2488 and 2656 respectively. Percent clip minimum and percent clip maximum values are 0.02 and
0.98, values less than 0.02 mean the values between 2488 and 2492, values more than 0.98 mean
the values between 2652 and 2656, values between 2488 and 2492 become 0, values between
2652 and 2656 become 255, the remaining values are between 0 and 255.
Std deviation: Apply a linear stretch between the pixel values defined by the std deviation (n)
value. For example, the minimum and maximum pixel values of the image could be 2488 and 2656
respectively. If the value of standard deviation (n) is defined as 2, then the values beyond 2
standard deviation become 0 or 255, the remaining values stretch between 0 and 255.
Histogram Equalization: Apply a non-linear stretch between the pixel values, redistribute the pixel
values so that the pixel values in a certain range is approximately equal. This method works well
when there are a lot of pixel values that are closely grouped together.



Color Bar: The colorbar supports several uniformly varying color intervals for color mapping.
BandList: Select a band from the band list to draw the histogram.
Show all bands (Optional): Whether to show all bands.

Save Curve:
Width: The width of the saved curve.
Height: The height of the saved curve.
Resolution: The resolution of the saved curve.
Output path: The output path of the saved curve.



Vector Context Menu

Brief

The right button menu of vector data in the layer management tree mainly includes import and export vector data,
it also contains information, show attribute table, zoom to layer, color by elevation, and display by selected for
single vector data.

Data Type Context Menu

Import Data: The import data format is SHP (*.shp), the same with the function , see Add Data. Import
vector data generate by Point Cloud to Contour) , as shown below:

Remove All: Remove all vector data from LiPowerline.

Data Context Menu

Info: View the basic information of vector file, including file path, elements count and bounding box.

Open Attribute Table:Displays the property sheet information of the vector data. The result is shown in the



figure:

Zoom to Layer: Calculates the bounding box of the current vector data, and all windows that contains this
file will display globally in this bounding box range.
Color by Elevation: Display the vector data by z value based on selected color bar.
Display by Selected: Display the vector data in fixed color, as shown in the following figure:



Remove: Remove vector file from LiPowerline.

Note: Except "Import Data", the other function in context menu work on all windows that contains this
vector file.



Tables Context Menu

Brief

The right button menu of table data in the layer management tree mainly includes import and export table data, it
also contains information, attribute, zoom to layer, and removal for single model data.

Data Type Context Menu

Import Data: The import data format is CSV（*.csv）. If click this function, pop-up the dialog, select data
type as "Point" or "Circle", and set the specified field X, Y, Z, Diameter (if the data type is circle), and check
whether to show labels.

Select data type as "Point", the table file displayed as below:



Select data type as "Circle", the table file displayed as below:



Remove All: Remove all table files from LiPowerline.

Data Context Menu

Info: View the table's basic information, including path, the number of elements, the minimum and the
maximum of X, Y, Z values.

Attribute: Display the contents of the table. As shown in the following figure, double click specific row, the
window will go to the position.



Zoom to Layer: Calculates the bounding box of the current table data, and all windows that contains this file
will display globally in this bounding box range.
Remove: Remove the selected file from LiPowerline.

Note: Except "Import Data", the other function in context menu work on all windows that contains this table
file.



Model Context Menu

Brief

The right button menu of model data in the layer management tree mainly includes import and export table data,
it also contains information, display setting, zoom to layer, restatistics, export for single model data.

Data Type Context Menu

Import Data: The model formats that LiPowerline supported includes: Model (.LiTin), LiModel (.LiModel)、
OSG data (.osgb, .ive, .desc, .obj). Among them, the LiTIN format and LiModel format are LiPowerline

defined model format. This function is the same with the function  , see Add Data.
Remove All: Remove all model files from LiPowerline.

Data Context Menu

Info: View the basic information of model file, including the path, resolution, the minimum and maximum of X,
Y, Z. This function just for LiTin and LiModel file.

View Mode: Set the model file's display mode, including display by elevation, display by texture, display by
light. if select "Display by Elevation", pop-up the selection of color bar dialog, the display effect as below:



The user can [generate models with texture](../DataManagement/Conversion/ConverttoTextureLiModel.md).
An example of "Display by Texture" is shown below:



if select "Display by Lighting", pop-up the selection of color bar dialog, the display effect as below:



Zoom to Layer: Calculates the bounding box of the current model data, and all windows that contains this
file will display globally in this bounding box range.
ReStatistics: Recalculate basic information such as Min X Y Z and Max X Y Z. In general, if you edit the
LiModel data, such as smooth height or repair height, you can use the Restatistics function.
Export: This function is only for LiTin and LiModel file, and the export format is TIF. In General, after 3D
visualization editing of LiModel and LiTIN which generated by DEM, it is necessary to convert the editing files
to TIF format file.
Remove: Remove the selected model data from viewer window or project.

Note: Except "Import Data", the other function in context menu work on all windows that contains this
model file.



Window Management

Brief

The project windows manage all windows(i.e. viewers) and data in windows. The user can remove data from
window, edit display order by dragging data node, show/hide data in specified window by checking/unchecking
the box before window/data node. The context menu(i.e. right-click menu) of data node, which differs depending
on data types, is mainly used for data query, display, statistics, export, and removal, etc. These functions are
effective on specified window.

Click the  button to show the project windows as follows:

Context Menu

Open the context menu by right clicking window or data.

Window Context Menu

Remove All: Remove all data from the selected window.

Data Context Menu

Point Cloud Data Context Menu: Same as the context menu of point cloud data in layer tree.
Raster Data Context Menu: Same as the context menu of raster data in layer tree.
Vector Data Context Menu: Same as the context menu of vector data in layer tree.
Table Data Context Menu: Same as the context menu of table data in layer tree.
Model Data Context Menu: Same as the context menu of model data in layer tree.



Note: The context menu of window management is only effective on specified window, while the context
menu of layer management is effective on all windows.



Viewers
This menu provides operations to create, close and arrange windows.

Tile Windows

Cascade Windows

New Window

Close

Close All



Tile Windows
Brief: Rearrange all the viewers in tiled fashion.

Steps

1. Click the menu Viewers > Tile Windows. The result is as follows.

Note: This function needs at least one window in the current project.



Cascade Windows
Brief: Rearrange all the viewers in cascaded fashion.

Steps

1. Click the menu Viewers > Cascade Windows. The result is as follows.

Note: This function needs at least one window in the current project.



New Window
Brief：Create new window in the current project.

Steps

1. Click the menu Viewers > Add Window. The result is as follows.

Shortcut Key：Ctrl+F3



Close
Brief: Close the active window in the current project.

Steps

1. Click the menu Viewers > Close. The active window will be closed.

Shortcut Key：Ctrl+F4



Close All
Brief: Close all windows in the current project.

Steps

1. Click the menu Viewers > Close All. All windows are closed.



Display
Display menu of the software.

Render to File

Save to Video

Auto Calculate Center

Camera Roam

Display Options

Camera Settings

Class Setting Options

Language

Theme

Default Theme

Gray Theme

Dark Theme

Show Legend

Show Coordinate Axis

Show Model

Show Triangle

Show Point

Shaders

EDL

Glass

Reset All GUI Element Positions

Reset Default Element Positions



Render to File
Brief: This tool can render the current 3D view as an image file (*.bmp format is supported). The user can also
change the zoom factor, which affects the final image size.

Steps

1. Adjust the 3D view to get the scene you want to render.
2. Click Display > Render to File and you will get a dialog shown as follows.

3. (Optional) Set the zoom factor.
4. (Optional) Check or uncheck the "Don't scale features (points size)" according to demand.
5. (Optional) Set the Output path.
6. Click "OK" to get the rendered image.

Settings

Input: Current active window.
Zoom: Default value is 1 (original image size). You can increase the rendered image size by setting larger
zoom factor (the resulting size is displayed on the right).
Don't scale features (points size): By default unchecked. If it is checked, the rendered point size won't be
increased, even if the zoom factor is greater than 1.
Output path: The file path to which the image will be saved.



Save To Video
Brief: Record the current window screen and save as video (mp4 and avi formats are supported).

Steps

1. Click Display > Save To Video, an interface will show as follows.

2. Set the frame rate(default is 25 frame per second).
3. Set the bit rate.
4. Set the output path of video.
5. Click "OK". The following interface is shown on the left-top corner of the current window.

6. Change the camera to get the scene which you want to record.
7. Click "Stop" or "Start"

Stop：Pause the current record.
Start：Recover the record.

8. Click "End" to finish recording. The video will be saved.

Settings

Input: the scene of the window for record.
Frame Rate: The frequency (rate) at which consecutive images called frames appear on a display.
Bit Rate: Refers to the number of bits used per unit of playback time to represent the video. Lower bit rate
may result in lower resolution of the picture and has mosaics on the picture, and however the higher bit rate
may lead a larger video file.
Output path: The file path to which the video will be saved.



Auto Calculate Center
Brief: The control of automatically calibrated the scene camera view center to exist point in the scene while
scene navigation of current window.

Steps

1. Click Display > Auto Calculate Center to make it unchecked. This will lead the 3D visualization window to
calculate the scene center purely based on the movements of the mouse. This means when the point cloud
was dragged to move at the direction perpendicular to the visual direction, LiPowerline will not consider
whether the scene center is linked to an actual point within the point cloud.



Camera Roam
Brief: This function can control the scene camera to navigate through a roam path. Two types of roam path are
supported including roam path based on viewport and roam path based on POS file. This function can also
generate immersive video if cooperated with Save to Video function.

Steps

1. Click Disply > Camera Roam to open Camera Roam Set dialog as bellow.

2. Choose mode as desired(Select "Roam by Viewports" or "Roam by Pos Path").

2.1 Roam by Viewports
Add Key Frame：Click this button to add current viewport as a key frame.
Delete Key Frame: Click this button to delete a key frame.
Load Key Frames from File: Click this button to import a key frame file.
Save Key Frames to File: Click this button to export all key frames to file.
Delete All Key Frames: Click this button to delete all key frames.

Select a key frame in the list: Scene camera will be adjusted to this key frame.
2.2 Roam by POS File

Check or uncheck "Show Path" as desired.
Set the Path Width, which will be activated when "Show Path" is checked.



Click Settings to open the following dialog.

Select a POS File: txt format only, each line of the file represents a key frame. The first three
columns are assumed to be XYZ. Column delimiters include comma, semicolon and space.
Set parameters: Including offset, time step, yaw, pitch, roll.
Click "Ok" to end the roam path setting.

3. Click "Start Roam" to begin roam through current path. After finished, the following dialog will show.

4. Click "Ok" to end the camera roam.
5. Click "Cancel" to exit this function.

Settings

Input: Viewport of current window or POS file.
Settings of Roam by POS file：

Path Width: Non negative integer only, defines the line width of POS trajectory in the viewer.
X/Y/Z Offset：The default value will be the offset of scene coordinate to the world coordinate system,
as POS data is in the world coordinate system.
Time Step: real number larger than 0.01 only, defines the time interval between key frames. The smaller
this value is, the slower the roaming speed is.



Yaw/Pitch/Roll：Local roam coordinate is defined that the orign is key frame center, the Y axis points to
the motion direction, the X axis is defined based on Y axis and world coordinate Z axis using right-hand
coordinate system principle, the Z axis is defined based on X axis and Y axis using right-hand
coordinate system principle. By default, the roam camera is towards -Z, the right of camera is +X, the
upper of camera is +Y. Yaw means spinning around +Z. Pitch means spinning around +X. Roll means
spinning around +Y.



Class Setting Option
Brief：The class setting of LiPowerline complies with the ASPRS standard. As show in the figure below, the
class 0-9 and 12 are fixed class type, the 10th, 11th, and 13th-31th class are reserved class. The fixed class can't
be modified, and the reserved classes are customizable. This function set the order of classes according to the
requirements and it will be displayed in order on the dialog and profile function.

Steps

1. Click Display > Class Setting Option, open the dialog (default list of classes):



class settings in the classification function interface are as shown in the following figure:



The class setting interface in the profile is shown in the following figure:



2. Select one class, click the button  to move down one step, click the button  to move to the bottom, click
the button  to up one step, click button  to move to the top; or mouse drag the class to a fixed position.



Taking Reserved15 class as an example, set the reserved15 as the highest priority, the class settings in the
classification function interface and the class setting interface in the profile are shown in the following figure:





3. Double click the class in the class list to setting the class's name. As shown below:

4. Click "Default" to restore the class setting option to default.
5. Click "OK" to save the current class setting list.



6. Click "Cancel" to cancel the current class priority setting and restore to the previous setting.



Language
Supported menu languages in LiPowerline are English and Chinese.

Steps

1. Click Display > Language > English/Chinese to switch menu language. It will be effective after software
restart.

2. Click Yes to restart the software immediately; Or click Cancel to restart later.



Theme
LiPowerline provides three GUI themes: Default Theme, Gray Theme, and Dark Theme.

Default Theme

Gray Theme

Dark Theme



Default Theme
Brief：Default Theme of the software GUI.

Steps

1. Click Displau > Theme > Default theme to activate the default theme:



Gray Theme
Brief：Gray Theme of the software GUI.

Steps

1. Click Display > Theme > Gray Theme to activate the gray theme:



Dark Theme
Brief：Dark Theme of the software GUI.

Steps

1. Click Display > Theme > Dark Theme to activate the dark theme:



Show Legend
Brief: Show/hide the legend in display windows.

Steps

1. Click Display > Show Legend to check/uncheck this option.
Display window without legend:

Display window with legend:



Show Coordinate Axis
Brief: Show/hide the coordinate axis in display windows.

Steps

1. Click Display > Show Coordinate Axis to check/uncheck this option.
Display window without axis:

Display window with axis:



Shader
The software currently offers two special shaders: EDL and Glass. They can be combined with other display
modes(such as display by elevation and display by intensity) to enhance display effect.

EDL

Glass



EDL Shader
Brief：The EDL shader can enhance the rendering effect of depth discontinuity. With this tool the user can
distinguish the foreground easily from the background .

The EDL effect can be enabled/disabled for individual display window. An example is shown below. The left
window displays point cloud data by elevation without EDL effect. The right window is with EDL effect.

Note: The EDL Shader is only applicable to point cloud data.

https://blog.kitware.com/eye-dome-lighting-a-non-photorealistic-shading-technique


Glass Shader
Brief: With the glass shader point cloud object appears translucent.

This effect can be enabled/disabled for individual display window. An example is shown as follows.

Note: The Glass Shader is only applicable to point cloud data.



Reset All GUI Elements Positions
Brief: All the GUI elements will be reset to the state when the software was closed last time.

Steps

1. Click the menu Display > Reset All GUI Elements Positions



Reset Default Elements Positions
Brief: The positions of all the windows and toolbars will be restored to the default state.

Steps

1. Before the elements are reset, the interface is as follows.

2. Click the menu Display > Reset Default Elements Positions and the result is shown below.



Data Management
This chapter introduces the basic tools commonly used for point cloud and raster data processing. Contents
include: point cloud tools, raster tools, clip tools, format conversion and data extraction.

Point Cloud Tools

Outlier Removal

Normalization

Normalization by Ground Class

Tile by Range

Tile by Point Number

Merge

Boundary

Subsampling

PCV

Define Projection

ReProjection

Extract Color from Image

Subdivision

Transformation

Raster Tools

Band Calculator

Raster Mosaic

Raster Subdivision

Clip

Clip by Circle

Clip by Rectangle

Clip by Polygon

Conversion

Convert to LiData

Convert to Las

Convert to ASCII

Convert to Raster



Convert to Shape

Convert to DXF

Convert Image to LiModel

Convert to Texture LiModel

Convert LiModel to Image

Convert Raster to ASCII

Extract

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by Time

Extract by Serial Time



Point Cloud Tools
The Point Cloud Tools include Outlier Removal, Normalization, Tile by Range, Tile by Point Number, Merge,
Boundary, Subsampling, PCV, Projection, Extract Color from Image, subdivision and Transformation.

Outlier Removal

Normalization

Normalization by Ground Class

Tile by Range

Tile by Point Number

Merge

Boundary

Subsampling

PCV

Define Projection

ReProject

Extract Color from Image

Subdivision

Transformation



Outlier Removal

Brief

Common noises include high level gross errors and low level gross errors. As shown below, high level gross error
is usually caused by the returns of high-flying objects (such as birds or aircraft) during the process of data
collection; low-level gross error are returns with extremely low attitudes caused by the multipath effect of a laser
pulse. The Outlier Removal tool aims to remove these errors as much as possible and therefore improve the data
quality.

The algorithm will first search for each point's neighboring points within a user-defined area and calculate the
average distance from the point to its neighboring points. Then, the mean and standard deviation of these
average distances for all points are calculated. If the average distance of a point to its neighbors is larger than
maximum distance (maximum distance = mean + n * standard deviation, where n is a user-defined multiple
number), it will be considered as an outlier and be removed from the original point cloud.

Effect picture:

Usage

Click Data Management > Point Cloud Tools > Outlier Removal



Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Neighbor Points (default value is "10"): The number of points required in the neighborhood to calculate
the average distance of each point. If there are not enough points found, the algorithm will not be executed.
Multiples of std deviation (default value is "5"): The factor multiplied by the standard deviation to
calculate the maximum distance.
Output path: Path of the output file. After the algorithm being executed, a new file will be generated. When
more than one files are entered, the path needs to be set to a folder.

Note: The algorithm can be performed repeatedly to improve the denoising results. The outlier removal
results is limited if the noises are to dense.



Normalization

Brief

The normalization tool can remove the influence of terrain relief on the elevation value of the point cloud data.
This function requires that the extent of the DEM overlaps with the extent of the point cloud data. The
normalization process is performed by subtracting the corresponding terrain elevation of the DEM from each
point's Z value. The output of this function is similar to Normalization by Ground Class.

Usage

Click Data Management > Point Cloud Tools > Normalization

Settings



Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Input DEM File: Users can select single or multiple single-band TIFF image files from the drop-down list. File
format: *.tif.

: Users can add external DEM file data.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Output path: Path of the output file. After the algorithm being executed, the new normalized file will be
generated. When entering more than one file, the path will need to be set as a folder.



Normalization by Ground Class

Brief

The normalization tool can remove the effects of topographic relief on the elevation value of point cloud data. This
function requires that the input data has already been classified into ground points and non-ground points. The
normalization process is performed by subtracting the terrain elevation (represented by the elevation of the closet
ground point to each point) from each point's Z value. The output of this function is similar to Normalization.

Usage

Click Data Management > Point Cloud Tools > Normalization by Ground Class

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Output path: Path of the output file. After the algorithm being executed, the normalized new file will be
generated. When entering more than one file, the path needs to be set as a folder.



Tile by Range

Brief

Tile by Range divides the point cloud into a series of small data files based on the user-defined width and length
of the small data file. This process begins from the lower-left corner of the input file's bounding box. The output of
this function is similar to Tile by Point Number.

Brief

Click Data Management > Point Cloud Tools > Tile by Range

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Width (default value is "500"): The width of the data block size, which is the length in the X-axis direction.
Height (default value is "500"): The length of the data block size, which is the length in the Y-axis direction.
Output path: Path of the output folder. After the algorithm being executed, new files will be generated.



Tile by Point Number

Brief

Tile by Point Number divides the point cloud into a series of small data files with a total of user-defined number
of points. This process begins from the lower-left corner of the input file's bounding box. The output of this
function is similar to Tile by Range.

Principle

The Point Number entered by the user will be recalculated according to the actual number of blocks in the actual
chunking process. The formula is as follows:

Among them,  is the number of tiles,  is the actual point number of a tile,  is the

total number of points in the original file, and is the user-defined point number.

Effect picture of tile:



Original point cloud data and point cloud data after chunking by point (different yellow bounding boxes represent
different point cloud data).

Usage

Click Data Management > Point Cloud Tools > Tile by Point Number

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Point Number (default value is "50000"): Set the number of points in each tile. Note that the actual number
of points in a tile may be slightly different from the user-defined number.
Output path: Path of the output folder. After the algorithm being executed, new files will be generated.



Merge

Brief

Merge multiple point cloud files into a single point cloud file. This function is the reverse operation of Tile by
Range and Tile by Point Number.

Usage

Click Data Management > Point Cloud Tools > Merge

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Output path: Path of the output folder. After the algorithm being executed, a new file will be generated.



Boundary

Brief

Use a regular hexagon to extract the boundary of a point cloud data. According to the Edge, determine the height
of each regular hexagon, and draw each hexagon based on the bounding box of the point cloud data. If the
number of points within a hexagon is greater than or equal to the user-defined Density value, this hexagon will
be kept and merged with its connected hexagons. The ultimate output file is the final border vector file.

Usage

Click Data Management > Point Cloud Tools > Boundary

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Edge (default value is "10"): The height of the hexagon, which is used to set the size of drowning a
hexagon.
Density (default value is "1"): The thresholding number of points in a hexagon, below which no hexagon
will be drawn.



Output path: Path of the output file. A new boundary vector file will be generated after the algorithm is
executed. File format: *.shp.



Subsampling

Brief

Subsampling point clouds, namely, reducing the number of point clouds, LiPowerline offers three methods for
resampling: minimum point spacing, sampling rate, and octree.

Usage

Click Data Management > Point Cloud Tools > Subsampling

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Sampling Type: This parameter defines the resampling method.

Minimum Points Spacing (default, default value is "0.0000"): Users need to set a minimum point
spacing between two points so that the minimum three-dimensional distance between any two points in
the sampled point cloud will not be less than this value. The larger the value is set, the fewer points will
be kept.
Sampling Rate (default value is "99.99%"): Users need to set the percentage of reserved points. In
this mode, LiPowerline will randomly retain the specified number of points. Reserved Points = Total
Number of Points * Sample Rate. The value of this parameter ranges from 0 to 100%. The smaller the
value is set, the fewer points will be kept.
Octree (default value is "21"): This method allows users to select an "octree" subdivision level and
build 3D voxels for the input point cloud. Only the point closest to each voxel center will be retained. The
"octree" subdivision level ranges from 1 to 21. The smaller the value is set, the fewer points will be kept.

Output path: Path of the output file. New file will be generated after the algorithm being executed.



PCV

Brief

PCV tool can be used to improve visualization effect of a point cloud. The principle of the PCV (Portion of Visible
Sky) algorithm is to evenly distribute multiple light sources at the top of the hemisphere or sphere calculate, and
then calculate the cumulative number of times when the light can be irradiated by illuminating each point in a
point cloud. The last statistical result will be used as the intensity of the point cloud. The rendering effect of the
point cloud intensity after PCV calculation is shown in the figure below.

Usage

Click Data Management > Point Cloud Tools > PCV

Select the point cloud data that needs to be processed by PCV.



After the PCV process, the intensity range of a point cloud will be 0-255. By clicking on display by intensity
or clicking display by the mixed mode, users can see the boundary between different land covers more
clearly in the point cloud after PCV process. The figure below shows an example of intensity and height
blend displaying effect after PCV calculation.



Define Projection

Brief

Define projection information for point cloud data, including geographic coordinates (usually latitude and longitude
coordinates) and projection coordinates (plane coordinates converted by projection).

Usage

Click Data Management > Point Cloud Tools > Define Projection

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File format: *.LiData.

Filter: Users need to enter the customized coordinate system. By entering the coordinate system keywords,
the corresponding coordinate system can be filtered from the Coordinate reference systems of the world
table (for example: to set the point cloud coordinate system to WGS 84 / UTM Zone 49N, users can enter
UTM 49N in the filter for fast screening, or enter its EPSG number: 32649 for quick search.) Users can also
import external coordinate system settings by clicking the Add Coordinate System button.

Add Coordinate System: Users can add external coordinate system settings or customize coordinate
system settings. LiPowerline software provides four ways to add external coordinate system:

Import from WKT
Import from PRJ
Add Geographic Coordinate System



Add Projected Coordinate System
Hide deprecated CRSs: Hide deprecated coordinate systems.

Import from WKT

WKT format can refer to the following way:

    GEOGCS[
        "GCS_Beijing_1954"
      ,DATUM["D_Beijing_1954",SPHEROID["Krasovsky_1940",6378245.0,298.3]]
        ,PRIMEM["Greenwich",0.0]
        ,UNIT["Degree",0.0174532925199433]
        ,AUTHORITY["EPSG",4214]
    ]

    PROJCS[
        "MyProjCS"
        ,GEOGCS["WGS84",DATUM["WGS_1984",SPHEROID["WGS84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],TOWGS84[0,0
,0,0,0,0,0],AUTHORITY["EPSG","6326"]]
        ,PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]]
        ,UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9108"]]
        ,AUTHORITY["EPSG","4326"]]
        ,PROJECTION["Transverse_Mercator"]
        ,PARAMETER["latitude_of_origin",0]
        ,PARAMETER["central_meridian",-81],PARAMETER["scale_factor",0.9996]
        ,PARAMETER["false_easting",500000]
        ,PARAMETER["false_northing",0]
        ,UNIT["Meter",1]
    ]

Import from PRJ

PRJ format can refer to the following way:

    +proj=longlat +ellps=aust_SA +towgs84=-117.808,-51.536,137.784,0.303,0.446,0.234,-0.29 +no_defs

Add Geographic Coordinate System

http://spatialreference.org/ref/epsg/32650/
http://proj4.org/usage/quickstart.html


Name: Users can customize a geographic coordinate system name.
Datum:

Name: Users can customize a datum name or select a known datum from the drop-down list.
Spheroid: If a user selects the datum from the drop-down list, the ellipsoid parameter does not require
user to enter.

Name: The name of the spheroid.
Semimajor Axis: Spheroid's major semiaxes.
Inverse Flattening: Inverse flattening of the spheroid.

Angular Unit:
Name: Users can customize the angle unit name, or select the angle unit name from the drop-down list.
Radians Per Unit: Define the unit of arc in the geographic coordinate system.

Prime Meridian:
Name: Users can customize the name of the central meridian, or select the name of the central meridian
from the drop-down list.
Longitude: Input the central meridian longitude.

Add Projected Coordinate System

Name: Users can customize the name of a projection coordinate system.
Projection:

Name: Users can customize a projection name or select a known projection from the drop-down list. It
should be noted that user-defined projections can be modified from a projection template selected from
the drop-down list. Linear units:

Linear Unit:
Name: Users can customize the linear unit name or select the linear unit name from the drop-down list.
Meters per Unit: Input meters per unit.
Geographic Coordinate System: Users can paste the geographic coordinate system parameters into
the text box, or click Change.

Change



When the user clicks on the Modify button, the following dialog box will pop up for modifying the geographic
coordinate system.

The user can filter out the needed coordinate system through the filter operation, or can also add the geographic
coordinate system through the New Geographic Coordinate System and the setting method is the same as
Add Geographic Coordinate System.



Reproject

Brief

The point cloud can be converted by projection, including the conversion between geographic coordinate system
and projected coordinate system. When different geographic coordinate systems are converted to each other,
due to the differences between the ellipsoid used and the reference plane, it will involve the conversion between
ellipsoids. LiPowerline provides the seven-parameter transformation model. Select the "using the seven-
parameters" option and click the "Seven Parameters Setting" button. The user can enter the values for X-
translation, Y-translation, Z-translation, X-axis rotation, Y-axis rotation, Z-axis rotation, and scale values for
seven-parameter transformation.

Usage

Click Data Management > Point Cloud Tools > Reproject

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Use Seven Parameters: User decides whether to use seven parameters for re-projection, if checked, seven
parameters will be used.



Seven Parameters Setting: Select the Use Seven Parameters option, click the Seven Parameters Setting
button, and the Seven Parameters Dialog will pop up. Click  to fill the seven-parameter values by opening
a txt file; click  to save the set value as a txt file; click  to clear the entered value.

X (m): The X translation in seven parameters.
Y (m): The Y translation in seven parameters.
Z (m): The Z translation in seven parameters.
Rx (''): The X-axis rotation in seven parameters.
Ry (''): The Y-axis rotation in seven parameters.
Rz (''): The Z-axis rotation in seven parameters.
λ (ppm): The zoom scale in seven parameters.

Filtering: Users needs to input the customized coordinate system. By entering the coordinate system
keywords, the corresponding coordinate system can be filtered from the Coordinate reference systems of
the world table (for example: to set the point cloud coordinate system to WGS 84 / UTM Zone 49N, users
can enter UTM 49N in the filter for fast screening, or enter its EPSG number 32649 for quick search.) Users
can also import external coordinate system by clicking the Add Coordinate System button.
Add coordinate systems: For details, refer to Define Projection Parameter Settings.
Hide deprecated CRSs: Hide deprecated coordinate systems.
Output path: Path of the output file. New files will be generated after the algorithm is executed.

Note: The reprojected point cloud must already have projection information. To check whether the current
point cloud has projection information, users can select the data in the data list and its projection
information will be displayed in the current file coordinate system.



Extract Color from Image

Brief

Extract Color from Image tool can extract RGB information from multi-band imagery and assigned them to each
point in a point cloud. The user is required to enter one or more multi-band images that overlapping with the
extend of the point cloud data.

After the process is completed, the display mode of the point cloud data will automatically change to RGB display
(you can also click  on the toolbar Button, to display the point cloud in RGB).

Usage

Click Data Management > Point Cloud Tools > Extract Color from Image

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Input File: The user needs to enter one or more multi-band images that are geographically overlapping with
the point cloud data. If the image data has already been opened in the software, click the drop-down button
to select the data, or you can click  to open the external image data. Click  to remove selected
images from the list and click  to clear the image data list. File format: *.tif.



Subdivision

Brief

Subdivision tool can divide a point cloud to a series of frames based on the user defined scales. Currently,
LiPowerline supports four subdivision scales: a scale of 1:5000 (taken to 1 km), 1:2000 (taken to 0.1 km), 1:1000
(taken to 0.1 km), and 1:500 (taken to 0.01km). Moreover, only subdivision in rectangular is supported currently.
The frame ID will be named by the coordinate number, which is composed of the southwest corner of the frame
(Y coordinate + X coordinate). After the operation is completed, a vector file will be generated in shp format
recording each subdivided frame.

Usage

Click Data Management > Point Cloud Tools > Subdivision

Settings

Input LiData File: Input the point cloud data to be subdivided. If the point cloud data is already open in the
software, click the drop-down button to select the data; or you can click  to open external point cloud
data. Click  to remove the selected data. Click  to clear the image data list. File format: *.LiData.
Scale: User-defined scale. LiPowerline has four scales: 1:500, 1:1000, 1:2000, 1:5000.
Output path: Path of the output folder. After the algorithm is executed, a new shp file will be generated.



Transformation

Brief

LiPowerline software supports multiple coordinate conversion methods. Users can select a conversion type to
perform point cloud data conversion according to their needs.

The four supported coordinate conversion methods are:

Linear
XYMultiply
Translate and Rotate
3D Affine

Steps

1. Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
2. Select the Transformation Type. The user selects the desired conversion type from the drop-down box and

sets the relevant parameters.
3. Output path: Path of the output folder. After the algorithm is executed, new files after transformation will be

generated.

Usage

Click Data Management > Point Cloud Tools > Transformation

Settings

Linear



The linear transformation is used to pan and zoom a point cloud. A panning and scaling parameter need to be set
to the X, Y, Z coordinates, respectively. The targeted coordinates are calculated using the following formula:

Among them: Sx, Sy, Sz are the scaling factors for the x, y, and z coordinates. Px, Py, and Pz are the panning
parameters for the x, y, and z coordinates. x, y, and z are the original coordinates, and X, Y, and Z are
coordinates obtained after the linear transformation.

XYMultiply

The target coordinates are calculated using the following formula:

Among them, Px, Py, Pz, a, b, c, d, e are the transformation parameters, Sx, Sy, Sz are the original coordinates,
and X, Y, Z are the transformed coordinates. This is often used as a 2D Helmert transformation.

Translate and Rotate



The target coordinates are calculated using the following formula:

R11、R12、R13、R21、R22、R23、R31、R32、R33 are calculated as follows:

R11 = cos( Ry ) * cos( Rz )

R21 = cos( Ry ) * sin( Rz )

R31 = -sin( Ry )

R12 = sin( Rx ) sin( Ry ) cos( Rz ) - cos( Rx ) * sin( Rz )

R22 = sin( Rx ） sin( Ry ) sin( Rz ) + cos( Rx ) * cos( Rz )

R32 = sin( Rx ) * cos( Ry )

R13 = cos( Rx ) sin( Ry ) cos( R_z ) + sin( Rx ) * sin( Rz )

R23 = cos( Rx ) sin( Ry ) sin( Rz ) - sin( Rx ) * cos( Rz )

R33 = cos( Rx )* cos( Ry )

λ (default value is "0"): Scale conversion factor applied to X, Y, Z.
Dx, Dy, Dz (default value is "0"): Panning values added to X, Y, Z.
Rx, Ry, Rz (default value is "0"): The angle of rotation about the X, Y, and Z axes in degrees.

Note: To achieve millimeter-level accuracy, there should be at least eight decimal places after the decimal
point.

3D Affine



The target coordinates are calculated using the following formula:

Dx, Dy, Dz (default value is "0"): Panning values added to X, Y, Z.
Mx, My, Mz (default value is "0"): Scale factor applied to the X, Y, and Z axes.
Rx, Ry, Rz (default value is "0"): The angle of rotation about the X, Y, and Z axes in degrees.

Note: To achieve millimeter-level accuracy, there should be at least eight decimal places in the user inputs.



Raster Tools
Raster tools include Band Calculation, Raster Mosaic, and Raster Subdivision.

Band Calculator

Raster Mosaic

Raster Subdivision



Band Calculator

Brief

Band Calculator tool can generate a new raster image based on a user-defined map algebra equation from two
single-band images.

Band operator functions and operators include: Basic operations: plus (+), minus (-), multiply (×), and divide (÷);
Trigonometric functions: sine sin(x), cosine cos(x), tangent tan(x), arcsine asin(x), arc cosine acos(x), arc tangent
atan(x); Other mathematical functions: natural exp(x), natural logarithm ln(x), logarithm to base a log(a, x), square
root sqrt(x), quadratic power Power2, cubic power Power3, round integer part, inverse

The band operation function can be applied to single or two raster images, and the input data must meet the
following conditions:

(1) The input data must be a single-band image;

(2) The input data must have the same spatial resolution;

(3) The spatial range of the input data must have intersections.

Usage

Click Data Management > Raster Tools > Band Calculator

Settings

Output path: Path of the output folder. After the algorithm is executed, a new file will be generated after the
band operation.



Raster Mosaic

Brief

Raster Mosaic refers to the technical process of merging two or more images to one image. LiPowerline
provides seven sampling methods: Nearest Neighbour, Bilinear, Cubic, CubicSpline, Lanczos, Average, and
Mode. It is the reverse operation of Raster Subdivision.

Usage

Click Data Management > Raster Tools > Raster Mosaic

Settings

Input Tiff File: Users can select multiple files (>1) to be processed from the drop-down list.
: Users can add multiple external images for image mosaic.
: Click this button to clear all images in the list.

Sample Type: Users need to select the sampling type from the drop-down list.
NearestNeighbour (default): Nearest neighbor, sampled from the nearest neighbor.
Bilinear: Bilinear sampling (2 x 2 cores).
Cubic: Cubic convolution approximation (4 x 4 kernels).
CubicSpline: Cubic B-spline approximation (4×4 kernel).
Lanczos: Lanczos Window Sine Interpolation (6×6 Cores). Lanczos can be used as a low pass filter or
to smoothly interpolate the value of a digital signal between its samples.
Average: Calculate the average of all non-value pixels.
Mode: Select the most frequently occurring value for all sampling points.

Output path: Path of the output folder. After the algorithm is executed, a new file will be generated.

https://en.wikipedia.org/wiki/Lanczos_resampling


Raster Subdivision

Brief

The raster subdivision tool is the inverse operation of raster mosaic. The frame number adapts the coordinate
number and consists of the southwest corner of the frame (Y coordinate + X coordinate). A scale of 1:5000 is
taken into 1 km, 1:2000 and 1:1000 to 0.1 km, and 1:500 to 0.01 km.

Usage

Click Data Management > Raster Tools > Raster Subdivision

Settings

Input File: Users can select the file to be processed from the drop-down list.
: Users can add external files that need to be processed.

Scale (default "1:500"): Users can select a targeted scale. LiPowerline has four scale options: 1:500,
1:1000, 1:2000, and 1:5000.
Output path: Path of the output folder. After the algorithm is executed, new subdivided files will be
generated.



Clip
The clipping tools include Clip by Circle, Clip by Rectangle and Clip by Polygon.

Clip by Circle

Clip by Rectangle

Clip by Polygon



Clip by Circle

Brief

Clip by circle tool extracts the point cloud data within user-defined circle(s), and the extracted points can be
saved in one or multiple files.

Usage

Click Data Management > Clip > Clip by Circle

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
X Coordinate (m): Enter the X coordinate of the circle center.
Y Coordinate (m): Enter the Y coordinate of the circle center.
Radius (m): Enter the radius of the circle.
Generate a File: Extract all the point cloud data within 2D circle(s) to one file.
Generate Multiple Files: Extract the point cloud data within each circle and save them to one individual file.
The file is named by its center and radius by default.

: Click this button to add the coordinates and radius of a circle to the processing list. Perform the same
operation to add multiple clipping circles.

: Click this button to load external data files. The file format refers to the Clip Range File Format in the
appendix.

: Click this button to remove the selected row(s) in the processing list.



Output path: The generated file will be saved in this output path.



Clip by Rectangle

Brief

Clip by rectangle tool extracts the point cloud data within user-defined rectangular(s), and the extracted points
can be saved in one or multiple files.

Usage

Click Data Management > Clip > Clip by Rectangle

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Y Maximum (m): Enter the maximum Y coordinate of the rectangle.
Y Minimum (m): Enter the minimum Y coordinate of the rectangle.
X Minimum (m): Enter the minimum X coordinate of the rectangle.
X Maximum (m): Enter the maximum X coordinate of the rectangle.
Generate a File: Extract all the point cloud data within the rectangle to a file.
Generate Multiple Files: Extract the point cloud data within each rectangle and save them to one file. The



file is named by the rectangle's lower left corner coordinate and the rectangle's width and height by default.
: Click this button to add the entered rectangle range to the processing list. Perform the same operation

to add multiple clipping regions.
: Click this button to load external data files. The file format refers to the Clip Range File Format in the

appendix.
: Click this button to remove the selected row(s) in the processing list.

Output Path: The generated file will be saved in this output path.



Clip by Polygon

Brief

Clip by polygon tool extracts the point cloud data within user-defined polygon vector file, and the extracted points
will be saved in one file.

Usage

Click Data Management > Clip > Clip by Polygon

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Shape File: Select the vector file loaded into LiPowerline software from the drop-down menu, or click the

button  to load the external vector data file.

Output Path: The generated file will be saved in this output path.

Note: The vector data file used to clip the point cloud data must be a polygon file (not point or line file), and
currently MultiPolygon files are not supported.



Conversion
Conversion Tools contain Convert to LiData, Convert to Las, Convert to ASCII, Convert to Raster, Convert
to Shape, Convert to DXF, Convert Image to LiModel, Convert to Texture LiModel, Convert LiModel to
Image, Convert Raster to ASCII.

Convert to LiData

Convert to Las

Convert to ASCII

Convert to Raster

Convert to Shape

Convert to DXF

Convert Image to LiModel

Convert to Texture LiModel

Convert LiModel to Image

Convert Raster to ASCII



Convert to LiData

Brief

Convert to LiData can convert point cloud data in LAS or LAZ formats to LiPowerline customized point cloud
format (LiData format).

Usage

Click Data Management > Conversion > Convert to LiData

Settings

File List: Import the file that needs to be converted. The file formats currently supported are : .las, .laz. Users
need to click  to select the point cloud data; users can select one or more file(s) in the existing list and
click  to delete them from the list; users can click  to remove all files in the list.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
Output Path: Path of the output folder. After the conversion is executed, the converted new file(s) will be
generated.



Convert to Las

Brief

Convert to Las can convert point clouds in LiData format to LAS format, namely the standard Lidar point cloud
data format.

Usage

Click Data Management > Conversion > Convert to Las

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
Output Path: Path of the output folder. After the conversion being executed, the converted new file(s) will be
generated.



Convert to ASCII

Brief

The Convert to ASCII tool can convert the LiData point cloud to ASCII format, a text format that can be easily
viewed in a text editor.

Usage

Click Data Management > Conversion > Convert to ASCII

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported. All Las attributes are
supported.
Export Format: LiPowerline supports two suffix formats: txt and csv, and support separators are: commas,
spaces and TAB.
Output path: Path of the output folder. After the conversion is executed, the converted new file(s) will be
generated.



Convert to Raster

Brief

The Convert to Raster tool can convert LiData point cloud data to raster images according to the Attribute of the
points in Cell Value method.

Usage

Click Data Management > Conversion > Convert to Raster

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
XSize (m, default value is "2"): The X pixel resolution of the output raster.
YSize (m, default value is "2"): The Y pixel resolution of the output raster.
Attribute (default is "Z"): Select the point attribute used to calculate the raster cell value.

Z (default): Generate the raster data using the Z value of the point cloud data.
Intensity: Generate raster data using the intensity values of the point cloud data.
Scan angle: Generate raster data using the scan angle of point cloud data.
Return number: Generate raster data using the return number of the point cloud data.
Number of returns of given pulse: Raster data is generated using the number of returns of given pulse
of the point cloud data.

Cell value: Choose how to fill raster pixel values.
Minimum (default): Use the smallest attribute value as the value of a raster cell.
Average: Use the average of attribute values of all points within a raster cell as its value.
Maximum: Use the largest attribute value as the value of a raster cell.

Merge files into one: Users can set merging all raster into one data file. If not checked, each point cloud
data will be generated into a separate raster file.
Output path: Path of output folder. After the algorithm is executed, the converted new file is generated.



Convert to Shape

Brief

The Convert to Shape tool can convert point cloud files in LiData format to point files in vector format.

Usage

Click Data Management > Conversion > Convert to Shape

Settings

Input data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
Attributes to Export: Users can select the attributes that need to be exported, and all Las attributes are
supported. The selected attributes will be written in the attributes of the shape file data.
Output path: Path of the output folder. After the conversion being executed, the converted new file will be
generated.



Convert to DXF

Brief

The Convert to DXF tool can convert LiData format point cloud files to point vector data in DXF format.
LiPowerline software exports DXF files in ASCII format.

Usage

Click Data Management > Conversion > Convert to DXF

Settings

Input Data: The input file can be a single point cloud data file or multiple data files. File Format: *.LiData.
From Class: Source class (es).
Tile: Since the amount of point cloud data is often large, the software provides an optional tile mode that can
split the input data file to a number of tiles.

No Tile: Export a single DXF file.
Tile by Rows and Columns: According to the boundary of the point cloud data, the point cloud will be
split into a total number of rows * columns data blocks evenly, and a single DXF file will be generated.

Rows (default value is "3"): User-defined number of rows that the point cloud want to be split into.
Columns (default value is "3"): User-defined number of columns that the point cloud want to be
split into.

Tile by Width and Height: The point cloud will be split into a number of tiles from the lower left corner
by the specified width and height, one DXF file per block.

Width (m, default value is "100"): User-defined block width.
Height (m, default value is "100"): User-defined block height.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s) will be



generated.



Convert Image to LiModel

Brief

Convert image to LiModel tool can convert single-band raster data (DEM, DSM, CHM, etc.) to LiModel format.
The LiModel format is a LiPowerline software customized format that allows the converted single-band raster
data to be displayed and edited in a 3D window.

Usage

Click Data Management > Conversion > Convert Image to LiMode

Settings

Input Tiff File: Users can select the file to be processed from the drop-down list.
: Users can add files to be converted that have not been opened.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all files in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s) will be
generated.



Convert to Texture LiModel

Brief

Convert to Textured LiModel tool is based on the Convert Image to LiModel tool, which maps color values of a
DOM data to the LiModel model for display. This function only supports single file data conversion.

Usage

Click Data Management > Conversion > Convert to Texture LiModel

Settings

Input DEM: Users can select a file to be converted from the drop-down list or use the button 

to load an external data file. Single-band raster data is required.

Input DOM: Users can select a desired file from the drop-down list or use the button  to load

an external data file. The selected color image needs to have at least three bands.
Output LiModel: Path of the output file. After the conversion being executed, the converted new file will be
generated.



Convert LiModel to Image

Brief

Convert LiModel to Image tool converts LiModel format files to raster images in TIFF format. After editing LiModel
data, users can use this function to convert the data to TIFF format.

Usage

Click Data Management > Conversion > Convert LiModel to Image

Settings

Input LiModel File: User can select a file to be processed from the drop-down list.
: Users can add external data files to be converted.
: Users can select a file in the list and click this button to remove the file from the list.
: Click this button to clear all the data in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file will be
generated.



Convert Raster to ASCII

Brief

Convert Raster to ASCII tool can be used to convert TIF format raster images to files in ASCII format.

Usage

Click Data Management > Conversion > Convert Raster to ASCII

Settings

Input Tiff File: Users can select the file to be processed from the drop-down list.
: Users can add external file(s) to be converted.
: Users can select one or files in the list and click this button to remove them from the list.
: Click this button to clear all files in the list.

Output path: Path of the output folder. After the conversion being executed, the converted new file(s) will be
generated.



Extract
Extraction tools include Extract by Class, Extract by Elevation, Extract by Intensity, Extract by Return,
Extract by Time, and Extract by Serial Time.

Extract by Class

Extract by Elevation

Extract by Intensity

Extract by Return

Extract by Time

Extract by Serial Time



Extract by Class

Brief

Extract by class tool can extract all the point cloud data of the user-selected class, and save the data in one file.
This function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Class

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
From Class: Users need to select the class to be extracted from the drop-down list. The unavailable status
in the drop-down list represent the corresponding category that does not exist in the file.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.



Extract by Elevation

Brief

Extract by Elevation tool can extract the point cloud data in the user-defined elevation range to a file. This
function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Elevation S

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (m, default value is "100"): Users need to enter the minimum elevation value of the point cloud data to
be extracted.
Max (m, default value is "200"): Users need to enter the maximum elevation value of the point cloud data
to be extracted.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.



Extract by Intensity

Brief

Extract by Intensity tool can extract all the point cloud data within the user-defined intensity range. This function
supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Intensity

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Min (default value is "100"): Users need to enter the minimum intensity value of the point cloud data to be
extracted.
Max (default value is "200"): Users need to enter the maximum intensity value of the point cloud data to be
extracted.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.



Extract by Return

Brief

Extract by Return tool can extract all the point cloud data of the user-defined return number, and saved the data
in a file. This function supports multiple file operations.

Usage

Click Data Management > Extract > Extract by Return

Settings

Input Data: Input one or more point cloud data files. File Format: *.LiData.
Return number: Users need to select the return number of the point cloud data to be extracted. Click on the
drop-down menu to select the return number, including: first return, last return, 2nd return, 3rd return, 4th
return, and returns after 4th.
Output path: Path of the output folder. After the algorithm being executed, the extracted new file(s) will be
generated.

Note: If the data does not have the return number selected by the user, the extraction will not be executed.



Extract by Time

Brief

Extract by GPS time tool can extract all the point cloud data within the user-defined GPS time range, and save
them in a file.

Usage

Click Data Management > Extract > Extract by Time

Settings

File List: Select the file to be processed from the drop-down list.
Min Time: Displays the minimum GPS time value in the point cloud file selected by the user. This value does
not require user settings.
Max Time: Displays the maximum GPS time value in the point cloud file selected by the user. This value
does not require user settings.
Start Time (default value is "min Time"): Input the minimum GPS time value of the point cloud data to be
extracted.
End Time (default value is "max Time"): Input the maximum GPS time value of the point cloud data to be
extracted. This value must be larger than the start time.

: If you want to extract the point cloud at a specified interval, enter the interval value in the text box, and
then click this button, the values of the start time and end time will increase at the set interval.

: Add the input time range to the range list. All point cloud data in the time range will be extracted into
one file.

: Users can click this button to load external GPS range file. The time range in the file needs to be
between the min Time and the max Time. The file format can be referred to the appendix for information in
the GPS time file format.

: Users select a row in the time range list and click this button to remove the row from the list.
Output Path: Path of the output folder. After the algorithm being executed, the extracted new file will be
generated.



Extract by Serial Time

Summary

Extract by Serial Time tool helps the user to extract the points in customized GPS time period and save them to a
separate file.

Usage

Click Data Management > Extract > Extract by Serial Time.

Settings

File List: Select the file to be processed from the file list.
File List Filter: Automatically select files to be processed based on the fields entered by the user.
Min Time: Display the minimum GPS time value in the point cloud file selected by the user. This value does
not require user settings.
Max Time: Display the maximum GPS time value in the point cloud file selected by the user. This value does
not require user settings.
Start Time (default value is "Min Time"): Input the minimum GPS time value of the point cloud data to be
extracted.
End Time (default value is "Max Time"): Input the maximum GPS time value of the point cloud data to be
extracted.
Output Path: The path of the output file.



Classify
LiPowerline can be used to classify unclassified point cloud, or to reclassify points that have already been
classified.

Classify Ground Points

Extract Median Ground Points

Classify by Attribute

Classify Low Points

Classify by Below Surface

Classify Isolated Points

Classify Air Points

Classify by Height Above Ground

Classify by Min Elevation

Classify Buildings

Classify Power Line

Classify Model Key Points



Classify Ground Points

Brief

Ground points classification is an important operation of point cloud preprocessing, which can be implemented in
LiPowerline with an improved progressive TIN densification filtering algorithm (Zhao et al.,2016).

The algorithm first generates a sparse triangulated irregular network(TIN) through seed points, and then
iteratively processes layer-by-layer densification until all ground points have been classified. The specific steps of
the algorithm are described as follows:

1. The initial seed point selection. If the point cloud contains buildings, the maximum building size is taken as
the grid size to grid the point cloud, and for the point cloud without the building, the default value is used as
the grid size. Take the lowest point in the grid as the starting seed point.

2. Build a TIN. The initial TIN was constructed using the initial seed point.
3. Iterative densification process. Traverse all the unclassified points, query the triangles that each point

belongs to in the horizontal projection plane; Calculate the distance(d) from the point to the triangle and the
max angle between the point and three vertices with the triangles plane. As shown in the figure below, the
distance and max angle are compared with the Iteration distance and Iteration angle, separately. If it is
less than the corresponding threshold, then the point is classified as a ground point and added to the
triangulation. Repeat this process until all ground points have been classified.

The flow of algorithm is shown in the figure.



Usage

Click Classify > Classify Ground Points



Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Max Building Size (m, default value is "20"): The maximum length of the building edge that exists in the
point cloud scan. If this parameter is set too small, the flat roof of the building may be mistaken as the terrain.
When there is a building in the point cloud data, the maximum building size can be measured by using the
Length Measurement in the menu bar. The value of this parameter should be greater than the measured
value. For point cloud data without buildings, this parameter can use the default value of 20m.
Max Terrain Angle (°, default value is "88"): The maximum slope of the terrain shown in the point cloud.
This parameter can determine whether the points nearby the ground points belong to the ground or not.
Usually, the parameter can be set as default.
Iteration Angle (°, default value is "30"): The allowable range of angles between unclassified points and
ground points. For areas with large topography and undulations, it can be bigger.Generally, it is set between
10 to 30 degrees. In addition, the iteration angle should adjust with the iteration distance.
Iteration Distance (m, default value is "1.6"): Distance threshold between the unclassified points and the
triangle in the triangle mesh. When the topography is highly undulating, it should be set to a larger value. The
general setting is 1~2 meters.In addition, the iteration distance should adjust with the iteration angle.
Reduce Iteration Angle When Edge Length < (m, default value is "5", Optional): When the triangle
length of the points to be classified is smaller than the threshold, the iteration angle should be decreased.
Use the parameter to indicate that when the point to be classified corresponds to the length of the triangle in
the triangulation network is less than the threshold, the iteration angle is reduced accordingly. When a
sparse ground point needs to be obtained, the threshold may be increased accordingly.
Stop Triangulation When Edge Length < (m, default value is "1", Optional): When the triangle length of
the point to be classified corresponds to the length of the triangle is less than the threshold, the densification
of triangulation network is stopped. This value can prevent the locally generated ground point from being too
dense. When this value increase, the ground points will be sparse, and vice versa.
Only Key Points (Optional): Extract key points of terrain model on the basis of ground point filtering. This
function can preserve the key points on the terrain and sparse the points on the flat area. For the specific
usage, please see Classify Model Key Points.

Note: Because the actual terrain is complex and changeable, when using this function to perform ground
point classification, different parameters needs to be adjusted in order to achieve relatively ideal results. In
addition, the classification result in local area can be reclassified by Classify Ground by Selected and the
Classify by Interactive Editing tool.

    @inproceedings{
        author={Zhao X Q, Guo Q H, Su Y J and Xue B L},
        title={Improved progressive TIN densification filtering algorithm for airborne LiDAR data in forested areas},
        booktitle={ISPRS Journal of Photogrammetry and Remote Sensing,117:79-91},
        year={2016}
    }



Extract Median Ground Points

Brief

Generally, the point cloud data scanned by small aircrafts and unmanned aerial vehicles (UAV) has a higher
density and a thicker ground point. If use the traditional filtering methods for large aircraft obtained point cloud,
the extracted ground points are thicker and the TIN is uneven. However,the median ground method can obtain a
thinner and smoother ground point in the middle of a thicker ground point. This method belongs to the
optimization step after the initial ground point has been extracted. Therefore, the point cloud data must
first be classified using ground point classification method. The comparison results before and after using
the median ground point classification method are as follows.

Usage

Click Classify > Extract Median Ground Points

Settings



Input Data: The input file can be a single point cloud data or a point cloud dataset, which must has already
been classified by ground points and been opened in the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Min Height (m, default value is"0.02"): A certain height difference from the lowest point on the ground is
set as the starting elevation. The 0.02 represents the minimum height from the lowest point elevation of 0.02
meters is the minimum elevation.
Max Height (m, default value is"0.3"): A certain height difference from the lowest point on the ground is set
as the termination elevation. The 0.3 represents 0.3 meters from the lowest elevation of 0.3 meters is the
maximum elevation.
Grid Size (m, default value is"0.5"): The grid is used as a unit when extracting ground points. When the
number of points in the grid is less than a threshold, the grid will not further be involved in ground point
extraction. Therefore, this method is only applicable to the ground points that are thicker and have higher
density of point clouds.
Multiples of std deviation (default value is"0.3"): The number and thickness of the extracted point cloud
ground points are controlled by setting the multiple of standard deviation. The default value is 0.3, which
means that 22% of ground points are extracted as ground points (similarily, 0.5 corresponds to 40%, 0, 7
corresponds to 50%, 0.9 corresponds to 62%, and 1.5 corresponds to 86%).
DefaultValue: Click this button to set all parameters as default.

Note: This classification algorithm is only applicable to thicker ground point data scanned by small aircrafts
and unmanned aerial vehicles (UAVs), and the data needs to be classified by ground points firstly. In all,
this function is an optimization step.



Classify by Attribute

Brief

This function classifies the point cloud into another class according to their attributes. Currently available
classification attributes include Absolute Elevation, Intensity, GPS Time, Scan Angle, and Return Number. In
addition, the function can restore all classes and/or reclassify the point cloud for undesirable classification results.

Usage

Click Classify > Classify by Attribute

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Choose Attribute: The selected attribute will be used to classify the point cloud.

None (default): The default setting will change all points in the From Class option to To Class.
Absolute Elevation: Classified by elevation range. If the elevation value of a point is between the
specified range, it will be assigned to the To Class.
Intensity: Classified by intensity range. If the intensity value of a point is between the specified range, it
will be assigned to the To Class.
Time: Classified by GPS time. If the GPS time value of a point is between the specified range, it will be
assigned to the To Class.
Angle: Classified by scan angle. If the scan angle value of a point is between the specified range, it will
be divided into the To Class.
Return: Classified by the return number. If the return number at a point is between the specified range,
it will be assigned to the To Class.



Classify Low Points

Brief

The low point refers to the noise point that is lower than the actual terrain. The existence of the low point will
affect the extraction of the ground point, because the progressive triangulation filtering algorithm is based on the
seed points represented by the lowest point of the gridded point cloud. Therefore, filtering out the low point is a
preprocessing operation, which directly affects the filtering effects, the establishment of a digital model, and the
generation quality of contour lines. The triangulated terrain model created by the ground points with low points is
shown below.

The distribution of low points is divided into individual points or clusters. The algorithmic flow of this function is:

1. Traverse the point cloud and search for points to be classified within a certain range of radius of the current
single point or point cluster.

2. Calculate the maximum height difference between the current point and the neighboring point, which is
compared with the threshold.

3. If the value is greater than the threshold, the current point is considered to be a low point, otherwise, it is not
classified as a low point.

Usage

Click Classify > Classify Low Points



Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is“1”): When the number of points is set to 1, the single low point is
classified. If it is greater than 1, cluster low points are classified.
Radius (m, default value is"5"): The radius threshold between the unclassified point and the neighboring
point.
Height (m, default value is"0.5"): The height difference threshold between the unclassified point and the
neighboring point.
DefaultValue: Click this button to set all parameters as default.



Classify by Below Surface

Brief

This function classifies points in the initial category that are below the elevation of the surrounding neighborhood.
For example, when the starting category is ground, this method can be used to classify points lower than the
surface elevation to be the lower-than-the-surface point. The main algorithm idea of this function is:

1. Search for a certain number of nearest points for the current point in initial class.
2. Fit the plane with the nearest point.
3. Calculate the absolute value of the height difference between the current point and the plane. If the value is

less than the set Z tolerance, it is not categorized. If it is greater than the tolerance, go to the next step.
4. Calculate whether the difference between the current point elevation and the average value of the

neighboring points is greater than the Limit of the standard deviation. If it is greater than, then it is classified
as the target category; otherwise, it is not classified.

Usage

Click Classify > Classify by Below Surface

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Limit (default value is"3"): The multiple of the mean squared error of the neighboring point fitting plane of
the unclassified points. The larger the value, the less points will be classified into the target class.
Z tolerance (m, default value is"3"): The threshold of height difference. The point to fit plane distance less
than this value is not classified. The larger the value, the less points will be classified into target class.



DefaultValue: Click this button to set all parameters as default.



Classify Isolated Points

Brief

This function classifies points in a certain area of point cloud, which is generally used to find outliers in the air or
below the ground.

Usage

Click Classify > Classify Isolated Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Points Number (default value is"3"): If the number of points in the neighboring radius are less than or
equal to the value, the point is considered as an isolated point.
Radius (m, default value is"5"): Neighboring search radius.
DefaultValue: Click this button to set all parameters as default.



Classify Air Points

Brief

This function classifies points that are significantly higher than the surrounding points into airborne noise points.
The idea of the algorithm is the same as the principle of Outlier Removal in the data management module.

Usage

Click Classify > Classify Air Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Neighbor Points (default value is"10"): The number of neighbors that will be used to determine whether a
point is a noise in the sky. Calculate the distance between each point to the nearest point and calculate the
standard deviation of the nearest distances.
Multiples of std deviation (default value is"5"): If the deviation of points beyond the minimum allowable
threshold, they are considered as noise in the sky. The larger the threshold, the less the noise will be divided
into.
DefaultValue: Click this button to set all parameters as default.



Classify by Height Above Ground

Brief

This function classifies the points on the surface of the terrain with a certain height, which can quickly classify
vegetation at different heights. For example, this classification can be performed three times to separate low
vegetation (0-1m), medium vegetation (1-10m), and high vegetation (10-100m), see the figure below.

Usage

Click Classify > Classify by Height Above Ground

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be opened in
the LiPowerline software.
From Class: Source class(es).



Ground Class: The default ground point is 2-class.
To Class: Target class.
Min Height (m, default value is "0"): The minimum height difference of the area to be classified above the
ground points.
Max Height (m, default value is "1"): The maximum height difference of the area to be classified above the
ground points.
DefaultValue: Click this button to set all parameters as default.

Note: This function need to contain the ground point in the cloud.



Classify by Min Elevation

Brief

This function classifies the points at a certain height within a certain radius in the source class.

Usage

Click Classify > Classify by Min Elevation

Settings

Input Data: The input file can be a single point cloud data or a point cloud data set, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Min Height (m, default value is"0"): The minimum height difference in the area to be classified above the
lowest point within the radius.
Max Height (m, default value is"1"): The maximum height difference in the area to be classified above the
lowest point within the radius.
Radius (m, default value is"5"): The radius of the area needs to be classified at the current point, which
needs to be classified.
DefaultValue: Click this button to set all parameters as default.



Classify Buildings

Brief

This function classifies buildings in point cloud data.

Usage

Click Classify > Classify Buildings

Settings

Input Data: The input file can be a single point cloud data file or a point cloud dataset, which must be
opened in the LiPowerline software and has already been classified by ground points.
From Class: Source class(es).
Ground Class: The default ground point is 2-class.
To Class: Target class.
Normal Radius (m, default value is "3"): The radius of the neighborhood when calculating the normal
vector of each point in the point cloud. Usually set to 4-6 times the distance between points.
Angle Threshold (°, default value is "10"): The angle threshold between two points in plane clustering.
When the actual angle of two points is less than the threshold, the two points will be clustered into the same
group.
Elevation Tolerance (m, default value is "0.6"): The distance threshold from point to plane in plane
clustering, which is expected to be slightly larger than the average point distance. When the actual distance
is less than the threshold, the point and plane will be clustered into the same group.
Minimum Points Number (default value is "100"): The minimum points number of building patches.
Max Slope (°, default value is "60"): The angle between the plane and the vertical direction. Greater than
this value is not considered as the top of the building but the wall or other classes.



Max Building Size (m, default value is "60"): The maximum length of buildings, which was used for the
detection of building patches between blocks.
DefaultValue: Click this button to set all parameters as default.

Note: Using this function requires that the point cloud has been classified by ground points.



Classify Power Line

Brief

This function classifies power lines in point cloud data.

Usage

Click Classify > Classify Power Line

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Voxel (default value is"3")：The general setting is 3 or 5. This value should not exceed the minimum
distance between the power lines in the gear.
DefaultValue: Click this button to set all parameters as default.



Classify Model Key Points

Brief

This function can thin a certain level of the classified points. It is generally used to generate a sparse point set
that retains the key points in the complex terrain area and thin the points in the flat area from the extracted dense
ground points.

The idea of the algorithm is: first, meshing of point cloud data, and then use the seed points in the grid to
establish the initial triangulation network. According to the upper and lower boundary thresholds, the points that
meet the conditions are added to the triangulation network. The process is iterated until all of the key points of
terrain model are classified. In the following figure, the yellow point is the ground point and the purple point is the
key point of terrain model.

Usage

Click Classify > Classify Model Key Points

Settings

Input Data: The input file can be a single point cloud data or a point cloud dataset, which must be opened in
the LiPowerline software.
From Class: Source class(es).
To Class: Target class.
Tolerance Above (m, default value is"0.15"): The maximum allowable elevation tolerance value over the
triangulation model composed by the original points. The larger the value, the more sparse the key points will



be extracted, and vice versa.
Tolerance Below (m, default value is"0.15"): The maximum allowable elevation tolerance value under the
triangulation model composed by the original points. The larger the value, the more sparse the key points will
be extracted, and vice versa.
Grid Size (m, default value is"20"): The value is used to ensure the density of key points extracted from the
model. For example, if you want to ensure that there is at least one point in the grid every 20 meters, this
value is set to 20.
DefaultValue: Click this button to set all parameters as default.



Power Line
To handle and analyze power line channel based on point cloud data, including Quick Report, Point Cloud
Realtime Condition, Vector Realtime Condition, Simulation Condition, Completion Acceptance, Fine Inspection,
Measurement and Toolbox etc.

Quick Report

Point Cloud Realtime Condition

Vector Realtime Condition

Simulation Condition

Completion Acceptance

Measurement

Toolbox

Detection Result List



Quick Report
To provide quick classification and analysis report after field work. Specific functions are as below:

Add Data

Settings

Mark Tower

Classify

Profile Tools

Danger Points Detection

Clear



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from
software (e.g. provided by LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to
produce X, Y, and Z point data. The intention of the data format is to provide an open format that allows different
LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do
some initial settings as shown in the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID,
Generating Software, File Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each
point record. LiPowerline imports all the point attributes by default.

Brief: One of the most useful features of LiPowerline is its ability to interface with data in many file
formats. You can import point clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.), tables,
images (JPG, TIF), models (OSG, LiModel, LiTin) or vectors into LiPowerline. It allows you to visualize,
animate and edit your point cloud as well. Point cloud data will be converted into LiData file at the first
time being added. LiData file is the LiPowerline native file format for point cloud and optimized for
viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.



You can search the coordinate system much more quickly by using regular expressions. For example, the
WGS 84 coordinate system will be displayed instantly when you input EPSG code of WGS 84 system as
shown in the figure below:

You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate
System. Recently used coordinate reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for
current point cloud data only. Apply All means all the point cloud data share the same configuration during
the LiPowerline's running and it won't show this configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z
coordinates and other attributes such as color and normal. These attributes can be simply arranged in one line for
each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do
some initial settings as shown in the figures below:



3. LiPowerline can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by
setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for
spreadsheets and databases. CSV format was used for many years prior to attempts to describe the format in a
standardized way in RFC 4180. The lack of a well-defined standard means that subtle differences often exist in
the data produced and consumed by different applications. These differences can make it troublesome to
process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format
is similar enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do
some initial settings as shown in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The
CSV table contains the ID of each tree, the x, y coordinate locations, the tree height, the crown diameter, and
the crown area properties. The data type could be Point or Circle. If Point type was selected, you should
specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.



Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D
scanners. It is a format for storing graphical objects that are described as a collection of polygons. A PLY file
consists of a header, followed by a list of vertices and then, a list of polygons. The header specifies how many
vertices and polygons are in the file. It also states what properties are associated with each vertex, such as (x, y,
z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary
version for compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII
text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do
some initial settings as shown in the figure below:

3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose
None.

5. Click Apply when you complete your configuration.

Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In
its simplest form, a raster consists of a matrix of cells (pixels) organized into rows and columns (grid) where each
cell contains a value representing information. The geographic location of each cell is implied by its position in the
cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no geographic coordinates are stored.
Due to the nature of the data storage technique data analysis is usually easy to program and quick to perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually
more aesthetically pleasing (traditional cartographic representation). Since most data is in vector form and no
data conversion is required. Accurate geographic location of data is maintained.



1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiPowerline stores triangulated regular network models generated by
DEM or DSM. LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiPowerline directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Settings

Summary

Common Settings

The user can set the working directory, point cloud coordinate system, class and detection parameters, detected
line voltage level and add configuration tables. The software can record the user's last 5 input history records in
settings of the working directory, point cloud coordinate system and classes and detection parameters. User can
select the most recently used item in the drop-down list. The working directory is used to manage the project. The
prj.ini file in the working directory records the point cloud coordinate system, classes and detection parameters,
and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Input Point Cloud Spatial Coordinate: The coordinate system of the point cloud data.
Classification and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected power line.
Add Configuration Table: If the detection line voltage level list is empty and does not contain the current
voltage level, user can add a new voltage level by adding a configuration table and set its safety distance
detection parameters.

Detection Parameter Settings

Power line module parameter settings include common settings and detection parameter settings.
Common settings include working directory settings, point cloud coordinate systems settings, class and
detection parameters settings, detected line voltage level settings; detection parameter settings include
class settings, detection types, and safety distance settings.



Displays key detection classes and safety distance detection parameters. User can add voltage levels and then
configure their corresponding detection parameters, including clearance distance analysis and crossing analysis.
Clearance distance analysis includes detections for different classes of objects, as well as different safety
distance and distance detection methods. For crossing analysis, user only needs to set the classes to be
detected, and user does not need to set a safety distance.

Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If the
distance is less than this value, it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the distance
is less than this value, it is a danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If the
distance is less than this value, it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether to be a
danger point by the horizontal distance. If the distance is less than set horizontal value, it is a danger



point. If the distance is larger than set horizontal value, judge the point whether to be a danger point by
the vertical distance. If the distance is less than the set vertical distance, it is a danger point. If the
distance is larger than the set vertical distance, judge the point whether to be a danger point by the
clearance distance then.

Add Row: Add a new detection class record.
Delete Selected Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Selected Column: Delete the selected column.
Modify Selected Column Name: Modify the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.

Note: In crossing analysis, if user does not select the detection class, software will only analyze the upper
crossing and lower crossing by default.



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower file. After
adding the position information of the tower, the software will automatically generate the index and name
information of the tower. Index is a number starting from the starting value and incrementing by 1. By default,
name is the same as Index. Tower type includes "None", "Tension Tower", and "Straight Line Tower". Double-
click the row for each tower to jump to that tower in the displaying window. By checking or unchecking the
checkbox in front of "display all tower points" to display or hiding the tower points in the window. Point size can be
modified. By clicking the hot key "S" and "D" on the keyboard to move the edited tower record forward or
backward.

Show All Tower Point (checked by default)：Display the tower names or indexes in the window. Uncheck
this option to hide the all the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Point Size (meter) (default value is "5.0"): Set the red marker sphere and text font size of the tower. 



Mark Tower

Add Tower Backward

Add Tower Forward

Delete Tower

Modify Tower Position

Tower Centralization

Click this button to start to pick the tower points. Click again to exit this function and save the current
tower information to the tower.LiTower file in the working directory.

Add a tower record after currently selected record.

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Click this button and the centralize tower window will popup. Click to select several points on the tower,
and click calculate button to get the center point of the tower. Click the function button again to exit this
function, and the tower information will be stored in the tower.LiTower file in the working directory.



Import Tower File
Input the tower file and renew the tower list in LiTower, txt, csv, and kml file. If the input file is in kml
format, user can use KML Tower Position Editor to load the tower information. If the input file is in txt or
csv format, user can follow the steps below to load the tower information.



1. Adjust the data type for each column, and select the number of skipped rows and the type of separator.
2. If the input data's coordinates are in latitude and longitude, user can check the “Transform” option in

Conversion tab to convert the geographic coordinates into projected coordinates.
3. Click "Apply" to import the tower file and renew the tower list.

Export Tower File

1. Select the export file format, including LiTower and KML formats. User can choose the export types of point,
line, point and line when selecting KML.

2. Set the output path.
3. Click "OK" to export the tower file.

Batch Edit Tower Name

Export the information in the current tower list to LiTower or kml file.



Right-click on the "Name" column in the tower list, and the popup selection menu is shown in the figure below,
including adding prefixes, adding suffixes, and batch modification. It can be used to add prefixes, suffixes, or both
to the tower names.

Batch Edit Tower Type

Right-click on the "Type" column in the tower list, and the popup selection menu is shown in the figure below,
including setting as a straight line tower and setting as a tension tower. User can modify the tower type as a
straight line tower or a tension tower in batches.



Classify

Summary

Usage

Add the point cloud data, and click Quick Report > Classify > Classify.

According to the tower file, clip and classify the point cloud data. Classify the point cloud into
transmission tower, power line, ground points, noise, and other selected classes. This This function can
process multiple data simultaneously. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list. This function can perform segmentation, classification, and
noise removal in one step, or user can select the function needed by checking the box in front of the
name of each function.



Settings

GPU Acceleration (Unchecked by default): Use GPU to accelerate classification operations.
Start Tower Index: Towers with index numbers smaller than this value are not involved in the calculation.
The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The
default value is the maximum Index in the tower file.
Channel Width (meters) (default is "60"): Width extending to both sides of the power line. The software
can record the user's current settings and automatically restore the settings when opened again.
Ground: Please refer to the Classify Ground Points in the Classify toolbox for the detailed information of
parameter settings.
Buildings: Please refer to the Classify Buildings in the Classify toolbox for the detailed information of



parameter settings. The software will not classify the buildings if this option is unchecked.
Filter Noise (Checked by default): Classify the noise points. The software will not classify the noise if this
option is unchecked.

Points Num (default value is "2"): If the number of point clouds in the local range of the point is less
than this value, then the point is noisy.
Radius (meters) (default value is "4"): Search radius around every point in cloud.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be (Smaller
Tower Index_Larger Tower Index). In order not to impact the following steps, it is highly recommended not
to change the file name. After the automatic classification, user need to check the accuracy of the result
and manually modify it in the Profile Tools.



Danger Points Detection

Summary

Usage

Click Quick Report > Detection > Danger Points Detection

Settings

Batch process the point cloud file to generate the danger points images and reports based on the tower
file. The interface of detect danger points function is shown as follow. This This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Start Tower Index: Towers with index numbers smaller than this value are not involved in the calculation.
The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The
default value is the maximum Index in the tower file.
Channel Width (meters) (default is "60"): Width extending to both sides of the power line. The software
can record the user's current settings and automatically restore the settings when opened again.
Detection Parameters: Detect the clearance danger points according to the customized

Cluster By Class: Unchecked by default. Used to control whether to cluster the result by class.If this
option is checked, the danger points will be clustered into different groups if they are in different classes;
otherwise, the class information will not influence the clustering process. The software can record the
user's current settings and automatically restore the settings when opened again.
Min Distance (meters) (default value is "0.3"): Points with clearance distance less than this distance
are not detected as danger points, as they are considered to be noise. The software can record the
user's current settings and automatically restore the settings when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.

Max Cluster Range (meters) (default value is "20.0"): After the detection results are clustered, if
the length along the power line direction is greater than this value, they are divided into multiple
dangerous point clusters. The software can record the user's current settings and automatically
restore the settings when opened again.

Generate Image: Refer to Generate Image UI.
Generate Report: Refer to Generate Report UI.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.



Clear

Summary

Usage

Quick Report > Detection > Clear

Settings

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Clear all the danger point detection result in the point cloud. After execute this function successfully, all
the danger points (in red) will be changed into non-danger point.



Point Cloud Realtime Condition
To handle and analyze power line channel based on point cloud data and to generate analysis report. Specific
functions are as below:

Add Data

Settings

Mark Tower

Line Infomation Collection

Clip and Classify

Classification Tools

Profile Tools

Danger Points Detection

Scissors Crossing Analysis

Water Analysis

Tree Growth Analysis

Tree Growth Warning Analysis

Tree Fall Analysis

Generate Image

Generate Report

Merge Report

Clear



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from
software (e.g. provided by LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to
produce X, Y, and Z point data. The intention of the data format is to provide an open format that allows different
LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do
some initial settings as shown in the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID,
Generating Software, File Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each
point record. LiPowerline imports all the point attributes by default.

Brief: One of the most useful features of LiPowerline is its ability to interface with data in many file
formats. You can import point clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.), tables,
images (JPG, TIF), models (OSG, LiModel, LiTin) or vectors into LiPowerline. It allows you to visualize,
animate and edit your point cloud as well. Point cloud data will be converted into LiData file at the first
time being added. LiData file is the LiPowerline native file format for point cloud and optimized for
viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.



You can search the coordinate system much more quickly by using regular expressions. For example, the
WGS 84 coordinate system will be displayed instantly when you input EPSG code of WGS 84 system as
shown in the figure below:

You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate
System. Recently used coordinate reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for
current point cloud data only. Apply All means all the point cloud data share the same configuration during
the LiPowerline's running and it won't show this configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z
coordinates and other attributes such as color and normal. These attributes can be simply arranged in one line for
each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do
some initial settings as shown in the figures below:



3. LiPowerline can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by
setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for
spreadsheets and databases. CSV format was used for many years prior to attempts to describe the format in a
standardized way in RFC 4180. The lack of a well-defined standard means that subtle differences often exist in
the data produced and consumed by different applications. These differences can make it troublesome to
process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format
is similar enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do
some initial settings as shown in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The
CSV table contains the ID of each tree, the x, y coordinate locations, the tree height, the crown diameter, and
the crown area properties. The data type could be Point or Circle. If Point type was selected, you should
specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.



Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D
scanners. It is a format for storing graphical objects that are described as a collection of polygons. A PLY file
consists of a header, followed by a list of vertices and then, a list of polygons. The header specifies how many
vertices and polygons are in the file. It also states what properties are associated with each vertex, such as (x, y,
z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary
version for compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII
text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do
some initial settings as shown in the figure below:

3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose
None.

5. Click Apply when you complete your configuration.

Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In
its simplest form, a raster consists of a matrix of cells (pixels) organized into rows and columns (grid) where each
cell contains a value representing information. The geographic location of each cell is implied by its position in the
cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no geographic coordinates are stored.
Due to the nature of the data storage technique data analysis is usually easy to program and quick to perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually
more aesthetically pleasing (traditional cartographic representation). Since most data is in vector form and no
data conversion is required. Accurate geographic location of data is maintained.



1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiPowerline stores triangulated regular network models generated by
DEM or DSM. LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiPowerline directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Settings

Summary

Common Settings

The user can set the working directory, point cloud coordinate system, class and detection parameters, detected
line voltage level and add configuration tables. The software can record the user's last 5 input history records in
settings of the working directory, point cloud coordinate system and classes and detection parameters. User can
select the most recently used item in the drop-down list. The working directory is used to manage the project. The
prj.ini file in the working directory records the point cloud coordinate system, classes and detection parameters,
and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Input Point Cloud Spatial Coordinate: The coordinate system of the point cloud data.
Classification and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected power line.
Add Configuration Table: If the detection line voltage level list is empty and does not contain the current
voltage level, user can add a new voltage level by adding a configuration table and set its safety distance
detection parameters.

Detection Parameter Settings

Power line module parameter settings include common settings and detection parameter settings.
Common settings include working directory settings, point cloud coordinate systems settings, class and
detection parameters settings, detected line voltage level settings; detection parameter settings include
class settings, detection types, and safety distance settings.



Displays key detection classes and safety distance detection parameters. User can add voltage levels and then
configure their corresponding detection parameters, including clearance distance analysis and crossing analysis.
Clearance distance analysis includes detections for different classes of objects, as well as different safety
distance and distance detection methods. For crossing analysis, user only needs to set the classes to be
detected, and user does not need to set a safety distance.

Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If the
distance is less than this value, it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the distance
is less than this value, it is a danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If the
distance is less than this value, it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether to be a
danger point by the horizontal distance. If the distance is less than set horizontal value, it is a danger



point. If the distance is larger than set horizontal value, judge the point whether to be a danger point by
the vertical distance. If the distance is less than the set vertical distance, it is a danger point. If the
distance is larger than the set vertical distance, judge the point whether to be a danger point by the
clearance distance then.

Add Row: Add a new detection class record.
Delete Selected Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Selected Column: Delete the selected column.
Modify Selected Column Name: Modify the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.

Note: In crossing analysis, if user does not select the detection class, software will only analyze the upper
crossing and lower crossing by default.



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower file. After
adding the position information of the tower, the software will automatically generate the index and name
information of the tower. Index is a number starting from the starting value and incrementing by 1. By default,
name is the same as Index. Tower type includes "None", "Tension Tower", and "Straight Line Tower". Double-
click the row for each tower to jump to that tower in the displaying window. By checking or unchecking the
checkbox in front of "display all tower points" to display or hiding the tower points in the window. Point size can be
modified. By clicking the hot key "S" and "D" on the keyboard to move the edited tower record forward or
backward.

Show All Tower Point (checked by default)：Display the tower names or indexes in the window. Uncheck
this option to hide the all the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Point Size (meter) (default value is "5.0"): Set the red marker sphere and text font size of the tower. 



Mark Tower

Add Tower Backward

Add Tower Forward

Delete Tower

Modify Tower Position

Tower Centralization

Click this button to start to pick the tower points. Click again to exit this function and save the current
tower information to the tower.LiTower file in the working directory.

Add a tower record after currently selected record.

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Click this button and the centralize tower window will popup. Click to select several points on the tower,
and click calculate button to get the center point of the tower. Click the function button again to exit this
function, and the tower information will be stored in the tower.LiTower file in the working directory.



Import Tower File
Input the tower file and renew the tower list in LiTower, txt, csv, and kml file. If the input file is in kml
format, user can use KML Tower Position Editor to load the tower information. If the input file is in txt or
csv format, user can follow the steps below to load the tower information.



1. Adjust the data type for each column, and select the number of skipped rows and the type of separator.
2. If the input data's coordinates are in latitude and longitude, user can check the “Transform” option in

Conversion tab to convert the geographic coordinates into projected coordinates.
3. Click "Apply" to import the tower file and renew the tower list.

Export Tower File

1. Select the export file format, including LiTower and KML formats. User can choose the export types of point,
line, point and line when selecting KML.

2. Set the output path.
3. Click "OK" to export the tower file.

Batch Edit Tower Name

Export the information in the current tower list to LiTower or kml file.



Right-click on the "Name" column in the tower list, and the popup selection menu is shown in the figure below,
including adding prefixes, adding suffixes, and batch modification. It can be used to add prefixes, suffixes, or both
to the tower names.

Batch Edit Tower Type

Right-click on the "Type" column in the tower list, and the popup selection menu is shown in the figure below,
including setting as a straight line tower and setting as a tension tower. User can modify the tower type as a
straight line tower or a tension tower in batches.



Line Information Collection

Power Line Type

Collection Time

Line information collection includes power line type and collection time.



Power Line Type

Summary

Select the transmission tower type (straight line tower / tension tower) and then set the line type between each
two towers. Save the power line type file.

Usage

Click Collection > Information > Power Line Type.

Open File

Save File

Add Power Line Type

Open the power line type file

Save the power line type file. The default output path is the information folder in the working directory.
The results are in the "SectionPowerLineType.csv" file.

Add a new power line type, and set the start and end transmission towers name.



Delete Power Line Type

Modify Power Line Type

Check Availability

Delete the selected power line type.

Modify the selected power line type.

Check if there is any overlap in the power line type of different pylon sections.



Collection Time

Summary

Set the collection time in different pylon sections.

Usage

Click Collection > Information > Collection Time.

Open File

Save File

Add Collection Time

Open the collection time file.

Save the collection time file. The default output path is the information folder in the working directory.
The results are in the "CollectionTime.csv" file.

Set the start and end transmission towers name, and set the collection time.



Delete Collection Time

Modify Collection Time

Check Availability

Delete the selected collection time.

Modify the selected collection time.

Check if there is any overlap in the collection time of different pylon sections.



Clip and Classify

Summary

Usage

Click Clip/Classify > Clip and Classify.

Settings

Clipping and classifying the point cloud data into segments. The Classification process will classify the
transmission tower, power line, ground points, and noise in the point cloud. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Output Path: Set the output path.
Clip (Checked by default): Clip the data into segments. If this option is unchecked, the data will not be
clipped.

Channel Width (meter) (default value is "60"): Width extending along both sides of the power line.
The software can record the user's current settings and automatically restore the settings when opened
again.
Segment Buffer (meter) (default value is "10"): Extension distance at both ends of the transmission
tower.
Start Tower Index: Towers with index numbers smaller than this value do not participate in gear
shifting. The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers greater than this value do not participate in gear shifting.
The default value is the maximum Index in the tower file.
Resampling (Unchecked by default): Resampling the processed data.

Classification (Checked by default): Perform classification operations, including shield line, ground point,
power line, tower and building.

Classify Power line and Tower (By Machine Learning is checked by default): Use deep learning
strategy to classify the power line and transmission tower.
Classify Ground Points: Please refer to the classify ground points tool for details.
Classify Building Points: Please refer to the classify building points tool for details.
Use GPU Acceleration(Checked by default): Use GPU to accelerate classification operations.

Filter Noise (Checked by default): Remove the noise in the point cloud. If this option is unchecked, the
software will not remove the noise in the point cloud.

Classify Noise: Please refer to the classify noise tool for details.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be (Smaller
Tower Index_Larger Tower Index). In order not to impact the following steps, it is highly recommended not
to change the file name. After the automatic classification, user need to check the accuracy of the result
and manually modify it in the Profile Tools.



Classification Tools

Summary

Classify Ground Points

Classify by Attribute

Classify Low Points

Classify by Below Surface

Classify Isolated Points

Classify Air Points

Classify by Height Above Ground

Classify by Min Elevation

Classify Buildings

Classify Model Key Points

Classification tools are mainly used to automatically classify the point cloud in different classes. The
toolset includes classify ground points, classify by attribute, classify low points, classify by below
surface, classify isolated points, classify by height above ground, classify by min elevation, classify
buildings, and classify mode key points.



Danger Points Detection

Summary

Usage

Click Realtime Analysis > Danger Points Detection

Settings

Detection Parameter:
Cluster By Class: Unchecked by default. Used to control whether to cluster the result by class.If this
option is checked, the danger points will be clustered into different groups if they are in different classes;
otherwise, the class information will not influence the clustering process. The software can record the
user's current settings and automatically restore the settings when opened again.
Min Distance (meters) (default value is "0.3"): Points with clearance distance less than this distance
are not detected as danger points, as they are considered to be noise. The software can record the
user's current settings and automatically restore the settings when opened again.

Judge if the point is a danger point according to the clearance distance and the set safety distance. The
interface of the clearance danger point detect function is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meters) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Clearance Danger Point List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Scissors Crossing Analysis

Summary

Usage

Click Realtime Analysis > Scissors Crossing Analysis

Settings

Detection Parameter:
Cluster Radius (meter) (default value is "3.0"): The maximum spatial distance when clustering
crossing points. The crossing point clusters in the range extract the nearest vertical distance point as the
crossing point of the cluster.
Buffer Size (meter) (default value is "0.5"): The power line point cloud in a certain buffer area near the
horizontal range of cross line will participate in the calculation.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings

Calculate the scissors crossing danger point by cross analysis on the power line and the detected
classes of points. The interface of scissors crossing analysis is shown as follow. This function can
process multiple data simultaneously. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Scissors Crossing Analysis List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Water Analysis

Summary

Usage

Click Realtime Analysis > Water Analysis

Settings

Detection Parameter：
Safe Distance (meter) (default value is "4.5"): The threshold of safety distance. If the distance from
the power line to the waterbody under it is less than this value, the corresponding point on the power line
will be recognized as a danger point.
Density Threshold (/square meter) (default value is "0"): The threshold used to extract the
waterbody from the point cloud. Those areas with point density lower than or equal to this value will be
recognized as "suspected waterbodies". After this extracting, merge the suspected waterbodies close to

Based on the "black hole" in the point cloud data, those continuous hollow areas which meets
requirements in the set parameters will be determined as the water area. Then the software will
calculate the distances from the power line points to the water surface to judge if the point on the power
line is danger point. The interface of water analysis is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



each other.
Smoothing Factor (default is "2"): Smooth the edge of the waterbody. The smaller the value is, the
finer the smoothing effect will be.
Area Threshold (square meter) (default value is "4000"): The threshold to extract the waterbody. If
the detected area is larger than this value, it will be recognized as waterbody.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Tree Growth Analysis

Summary

Usage

Click Early Warning Analysis > Tree Growth Analysis.

Settings

Tree Growth Parameter:
Growth Years (year) (default value is "1"): Set the predicted growth time. The software can record the
user's current settings and automatically restore the settings when opened again.
Constant Growing Speed (default): If this option is checked, “Growth Speed” will be allowed to be set,
and all kinds of trees will be considered to grow at this growth rate.
Growth Rate (meter/year) (default value is "0.3"): Set the tree growth rate. The function can record

Based on the result of individual tree segmentation, calculate and extract the danger points after a
certain period of growth. This function can process multiple data simultaneously. Click to add the
data to be processed. Click to remove the selected data. Click to clear the data list.



the user's current settings and automatically restore the settings when opened again.
Custom Growing Speed for Species: If this option is checked, user can set the growth rate for
different tree species in the table. Tree species files can be generated from Tree Species Classification,
and the default growth rate is 1 meter / year.

Clustering Parameter:
Cluster: This option is unchecked by default. If this option is checked, the software will cluster the result;
otherwise, the software will not cluster the result. The software can record the user's current settings
and automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Clustering Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there
are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be
selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Growth Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Tree Growth Warning Analysis

Summary

Based on the result of individual tree segmentation, calculate the years of each tree to grow to be a danger
tree. The interface of tree growth warning analysis is shown in the figure below. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected data.
Click to clear the data list.

Usage

Click Early Warning Analysis > Tree Growth Warning Analysis.

Settings

Tree Growth Parameter:
Growth Years (year) (default value is "1"): Set the predicted growth time. The software can record the
user's current settings and automatically restore the settings when opened again.
Constant Growing Rate (default): If this option is checked, “Growth Speed” will be allowed to be set,
and all kinds of trees will be considered to grow at this growth rate.
Growth Rate (meter/year) (default value is "0.3"): Set the tree growth rate. The function can record
the user's current settings and automatically restore the settings when opened again.



Custom Growing Speed for Species: If this option is checked, user can set the growth rate for
different tree species in the table. Tree species files can be generated from Tree Species Classification,
and the default growth rate is 1 meter / year.

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there
are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Growth Warning Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.



Tree Fall Analysis

Summary

Usage

Click Early Warning Analysis> Tree Fall Analysis

Settings

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there

Based on the result of individual tree segmentation, analyze the danger points on the trees during the
falling procedure. The interface of tree fall analysis is shown in the figure below. This function can
process multiple data simultaneously. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Detection Parameter:
Cluster: This option is unchecked by default. If this option is checked, the software will cluster the result;
otherwise, the software will not cluster the result. The software can record the user's current settings
and automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Offset Percentage (default value is "0"): The percentage of the tree's horizontal offset relative to the
height of the tree when falling.
Remove Danger Treetop: Not selected by default. If the detected treetops are already a clearance
danger point, when this option is checked, the tool will not record this point; otherwise, it will be
recognized as a danger point. The software can record the user's current settings and automatically
restore the settings when opened again.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be
selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Vaule: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Fall Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Generate Image

Summary

Usage

Click Report > Image

Settings

Image Type: Select the type of danger points need to be rendered in the image.
Clearance Danger: Render the clearance danger point detection result in the image.

Generate images based on the detection results of danger points and the results of individual tree
segmentation, including front views, top views, cross-section views of danger points, and tree height
distribution and tree density distribution. The function interface is shown in the figure below. This
function can process multiple data at the same time. Click to remove the selected data. Click to
clear the data list.



Scissors Crossing: Render the crossing danger point detection result in the image.
Water: Render the waterbody detection result in the image.
Tree Growth: Render the tree growth detection result in the image.
Tree Fall: Render the tree fall detection result in the image.
Tree Height Image: Unchecked by default. If this option is checked, the height distribution map of trees
in the file will be drawn.
Tree Density Image: Unchecked by default. If this option is checked, the density distribution map of
trees in the file will be drawn.

Image Parameter:
Scale Factor (default value is "1.0"): Checked by default. The ratio of the image width to the height
scale. Used to control the degree of deformation of the image height.
Color Setting: Unchecked by default. User can set the color for different classes of point cloud in the
generated image. If the option is unchecked, the image is drawn according to the colors of the point
cloud displayed in the window; otherwise the image is generated according to the customized colors.
The software can record the user's current settings and automatically restore the settings when opened
again.
Front View Width (pixels) (default is "1000"): The width of the front view.
Front View Height (pixels) (default is "450"): Height of the front view.
Top View Width (pixels) (default is "1000"): The width of the top view.
Top View Height (pixels) (default is "350"): Height of the top view.
Profile Thickness (m) (default is "1"): Thickness of point cloud profile when generating danger point
image. The software can record the user's current settings and automatically restore the settings when
opened again.
Point Size (default is "1"): The point size of image. The software can record the user's current settings
and automatically restore the settings when opened again.
Prefix of Tower (optional): In the generated front view and top view images, the prefix of the tower
label. Prefix is empty by default.
Suffix of Tower (optional): In the generated front view and top view images, the suffix of the tower
label. Suffix is empty by default.

Resampling Parameter: Point cloud resampling parameter settings. Used to control image generation
quality. The software can record the user's current settings and automatically restore the settings when
opened again.

Resampling: Unchecked by default. Set whether to resample the point cloud.
Grid size X, Y, Z (meters) (default is "0.5, 0.5, 0.1"): Construct a three-dimensional voxel of X Y Z,
one point is reserved in each voxel.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The tree height image and tree density image are generated based on the individual tree
segmentation results. Users can use Tree Growth Analysis, Tree Fall Analysis or individual tree
segmentation tool to perform the individual tree segmentation.

Note: When this function is executed from a different working condition page, images are generated based
on the corresponding data.



International Report

Summary

The international report is the general version report. It can generate the report based on different data type and
detection type. The interface of "generate report" function is shown as follow. This function can process multiple
data simultaneously. Click to add the data to be processed. Click to remove the selected data. Click to
clear the data list.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Crossing Danger: Clear the crossing danger point detection result in the cache folder.
Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.

Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: Line name.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Point Cloud Coordinate: The coordinate system used in the point cloud data.



Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: Data type and detection type are combined to use. If user wants to generate the clearance and
crossing danger points report based on the point cloud data, they need to choose "Data Based on Point
Cloud" in the data type, and "Clearance Danger Point" and "Crossing Danger Point" in the detection type.
Then set the other parameters, and Click "Start" to generate the report.



Merge Report

Summary

Based on the original reports, the software can merge the reports automatically. This is especially suitable for the
scenarios such as batch data processing and data processing in different projection bands. Click  to add the
working directories need to be processed. Click  to remove the selected working directory. Click  to clear
the working directory list. Click the list item to confirm the working directory information.

Confirm information

After adding the working directories, click the list item to confirm the working directory information.

Confirm Working Directory Information
Start Tower Name: The name of starting tower.
End Tower Name: The name of ending tower.
Point Cloud SRS: The coordinate system of the point cloud.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Crossing Danger: Clear the crossing danger point detection result in the cache folder.



Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.

Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: The name of the power line section.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: To ensure the order of automatic merge, please add the working directories in order.



Clear

Summary

Usage

Click Report > Clear

Settings

Clear File: Select the file types need to be clear.
Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Scissors Crossing: Clear the crossing danger point detection result in the cache folder.
Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Growth Warning: Clear the tree growth warning detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.
Stress Detection: Clear the stress detection result in the cache folder.
Drainage Thread Clearance: Clear the drainage thread creepage distance detection result in the cache

Clear the danger point attributes and the the corresponding file of the point cloud. The interface of clear
function is shown in the figure below. This function can process multiple data simultaneously. Click 
to add the data to be processed. Click to remove the selected data. Click to clear the data list.



folder.
Phase Spacing: Clear the phase spacing detection result in the cache folder.
Sag: Clear the sag analysis result in the cache folder.
Images: Clear the image files in the cache folder.

Clear Attribute: Clear the attribute information of the point cloud.
Clear Danger Attributes: Clear the danger attributes in the point cloud files.
Clear Tree Segmentation: Clear the individual tree segmentation result of the point cloud. And delete
the segmentation result file saved in the cache folder.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: When this function is executed from a different working condition page, the corresponding data is
cleared.



Vector Realtime Condition
To handle and analyze power line channel based on point cloud data and vector data and to generate analysis
report. Specific functions are as below:

Add Data

Settings

Mark Tower

Line Infomation Collection

Clip and Classify

Classification Tools

Profile Tools

Vector Editing

Danger Points Detection

Scissors Cross Analysis

Water Analysis

Tree Growth Analysis

Tree Growth Warning Analysis

Tree Fall Analysis

Generate Image

Generate Report

Merge Report

Clear



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from
software (e.g. provided by LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to
produce X, Y, and Z point data. The intention of the data format is to provide an open format that allows different
LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do
some initial settings as shown in the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID,
Generating Software, File Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each
point record. LiPowerline imports all the point attributes by default.

Brief: One of the most useful features of LiPowerline is its ability to interface with data in many file
formats. You can import point clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.), tables,
images (JPG, TIF), models (OSG, LiModel, LiTin) or vectors into LiPowerline. It allows you to visualize,
animate and edit your point cloud as well. Point cloud data will be converted into LiData file at the first
time being added. LiData file is the LiPowerline native file format for point cloud and optimized for
viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.



You can search the coordinate system much more quickly by using regular expressions. For example, the
WGS 84 coordinate system will be displayed instantly when you input EPSG code of WGS 84 system as
shown in the figure below:

You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate
System. Recently used coordinate reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for
current point cloud data only. Apply All means all the point cloud data share the same configuration during
the LiPowerline's running and it won't show this configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z
coordinates and other attributes such as color and normal. These attributes can be simply arranged in one line for
each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do
some initial settings as shown in the figures below:



3. LiPowerline can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by
setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for
spreadsheets and databases. CSV format was used for many years prior to attempts to describe the format in a
standardized way in RFC 4180. The lack of a well-defined standard means that subtle differences often exist in
the data produced and consumed by different applications. These differences can make it troublesome to
process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format
is similar enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do
some initial settings as shown in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The
CSV table contains the ID of each tree, the x, y coordinate locations, the tree height, the crown diameter, and
the crown area properties. The data type could be Point or Circle. If Point type was selected, you should
specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.



Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D
scanners. It is a format for storing graphical objects that are described as a collection of polygons. A PLY file
consists of a header, followed by a list of vertices and then, a list of polygons. The header specifies how many
vertices and polygons are in the file. It also states what properties are associated with each vertex, such as (x, y,
z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary
version for compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII
text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do
some initial settings as shown in the figure below:

3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose
None.

5. Click Apply when you complete your configuration.

Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In
its simplest form, a raster consists of a matrix of cells (pixels) organized into rows and columns (grid) where each
cell contains a value representing information. The geographic location of each cell is implied by its position in the
cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no geographic coordinates are stored.
Due to the nature of the data storage technique data analysis is usually easy to program and quick to perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually
more aesthetically pleasing (traditional cartographic representation). Since most data is in vector form and no
data conversion is required. Accurate geographic location of data is maintained.



1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiPowerline stores triangulated regular network models generated by
DEM or DSM. LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiPowerline directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Settings

Summary

Common Settings

The user can set the working directory, point cloud coordinate system, class and detection parameters, detected
line voltage level and add configuration tables. The software can record the user's last 5 input history records in
settings of the working directory, point cloud coordinate system and classes and detection parameters. User can
select the most recently used item in the drop-down list. The working directory is used to manage the project. The
prj.ini file in the working directory records the point cloud coordinate system, classes and detection parameters,
and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Input Point Cloud Spatial Coordinate: The coordinate system of the point cloud data.
Classification and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected power line.
Add Configuration Table: If the detection line voltage level list is empty and does not contain the current
voltage level, user can add a new voltage level by adding a configuration table and set its safety distance
detection parameters.

Detection Parameter Settings

Power line module parameter settings include common settings and detection parameter settings.
Common settings include working directory settings, point cloud coordinate systems settings, class and
detection parameters settings, detected line voltage level settings; detection parameter settings include
class settings, detection types, and safety distance settings.



Displays key detection classes and safety distance detection parameters. User can add voltage levels and then
configure their corresponding detection parameters, including clearance distance analysis and crossing analysis.
Clearance distance analysis includes detections for different classes of objects, as well as different safety
distance and distance detection methods. For crossing analysis, user only needs to set the classes to be
detected, and user does not need to set a safety distance.

Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If the
distance is less than this value, it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the distance
is less than this value, it is a danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If the
distance is less than this value, it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether to be a
danger point by the horizontal distance. If the distance is less than set horizontal value, it is a danger



point. If the distance is larger than set horizontal value, judge the point whether to be a danger point by
the vertical distance. If the distance is less than the set vertical distance, it is a danger point. If the
distance is larger than the set vertical distance, judge the point whether to be a danger point by the
clearance distance then.

Add Row: Add a new detection class record.
Delete Selected Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Selected Column: Delete the selected column.
Modify Selected Column Name: Modify the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.

Note: In crossing analysis, if user does not select the detection class, software will only analyze the upper
crossing and lower crossing by default.



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower file. After
adding the position information of the tower, the software will automatically generate the index and name
information of the tower. Index is a number starting from the starting value and incrementing by 1. By default,
name is the same as Index. Tower type includes "None", "Tension Tower", and "Straight Line Tower". Double-
click the row for each tower to jump to that tower in the displaying window. By checking or unchecking the
checkbox in front of "display all tower points" to display or hiding the tower points in the window. Point size can be
modified. By clicking the hot key "S" and "D" on the keyboard to move the edited tower record forward or
backward.

Show All Tower Point (checked by default)：Display the tower names or indexes in the window. Uncheck
this option to hide the all the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Point Size (meter) (default value is "5.0"): Set the red marker sphere and text font size of the tower. 



Mark Tower

Add Tower Backward

Add Tower Forward

Delete Tower

Modify Tower Position

Tower Centralization

Click this button to start to pick the tower points. Click again to exit this function and save the current
tower information to the tower.LiTower file in the working directory.

Add a tower record after currently selected record.

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Click this button and the centralize tower window will popup. Click to select several points on the tower,
and click calculate button to get the center point of the tower. Click the function button again to exit this
function, and the tower information will be stored in the tower.LiTower file in the working directory.



Import Tower File
Input the tower file and renew the tower list in LiTower, txt, csv, and kml file. If the input file is in kml
format, user can use KML Tower Position Editor to load the tower information. If the input file is in txt or
csv format, user can follow the steps below to load the tower information.



1. Adjust the data type for each column, and select the number of skipped rows and the type of separator.
2. If the input data's coordinates are in latitude and longitude, user can check the “Transform” option in

Conversion tab to convert the geographic coordinates into projected coordinates.
3. Click "Apply" to import the tower file and renew the tower list.

Export Tower File

1. Select the export file format, including LiTower and KML formats. User can choose the export types of point,
line, point and line when selecting KML.

2. Set the output path.
3. Click "OK" to export the tower file.

Batch Edit Tower Name

Export the information in the current tower list to LiTower or kml file.



Right-click on the "Name" column in the tower list, and the popup selection menu is shown in the figure below,
including adding prefixes, adding suffixes, and batch modification. It can be used to add prefixes, suffixes, or both
to the tower names.

Batch Edit Tower Type

Right-click on the "Type" column in the tower list, and the popup selection menu is shown in the figure below,
including setting as a straight line tower and setting as a tension tower. User can modify the tower type as a
straight line tower or a tension tower in batches.



Line Information Collection

Power Line Type

Collection Time

Line information collection includes power line type and collection time.



Power Line Type

Summary

Select the transmission tower type (straight line tower / tension tower) and then set the line type between each
two towers. Save the power line type file.

Usage

Click Collection > Information > Power Line Type.

Open File

Save File

Add Power Line Type

Open the power line type file

Save the power line type file. The default output path is the information folder in the working directory.
The results are in the "SectionPowerLineType.csv" file.

Add a new power line type, and set the start and end transmission towers name.



Delete Power Line Type

Modify Power Line Type

Check Availability

Delete the selected power line type.

Modify the selected power line type.

Check if there is any overlap in the power line type of different pylon sections.



Collection Time

Summary

Set the collection time in different pylon sections.

Usage

Click Collection > Information > Collection Time.

Open File

Save File

Add Collection Time

Open the collection time file.

Save the collection time file. The default output path is the information folder in the working directory.
The results are in the "CollectionTime.csv" file.

Set the start and end transmission towers name, and set the collection time.



Delete Collection Time

Modify Collection Time

Check Availability

Delete the selected collection time.

Modify the selected collection time.

Check if there is any overlap in the collection time of different pylon sections.



Clip and Classify

Summary

Usage

Click Clip/Classify > Clip and Classify.

Settings

Clipping and classifying the point cloud data into segments. The Classification process will classify the
transmission tower, power line, ground points, and noise in the point cloud. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Output Path: Set the output path.
Clip (Checked by default): Clip the data into segments. If this option is unchecked, the data will not be
clipped.

Channel Width (meter) (default value is "60"): Width extending along both sides of the power line.
The software can record the user's current settings and automatically restore the settings when opened
again.
Segment Buffer (meter) (default value is "10"): Extension distance at both ends of the transmission
tower.
Start Tower Index: Towers with index numbers smaller than this value do not participate in gear
shifting. The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers greater than this value do not participate in gear shifting.
The default value is the maximum Index in the tower file.
Resampling (Unchecked by default): Resampling the processed data.

Classification (Checked by default): Perform classification operations, including shield line, ground point,
power line, tower and building.

Classify Power line and Tower (By Machine Learning is checked by default): Use deep learning
strategy to classify the power line and transmission tower.
Classify Ground Points: Please refer to the classify ground points tool for details.
Classify Building Points: Please refer to the classify building points tool for details.
Use GPU Acceleration(Checked by default): Use GPU to accelerate classification operations.

Filter Noise (Checked by default): Remove the noise in the point cloud. If this option is unchecked, the
software will not remove the noise in the point cloud.

Classify Noise: Please refer to the classify noise tool for details.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be (Smaller
Tower Index_Larger Tower Index). In order not to impact the following steps, it is highly recommended not
to change the file name. After the automatic classification, user need to check the accuracy of the result
and manually modify it in the Profile Tools.



Vector Editing

Summary

Usage

Click Vector Editing > Start/End button, a vector editor toolbar will pop up. Click the button again to end editing.
Vector Editor is as below:

File Editor

Editor

Shortcut Settings

Layer Settings

Insulator Vectorization

Power Line Vectorization

Shield Line Vectorization

Drainage Thread Vectorization

Note: Please classify point cloud data into power line and tower before using vector editor.

Vector Editing is mainly used to vectorize and edit insulator, power line, shield line, drainage thread and
tower.



File Editor

Open Files: Open vector files(.shp .tow *.txt).
Save Files: Interface is as below. Tick the vector layer to be saved. Double click to rename the file. Select
output path and click OK to save the file. The file is saved to vector folder in working directory by default.

Export: Export vector file, including power line and tower.
Power Line: Export vector power line file in .dxf format.
Tower: Export vector tower file in .shp format.



Editor

Select:
Window Selection: Left click to draw a rectangle and entities within the rectangle will be selected.
Select Layers: Click and check the corresponding layer in pop-up window. All entities on this layer will
be selected.
Deselect All: Cancel all selection.

Delete:
Delete Entity: Delete selected entity.
Delete Layers: Delete entity on selected layer.

Vertex Editing: Edit node on entity. Left click to select entity and then drag node to other place.
Undo: Go back to last edition. This tool is not availble while editting.
Redo: Redo last edition. This tool is not availble while editting.
Update: Refresh scene.



Shortcut Settings

Clear Current：Clear current shortcut key settings.
Clear All：Clear all shortcut key settings.

Note: Some shortcut keys have been used for specific operation, please set other shortcut keys.

Set shortcut keys for commonly-used functions in verctorization module.



Layer Settings

Show/Hide: Show/Hide the vector in layers.
Color: Color of vector data in layers.
Line Width (Pixel, 2 by default): Width of vector data in layers.
Line Type (Solid line by default): Line type of polyline in layers, such as solid line, dash line, dotted line.

Settings of vector in layers, including Show/Hide, Color, Line Width and Line Type.



Insulator Vectorization
Insulator Vectorization Toolbar is as below, including Hang Insulator, Edit Insulator, Check Insulator.

Hang Insulator

Clip Tower: Untick by default. If tick this function for editing convenience, then the point cloud file will be
cliped into several seperate files by tower mark and buffer size.
Buffer Size (meter, 10 by default): The half length of the XY plane of the cutting bounding box is used to
control the size of the cutting area.
Current Tower Index: Index of tower being edited.
Insulator Length (meter, 3 by default): Insulator length.
Translate X (meter, 0.1 by default): Set translation distance along X-axis of the last drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the last drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the last drawn insulator.

1. Set tower type and enter tower index corresponding to towers in viewer.

Vectorize insulator. Click Hang Insulator button and a window will pop up. The operation steps are as
below:



2. Use length measurement tool to measure the length of insulator and set average length as insulator length.
3. Left click to pick up hang point(point connecting insulator and power line). For tension tower, insulator is

vectorized as point; for straight line tower, insulator is vectorized as line.
4. Vectorize next insulator, or right click to exit insulator vectorization.

Modify Insulator

Translate X (meter, 0.1 by default): Set translation distance along X-axis of the selected drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the selected drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the selected drawn insulator.

1. Click Modify Insulator button, then click and select the insulator to be edited. Set edit parameters in the pop
up window.

2. Click the right mouse button to hide the dialog and continue to modify the next insulator.
3. After the modification is completed, right-click again to exit the function.

Check Insulator

Note: please add in corresponding tower file(*.LiTower) before using insulator vectorization tools.

Edit position of selected insulator, the operation steps are as below:

Check whether there are coincident insulators in the scene, and if so, delete the coincident insulators.



Power Line Vectorization
Power Line Vectorization Toolbar is as below, including Fitting Power Line Based On Insulators, Fitting Power
Line Based On Point Cloud, Check Power Line and Split Power Line.

Fitting Single Power Line Based On Insulators

1. Left click to pick up insulator hang points on small numbered tower, or right click to end fitting power line by
insulator.

2. If hang points on large numbered tower match them correctly, take step3. If match fails or goes wrong, press
"Z" and left click to pick up corresponding insulator hang point on large numbered tower.

3. Left click to pick up the middle point on the power line.
4. Finish fitting. And repeat former steps.

Batch Fitting Power Lines Based On Insulators

Fitting Single Power Line Based On Point Cloud

1. Left click to pick up power line end point, or right click to end fitting power line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the power line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Fitting Multiple Power Lines Based On Point Cloud

Vectorize each power line by insulators. The operation steps are as below:

For multiple power line spans, users can click Batch Fitting button to batch fit power lines. Set split
numbers in the pop up window. Then click to vectorize power lines. The interface automatically exits
when vectorization completed.

Manually pick up three points on the power line and vectorize the power line. The operation steps are as
below:

For each power line span, pick up two end points(e.g. Pick up center point for each tower). Power lines
between the two towers will be fit automatically. The operation steps are as below:



1. Left click to pick up top center point of the tower1 or right click to end fitting multiple power lines by two
points.

2. Left click to pick up top center point of the tower2 or right click to go back to step1.
3. Right click to finish fitting. And repeat former steps.

Check Power Line

Split Power Line

Split and translate vectorized power lines selected in the viewer.

Split Power Line: Split selected power lines into multiple power lines following the settings.
Slant Distance(meter, 1m by default): The distance between two adjacent vectorized power lines after
splitting.
Split Number(2 by default): Power line split number. There are four options: 2, 4, 6, and 8.
Power Line Position: Power line position before being split, from minor tower to major tower.
Split: Perform split power line operation.

Translate Power Line: Translate selected power lines following the settings.
Keep Original Power Line: Untick by default, and original power line will not be kept. Otherwise the
opposite.
Vertical Line Direction(meter, 1m by default): Translation distance along vertical line direction.
Elevation Direction(meter, 0m by default): Translation distance along Z direction.

Check if there is a coincident vectorized power line in the viewer, and if so, delete the coincident power
line.



Translate: Perform translation power line operation.
Select All: Select all vectorized power lines in the viewer.
Deselect All: Cancel selection of all selected power lines.



Shield Line Vectorization
Shield Line Vectorization Toolbar is as below, including Three Points Fitting Single Shield Line and Batch Fitting
Shield Lines.

Three Points Fitting Single Shield Line

1. Left click to pick up shield line end point, or right click to end fitting shield line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the shield line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Batch Fitting Shield Lines

Manually pick up three points on shield line and vectorize shield line. The operation steps are as below:

For multiple shield line spans, users can click Batch Fitting button to batch fit shield lines.



Drainage Thread Vectorization
Drainage Thread Vectorization toolbar is as below, including Three Points Fitting Single Drainage Thread.

Three Points Fitting Single Drainage Thread

1. Left click to pick up end point of the drainage thread, or right click to end fitting.
2. Left click to pick up another end point of the drainage thread, or right click to get back to step1.
3. Left click to pick up a middle point of the drainage thread, or right click to get back to step2.
4. Finish fitting and repeat former steps.

Manually pick up three points from a single drainage thread and vectorize the drainage thread. The
opearation steps are as below:



Danger Points Detection

Summary

Usage

Click Realtime Analysis > Danger Points Detection

Settings

Detection Parameter:
Cluster By Class: Unchecked by default. Used to control whether to cluster the result by class.If this
option is checked, the danger points will be clustered into different groups if they are in different classes;
otherwise, the class information will not influence the clustering process. The software can record the
user's current settings and automatically restore the settings when opened again.
Min Distance (meters) (default value is "0.3"): Points with clearance distance less than this distance
are not detected as danger points, as they are considered to be noise. The software can record the
user's current settings and automatically restore the settings when opened again.

Judge if the point is a danger point according to the clearance distance and the set safety distance. The
interface of the clearance danger point detect function is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meters) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Clearance Danger Point List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Scissors Crossing Analysis

Summary

Usage

Click Realtime Analysis > Scissors Crossing Analysis

Settings

Detection Parameter:
Cluster Radius (meter) (default value is "3.0"): The maximum spatial distance when clustering
crossing points. The crossing point clusters in the range extract the nearest vertical distance point as the
crossing point of the cluster.
Buffer Size (meter) (default value is "0.5"): The power line point cloud in a certain buffer area near the
horizontal range of cross line will participate in the calculation.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings

Calculate the scissors crossing danger point by cross analysis on the power line and the detected
classes of points. The interface of scissors crossing analysis is shown as follow. This function can
process multiple data simultaneously. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Scissors Crossing Analysis List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Water Analysis

Summary

Usage

Click Realtime Analysis > Water Analysis

Settings

Detection Parameter：
Safe Distance (meter) (default value is "4.5"): The threshold of safety distance. If the distance from
the power line to the waterbody under it is less than this value, the corresponding point on the power line
will be recognized as a danger point.
Density Threshold (/square meter) (default value is "0"): The threshold used to extract the
waterbody from the point cloud. Those areas with point density lower than or equal to this value will be
recognized as "suspected waterbodies". After this extracting, merge the suspected waterbodies close to

Based on the "black hole" in the point cloud data, those continuous hollow areas which meets
requirements in the set parameters will be determined as the water area. Then the software will
calculate the distances from the power line points to the water surface to judge if the point on the power
line is danger point. The interface of water analysis is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



each other.
Smoothing Factor (default is "2"): Smooth the edge of the waterbody. The smaller the value is, the
finer the smoothing effect will be.
Area Threshold (square meter) (default value is "4000"): The threshold to extract the waterbody. If
the detected area is larger than this value, it will be recognized as waterbody.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Tree Growth Analysis

Summary

Usage

Click Early Warning Analysis > Tree Growth Analysis.

Settings

Tree Growth Parameter:
Growth Years (year) (default value is "1"): Set the predicted growth time. The software can record the
user's current settings and automatically restore the settings when opened again.
Constant Growing Speed (default): If this option is checked, “Growth Speed” will be allowed to be set,
and all kinds of trees will be considered to grow at this growth rate.
Growth Rate (meter/year) (default value is "0.3"): Set the tree growth rate. The function can record

Based on the result of individual tree segmentation, calculate and extract the danger points after a
certain period of growth. This function can process multiple data simultaneously. Click to add the
data to be processed. Click to remove the selected data. Click to clear the data list.



the user's current settings and automatically restore the settings when opened again.
Custom Growing Speed for Species: If this option is checked, user can set the growth rate for
different tree species in the table. Tree species files can be generated from Tree Species Classification,
and the default growth rate is 1 meter / year.

Clustering Parameter:
Cluster: This option is unchecked by default. If this option is checked, the software will cluster the result;
otherwise, the software will not cluster the result. The software can record the user's current settings
and automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Clustering Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there
are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be
selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Growth Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Tree Growth Warning Analysis

Summary

Based on the result of individual tree segmentation, calculate the years of each tree to grow to be a danger
tree. The interface of tree growth warning analysis is shown in the figure below. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected data.
Click to clear the data list.

Usage

Click Early Warning Analysis > Tree Growth Warning Analysis.

Settings

Tree Growth Parameter:
Growth Years (year) (default value is "1"): Set the predicted growth time. The software can record the
user's current settings and automatically restore the settings when opened again.
Constant Growing Rate (default): If this option is checked, “Growth Speed” will be allowed to be set,
and all kinds of trees will be considered to grow at this growth rate.
Growth Rate (meter/year) (default value is "0.3"): Set the tree growth rate. The function can record
the user's current settings and automatically restore the settings when opened again.



Custom Growing Speed for Species: If this option is checked, user can set the growth rate for
different tree species in the table. Tree species files can be generated from Tree Species Classification,
and the default growth rate is 1 meter / year.

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there
are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Growth Warning Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.



Tree Fall Analysis

Summary

Usage

Click Early Warning Analysis> Tree Fall Analysis

Settings

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there

Based on the result of individual tree segmentation, analyze the danger points on the trees during the
falling procedure. The interface of tree fall analysis is shown in the figure below. This function can
process multiple data simultaneously. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Detection Parameter:
Cluster: This option is unchecked by default. If this option is checked, the software will cluster the result;
otherwise, the software will not cluster the result. The software can record the user's current settings
and automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Offset Percentage (default value is "0"): The percentage of the tree's horizontal offset relative to the
height of the tree when falling.
Remove Danger Treetop: Not selected by default. If the detected treetops are already a clearance
danger point, when this option is checked, the tool will not record this point; otherwise, it will be
recognized as a danger point. The software can record the user's current settings and automatically
restore the settings when opened again.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be
selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Vaule: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Fall Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Generate Image

Summary

Usage

Click Report > Image

Settings

Image Type: Select the type of danger points need to be rendered in the image.
Clearance Danger: Render the clearance danger point detection result in the image.

Generate images based on the detection results of danger points and the results of individual tree
segmentation, including front views, top views, cross-section views of danger points, and tree height
distribution and tree density distribution. The function interface is shown in the figure below. This
function can process multiple data at the same time. Click to remove the selected data. Click to
clear the data list.



Scissors Crossing: Render the crossing danger point detection result in the image.
Water: Render the waterbody detection result in the image.
Tree Growth: Render the tree growth detection result in the image.
Tree Fall: Render the tree fall detection result in the image.
Tree Height Image: Unchecked by default. If this option is checked, the height distribution map of trees
in the file will be drawn.
Tree Density Image: Unchecked by default. If this option is checked, the density distribution map of
trees in the file will be drawn.

Image Parameter:
Scale Factor (default value is "1.0"): Checked by default. The ratio of the image width to the height
scale. Used to control the degree of deformation of the image height.
Color Setting: Unchecked by default. User can set the color for different classes of point cloud in the
generated image. If the option is unchecked, the image is drawn according to the colors of the point
cloud displayed in the window; otherwise the image is generated according to the customized colors.
The software can record the user's current settings and automatically restore the settings when opened
again.
Front View Width (pixels) (default is "1000"): The width of the front view.
Front View Height (pixels) (default is "450"): Height of the front view.
Top View Width (pixels) (default is "1000"): The width of the top view.
Top View Height (pixels) (default is "350"): Height of the top view.
Profile Thickness (m) (default is "1"): Thickness of point cloud profile when generating danger point
image. The software can record the user's current settings and automatically restore the settings when
opened again.
Point Size (default is "1"): The point size of image. The software can record the user's current settings
and automatically restore the settings when opened again.
Prefix of Tower (optional): In the generated front view and top view images, the prefix of the tower
label. Prefix is empty by default.
Suffix of Tower (optional): In the generated front view and top view images, the suffix of the tower
label. Suffix is empty by default.

Resampling Parameter: Point cloud resampling parameter settings. Used to control image generation
quality. The software can record the user's current settings and automatically restore the settings when
opened again.

Resampling: Unchecked by default. Set whether to resample the point cloud.
Grid size X, Y, Z (meters) (default is "0.5, 0.5, 0.1"): Construct a three-dimensional voxel of X Y Z,
one point is reserved in each voxel.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The tree height image and tree density image are generated based on the individual tree
segmentation results. Users can use Tree Growth Analysis, Tree Fall Analysis or individual tree
segmentation tool to perform the individual tree segmentation.

Note: When this function is executed from a different working condition page, images are generated based
on the corresponding data.



International Report

Summary

The international report is the general version report. It can generate the report based on different data type and
detection type. The interface of "generate report" function is shown as follow. This function can process multiple
data simultaneously. Click to add the data to be processed. Click to remove the selected data. Click to
clear the data list.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Crossing Danger: Clear the crossing danger point detection result in the cache folder.
Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.

Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: Line name.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Point Cloud Coordinate: The coordinate system used in the point cloud data.



Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: Data type and detection type are combined to use. If user wants to generate the clearance and
crossing danger points report based on the point cloud data, they need to choose "Data Based on Point
Cloud" in the data type, and "Clearance Danger Point" and "Crossing Danger Point" in the detection type.
Then set the other parameters, and Click "Start" to generate the report.



Merge Report

Summary

Based on the original reports, the software can merge the reports automatically. This is especially suitable for the
scenarios such as batch data processing and data processing in different projection bands. Click  to add the
working directories need to be processed. Click  to remove the selected working directory. Click  to clear
the working directory list. Click the list item to confirm the working directory information.

Confirm information

After adding the working directories, click the list item to confirm the working directory information.

Confirm Working Directory Information
Start Tower Name: The name of starting tower.
End Tower Name: The name of ending tower.
Point Cloud SRS: The coordinate system of the point cloud.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Crossing Danger: Clear the crossing danger point detection result in the cache folder.



Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.

Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: The name of the power line section.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: To ensure the order of automatic merge, please add the working directories in order.



Clear

Summary

Usage

Click Report > Clear

Settings

Clear File: Select the file types need to be clear.
Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Scissors Crossing: Clear the crossing danger point detection result in the cache folder.
Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Growth Warning: Clear the tree growth warning detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.
Stress Detection: Clear the stress detection result in the cache folder.
Drainage Thread Clearance: Clear the drainage thread creepage distance detection result in the cache

Clear the danger point attributes and the the corresponding file of the point cloud. The interface of clear
function is shown in the figure below. This function can process multiple data simultaneously. Click 
to add the data to be processed. Click to remove the selected data. Click to clear the data list.



folder.
Phase Spacing: Clear the phase spacing detection result in the cache folder.
Sag: Clear the sag analysis result in the cache folder.
Images: Clear the image files in the cache folder.

Clear Attribute: Clear the attribute information of the point cloud.
Clear Danger Attributes: Clear the danger attributes in the point cloud files.
Clear Tree Segmentation: Clear the individual tree segmentation result of the point cloud. And delete
the segmentation result file saved in the cache folder.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: When this function is executed from a different working condition page, the corresponding data is
cleared.



Simulation Condition
To handle and analyze power line channel based on point cloud data and simulated data and then generate
analysis report. Specific functions are as below:

Add Data

Settings

Mark Tower

Line Infomation Collection

Clip and Classify

Classification Tools

Profile Tools

Vector Editing

Danger Points Detection

Scissors Crossing Analysis

Water Analysis

Comprehensive Working Conditions Simulation

Tree Growth Analysis

Tree Fall Analysis

Drainage Thread Simulation Analysis

Current Carrying Capacity Analysis

Generate Image

Generate Report

Merge Report

Clear

Note: Vector data used in this module must be vectorized by insulators.



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from
software (e.g. provided by LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to
produce X, Y, and Z point data. The intention of the data format is to provide an open format that allows different
LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do
some initial settings as shown in the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID,
Generating Software, File Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each
point record. LiPowerline imports all the point attributes by default.

Brief: One of the most useful features of LiPowerline is its ability to interface with data in many file
formats. You can import point clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.), tables,
images (JPG, TIF), models (OSG, LiModel, LiTin) or vectors into LiPowerline. It allows you to visualize,
animate and edit your point cloud as well. Point cloud data will be converted into LiData file at the first
time being added. LiData file is the LiPowerline native file format for point cloud and optimized for
viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.



You can search the coordinate system much more quickly by using regular expressions. For example, the
WGS 84 coordinate system will be displayed instantly when you input EPSG code of WGS 84 system as
shown in the figure below:

You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate
System. Recently used coordinate reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for
current point cloud data only. Apply All means all the point cloud data share the same configuration during
the LiPowerline's running and it won't show this configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z
coordinates and other attributes such as color and normal. These attributes can be simply arranged in one line for
each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do
some initial settings as shown in the figures below:



3. LiPowerline can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by
setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for
spreadsheets and databases. CSV format was used for many years prior to attempts to describe the format in a
standardized way in RFC 4180. The lack of a well-defined standard means that subtle differences often exist in
the data produced and consumed by different applications. These differences can make it troublesome to
process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format
is similar enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do
some initial settings as shown in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The
CSV table contains the ID of each tree, the x, y coordinate locations, the tree height, the crown diameter, and
the crown area properties. The data type could be Point or Circle. If Point type was selected, you should
specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.



Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D
scanners. It is a format for storing graphical objects that are described as a collection of polygons. A PLY file
consists of a header, followed by a list of vertices and then, a list of polygons. The header specifies how many
vertices and polygons are in the file. It also states what properties are associated with each vertex, such as (x, y,
z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary
version for compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII
text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do
some initial settings as shown in the figure below:

3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose
None.

5. Click Apply when you complete your configuration.

Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In
its simplest form, a raster consists of a matrix of cells (pixels) organized into rows and columns (grid) where each
cell contains a value representing information. The geographic location of each cell is implied by its position in the
cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no geographic coordinates are stored.
Due to the nature of the data storage technique data analysis is usually easy to program and quick to perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually
more aesthetically pleasing (traditional cartographic representation). Since most data is in vector form and no
data conversion is required. Accurate geographic location of data is maintained.



1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiPowerline stores triangulated regular network models generated by
DEM or DSM. LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiPowerline directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Settings

Summary

Common Settings

The user can set the working directory, point cloud coordinate system, class and detection parameters, detected
line voltage level and add configuration tables. The software can record the user's last 5 input history records in
settings of the working directory, point cloud coordinate system and classes and detection parameters. User can
select the most recently used item in the drop-down list. The working directory is used to manage the project. The
prj.ini file in the working directory records the point cloud coordinate system, classes and detection parameters,
and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Input Point Cloud Spatial Coordinate: The coordinate system of the point cloud data.
Classification and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected power line.
Add Configuration Table: If the detection line voltage level list is empty and does not contain the current
voltage level, user can add a new voltage level by adding a configuration table and set its safety distance
detection parameters.

Detection Parameter Settings

Power line module parameter settings include common settings and detection parameter settings.
Common settings include working directory settings, point cloud coordinate systems settings, class and
detection parameters settings, detected line voltage level settings; detection parameter settings include
class settings, detection types, and safety distance settings.



Displays key detection classes and safety distance detection parameters. User can add voltage levels and then
configure their corresponding detection parameters, including clearance distance analysis and crossing analysis.
Clearance distance analysis includes detections for different classes of objects, as well as different safety
distance and distance detection methods. For crossing analysis, user only needs to set the classes to be
detected, and user does not need to set a safety distance.

Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If the
distance is less than this value, it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the distance
is less than this value, it is a danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If the
distance is less than this value, it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether to be a
danger point by the horizontal distance. If the distance is less than set horizontal value, it is a danger



point. If the distance is larger than set horizontal value, judge the point whether to be a danger point by
the vertical distance. If the distance is less than the set vertical distance, it is a danger point. If the
distance is larger than the set vertical distance, judge the point whether to be a danger point by the
clearance distance then.

Add Row: Add a new detection class record.
Delete Selected Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Selected Column: Delete the selected column.
Modify Selected Column Name: Modify the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.

Note: In crossing analysis, if user does not select the detection class, software will only analyze the upper
crossing and lower crossing by default.



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower file. After
adding the position information of the tower, the software will automatically generate the index and name
information of the tower. Index is a number starting from the starting value and incrementing by 1. By default,
name is the same as Index. Tower type includes "None", "Tension Tower", and "Straight Line Tower". Double-
click the row for each tower to jump to that tower in the displaying window. By checking or unchecking the
checkbox in front of "display all tower points" to display or hiding the tower points in the window. Point size can be
modified. By clicking the hot key "S" and "D" on the keyboard to move the edited tower record forward or
backward.

Show All Tower Point (checked by default)：Display the tower names or indexes in the window. Uncheck
this option to hide the all the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Point Size (meter) (default value is "5.0"): Set the red marker sphere and text font size of the tower. 



Mark Tower

Add Tower Backward

Add Tower Forward

Delete Tower

Modify Tower Position

Tower Centralization

Click this button to start to pick the tower points. Click again to exit this function and save the current
tower information to the tower.LiTower file in the working directory.

Add a tower record after currently selected record.

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Click this button and the centralize tower window will popup. Click to select several points on the tower,
and click calculate button to get the center point of the tower. Click the function button again to exit this
function, and the tower information will be stored in the tower.LiTower file in the working directory.



Import Tower File
Input the tower file and renew the tower list in LiTower, txt, csv, and kml file. If the input file is in kml
format, user can use KML Tower Position Editor to load the tower information. If the input file is in txt or
csv format, user can follow the steps below to load the tower information.



1. Adjust the data type for each column, and select the number of skipped rows and the type of separator.
2. If the input data's coordinates are in latitude and longitude, user can check the “Transform” option in

Conversion tab to convert the geographic coordinates into projected coordinates.
3. Click "Apply" to import the tower file and renew the tower list.

Export Tower File

1. Select the export file format, including LiTower and KML formats. User can choose the export types of point,
line, point and line when selecting KML.

2. Set the output path.
3. Click "OK" to export the tower file.

Batch Edit Tower Name

Export the information in the current tower list to LiTower or kml file.



Right-click on the "Name" column in the tower list, and the popup selection menu is shown in the figure below,
including adding prefixes, adding suffixes, and batch modification. It can be used to add prefixes, suffixes, or both
to the tower names.

Batch Edit Tower Type

Right-click on the "Type" column in the tower list, and the popup selection menu is shown in the figure below,
including setting as a straight line tower and setting as a tension tower. User can modify the tower type as a
straight line tower or a tension tower in batches.



Line Information Collection

Power Line Type

Collection Time

Line information collection includes power line type and collection time.



Power Line Type

Summary

Select the transmission tower type (straight line tower / tension tower) and then set the line type between each
two towers. Save the power line type file.

Usage

Click Collection > Information > Power Line Type.

Open File

Save File

Add Power Line Type

Open the power line type file

Save the power line type file. The default output path is the information folder in the working directory.
The results are in the "SectionPowerLineType.csv" file.

Add a new power line type, and set the start and end transmission towers name.



Delete Power Line Type

Modify Power Line Type

Check Availability

Delete the selected power line type.

Modify the selected power line type.

Check if there is any overlap in the power line type of different pylon sections.



Collection Time

Summary

Set the collection time in different pylon sections.

Usage

Click Collection > Information > Collection Time.

Open File

Save File

Add Collection Time

Open the collection time file.

Save the collection time file. The default output path is the information folder in the working directory.
The results are in the "CollectionTime.csv" file.

Set the start and end transmission towers name, and set the collection time.



Delete Collection Time

Modify Collection Time

Check Availability

Delete the selected collection time.

Modify the selected collection time.

Check if there is any overlap in the collection time of different pylon sections.



Clip and Classify

Summary

Usage

Click Clip/Classify > Clip and Classify.

Settings

Clipping and classifying the point cloud data into segments. The Classification process will classify the
transmission tower, power line, ground points, and noise in the point cloud. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Output Path: Set the output path.
Clip (Checked by default): Clip the data into segments. If this option is unchecked, the data will not be
clipped.

Channel Width (meter) (default value is "60"): Width extending along both sides of the power line.
The software can record the user's current settings and automatically restore the settings when opened
again.
Segment Buffer (meter) (default value is "10"): Extension distance at both ends of the transmission
tower.
Start Tower Index: Towers with index numbers smaller than this value do not participate in gear
shifting. The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers greater than this value do not participate in gear shifting.
The default value is the maximum Index in the tower file.
Resampling (Unchecked by default): Resampling the processed data.

Classification (Checked by default): Perform classification operations, including shield line, ground point,
power line, tower and building.

Classify Power line and Tower (By Machine Learning is checked by default): Use deep learning
strategy to classify the power line and transmission tower.
Classify Ground Points: Please refer to the classify ground points tool for details.
Classify Building Points: Please refer to the classify building points tool for details.
Use GPU Acceleration(Checked by default): Use GPU to accelerate classification operations.

Filter Noise (Checked by default): Remove the noise in the point cloud. If this option is unchecked, the
software will not remove the noise in the point cloud.

Classify Noise: Please refer to the classify noise tool for details.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be (Smaller
Tower Index_Larger Tower Index). In order not to impact the following steps, it is highly recommended not
to change the file name. After the automatic classification, user need to check the accuracy of the result
and manually modify it in the Profile Tools.



Vector Editing

Summary

Usage

Click Vector Editing > Start/End button, a vector editor toolbar will pop up. Click the button again to end editing.
Vector Editor is as below:

File Editor

Editor

Shortcut Settings

Layer Settings

Insulator Vectorization

Power Line Vectorization

Shield Line Vectorization

Drainage Thread Vectorization

Note: Please classify point cloud data into power line and tower before using vector editor.

Vector Editing is mainly used to vectorize and edit insulator, power line, shield line, drainage thread and
tower.



File Editor

Open Files: Open vector files(.shp .tow *.txt).
Save Files: Interface is as below. Tick the vector layer to be saved. Double click to rename the file. Select
output path and click OK to save the file. The file is saved to vector folder in working directory by default.

Export: Export vector file, including power line and tower.
Power Line: Export vector power line file in .dxf format.
Tower: Export vector tower file in .shp format.



Editor

Select:
Window Selection: Left click to draw a rectangle and entities within the rectangle will be selected.
Select Layers: Click and check the corresponding layer in pop-up window. All entities on this layer will
be selected.
Deselect All: Cancel all selection.

Delete:
Delete Entity: Delete selected entity.
Delete Layers: Delete entity on selected layer.

Vertex Editing: Edit node on entity. Left click to select entity and then drag node to other place.
Undo: Go back to last edition. This tool is not availble while editting.
Redo: Redo last edition. This tool is not availble while editting.
Update: Refresh scene.



Shortcut Settings

Clear Current：Clear current shortcut key settings.
Clear All：Clear all shortcut key settings.

Note: Some shortcut keys have been used for specific operation, please set other shortcut keys.

Set shortcut keys for commonly-used functions in verctorization module.



Layer Settings

Show/Hide: Show/Hide the vector in layers.
Color: Color of vector data in layers.
Line Width (Pixel, 2 by default): Width of vector data in layers.
Line Type (Solid line by default): Line type of polyline in layers, such as solid line, dash line, dotted line.

Settings of vector in layers, including Show/Hide, Color, Line Width and Line Type.



Insulator Vectorization
Insulator Vectorization Toolbar is as below, including Hang Insulator, Edit Insulator, Check Insulator.

Hang Insulator

Clip Tower: Untick by default. If tick this function for editing convenience, then the point cloud file will be
cliped into several seperate files by tower mark and buffer size.
Buffer Size (meter, 10 by default): The half length of the XY plane of the cutting bounding box is used to
control the size of the cutting area.
Current Tower Index: Index of tower being edited.
Insulator Length (meter, 3 by default): Insulator length.
Translate X (meter, 0.1 by default): Set translation distance along X-axis of the last drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the last drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the last drawn insulator.

1. Set tower type and enter tower index corresponding to towers in viewer.

Vectorize insulator. Click Hang Insulator button and a window will pop up. The operation steps are as
below:



2. Use length measurement tool to measure the length of insulator and set average length as insulator length.
3. Left click to pick up hang point(point connecting insulator and power line). For tension tower, insulator is

vectorized as point; for straight line tower, insulator is vectorized as line.
4. Vectorize next insulator, or right click to exit insulator vectorization.

Modify Insulator

Translate X (meter, 0.1 by default): Set translation distance along X-axis of the selected drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the selected drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the selected drawn insulator.

1. Click Modify Insulator button, then click and select the insulator to be edited. Set edit parameters in the pop
up window.

2. Click the right mouse button to hide the dialog and continue to modify the next insulator.
3. After the modification is completed, right-click again to exit the function.

Check Insulator

Note: please add in corresponding tower file(*.LiTower) before using insulator vectorization tools.

Edit position of selected insulator, the operation steps are as below:

Check whether there are coincident insulators in the scene, and if so, delete the coincident insulators.



Power Line Vectorization
Power Line Vectorization Toolbar is as below, including Fitting Power Line Based On Insulators, Fitting Power
Line Based On Point Cloud, Check Power Line and Split Power Line.

Fitting Single Power Line Based On Insulators

1. Left click to pick up insulator hang points on small numbered tower, or right click to end fitting power line by
insulator.

2. If hang points on large numbered tower match them correctly, take step3. If match fails or goes wrong, press
"Z" and left click to pick up corresponding insulator hang point on large numbered tower.

3. Left click to pick up the middle point on the power line.
4. Finish fitting. And repeat former steps.

Batch Fitting Power Lines Based On Insulators

Fitting Single Power Line Based On Point Cloud

1. Left click to pick up power line end point, or right click to end fitting power line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the power line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Fitting Multiple Power Lines Based On Point Cloud

Vectorize each power line by insulators. The operation steps are as below:

For multiple power line spans, users can click Batch Fitting button to batch fit power lines. Set split
numbers in the pop up window. Then click to vectorize power lines. The interface automatically exits
when vectorization completed.

Manually pick up three points on the power line and vectorize the power line. The operation steps are as
below:

For each power line span, pick up two end points(e.g. Pick up center point for each tower). Power lines
between the two towers will be fit automatically. The operation steps are as below:



1. Left click to pick up top center point of the tower1 or right click to end fitting multiple power lines by two
points.

2. Left click to pick up top center point of the tower2 or right click to go back to step1.
3. Right click to finish fitting. And repeat former steps.

Check Power Line

Split Power Line

Split and translate vectorized power lines selected in the viewer.

Split Power Line: Split selected power lines into multiple power lines following the settings.
Slant Distance(meter, 1m by default): The distance between two adjacent vectorized power lines after
splitting.
Split Number(2 by default): Power line split number. There are four options: 2, 4, 6, and 8.
Power Line Position: Power line position before being split, from minor tower to major tower.
Split: Perform split power line operation.

Translate Power Line: Translate selected power lines following the settings.
Keep Original Power Line: Untick by default, and original power line will not be kept. Otherwise the
opposite.
Vertical Line Direction(meter, 1m by default): Translation distance along vertical line direction.
Elevation Direction(meter, 0m by default): Translation distance along Z direction.

Check if there is a coincident vectorized power line in the viewer, and if so, delete the coincident power
line.



Translate: Perform translation power line operation.
Select All: Select all vectorized power lines in the viewer.
Deselect All: Cancel selection of all selected power lines.



Shield Line Vectorization
Shield Line Vectorization Toolbar is as below, including Three Points Fitting Single Shield Line and Batch Fitting
Shield Lines.

Three Points Fitting Single Shield Line

1. Left click to pick up shield line end point, or right click to end fitting shield line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the shield line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Batch Fitting Shield Lines

Manually pick up three points on shield line and vectorize shield line. The operation steps are as below:

For multiple shield line spans, users can click Batch Fitting button to batch fit shield lines.



Drainage Thread Vectorization
Drainage Thread Vectorization toolbar is as below, including Three Points Fitting Single Drainage Thread.

Three Points Fitting Single Drainage Thread

1. Left click to pick up end point of the drainage thread, or right click to end fitting.
2. Left click to pick up another end point of the drainage thread, or right click to get back to step1.
3. Left click to pick up a middle point of the drainage thread, or right click to get back to step2.
4. Finish fitting and repeat former steps.

Manually pick up three points from a single drainage thread and vectorize the drainage thread. The
opearation steps are as below:



Danger Points Detection

Summary

Usage

Click Realtime Analysis > Danger Points Detection

Settings

Detection Parameter:
Cluster By Class: Unchecked by default. Used to control whether to cluster the result by class.If this
option is checked, the danger points will be clustered into different groups if they are in different classes;
otherwise, the class information will not influence the clustering process. The software can record the
user's current settings and automatically restore the settings when opened again.
Min Distance (meters) (default value is "0.3"): Points with clearance distance less than this distance
are not detected as danger points, as they are considered to be noise. The software can record the
user's current settings and automatically restore the settings when opened again.

Judge if the point is a danger point according to the clearance distance and the set safety distance. The
interface of the clearance danger point detect function is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meters) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Clearance Danger Point List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Scissors Crossing Analysis

Summary

Usage

Click Realtime Analysis > Scissors Crossing Analysis

Settings

Detection Parameter:
Cluster Radius (meter) (default value is "3.0"): The maximum spatial distance when clustering
crossing points. The crossing point clusters in the range extract the nearest vertical distance point as the
crossing point of the cluster.
Buffer Size (meter) (default value is "0.5"): The power line point cloud in a certain buffer area near the
horizontal range of cross line will participate in the calculation.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings

Calculate the scissors crossing danger point by cross analysis on the power line and the detected
classes of points. The interface of scissors crossing analysis is shown as follow. This function can
process multiple data simultaneously. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Scissors Crossing Analysis List.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Water Analysis

Summary

Usage

Click Realtime Analysis > Water Analysis

Settings

Detection Parameter：
Safe Distance (meter) (default value is "4.5"): The threshold of safety distance. If the distance from
the power line to the waterbody under it is less than this value, the corresponding point on the power line
will be recognized as a danger point.
Density Threshold (/square meter) (default value is "0"): The threshold used to extract the
waterbody from the point cloud. Those areas with point density lower than or equal to this value will be
recognized as "suspected waterbodies". After this extracting, merge the suspected waterbodies close to

Based on the "black hole" in the point cloud data, those continuous hollow areas which meets
requirements in the set parameters will be determined as the water area. Then the software will
calculate the distances from the power line points to the water surface to judge if the point on the power
line is danger point. The interface of water analysis is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



each other.
Smoothing Factor (default is "2"): Smooth the edge of the waterbody. The smaller the value is, the
finer the smoothing effect will be.
Area Threshold (square meter) (default value is "4000"): The threshold to extract the waterbody. If
the detected area is larger than this value, it will be recognized as waterbody.

Vector File: Input the vector file in shp format. The software can record the user's current settings and user
can restore the settings in the drop-down menu or select button next time when opening this function.
Simulation File: Input the simulation file (*.LiSim file). The software can record the user's current settings
and user can restore the settings in the drop-down menu or select button next time when opening this
function.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Comprehensive Working Conditions Simulation

Summary

Usage

Click Early Warning Analysis > Comprehensive Working Condition Simulation Analysis.

Comprehensive working condition simulation analysis can simulate and analyze the power line status in
different wind, high temperature and ice cover conditions. According to the type of tower, it can be
divided into continuous segment and isolated segment. The continuous segment refers to the tension
section composed of several straight line towers. The isolated segment is an independent segment with
a tension tower tower at both ends, which is analyzed using the isolated gear method. The interface of
comprehensive working condition simulation analysis is shown in the figure below. Click to add the
vector data to be processed. Click to remove the selected vector data. Click to clear the vector
data list.



Settings

Voltage Level: Select the voltage level in the drop-down list. The default value is the voltage level in the
settings step.
Power Line Type: Select the power line type from the drop-down list, or user can enter key words to search.
If there is no desired record in the list, user can add a new type of power line with "Add Power Line Type"
function. The software can record the user's current settings and automatically restore the settings when
opened again.

Power Line Specifications: View the corresponding specifications of the current power line type.
Add New Power Line Type: Add a new type of power line.

Power Line Type File: Select piecewise power line type file. Simulate the working conditions in different
segments with different power lines.
Scanning Conditions: Conditions when the data were collected. The software can record the user's current
settings and automatically restore the settings when opened again.

Wire Temperature (Celsius): Wire temperature during the scanning.
Ice Thickness (mm): The thickness of ice one the wire during the scanning.
Wind Speed (m/s): Wind speed during the scanning.

Simulation Conditions: Simulated operating conditions. The software can record the user's current settings
and automatically restore the settings when opened again.

Wire Temperature (Celsius): The temperature of the wire under simulated conditions.
Ice thickness (mm): The thickness of ice under simulated conditions.
Wind speed (m/s): Wind speed under simulated conditions.

Start Tower Index: Set the index of the starting tower.
End Tower Index: Set the index of the ending tower.
Wind Deflection Process:

Wind Deflection Process: This option is unchecked by default. If this option is checked, the software
will interpolate the maximum wind deflection angle according to the interpolation angle to simulate the
swing of the wire during the wind deflection. If this option is unchecked, the software will simulate the
maximum wind deflection on both sides of the wire.
Interpolation Angle (degrees) (default is "5"): Angle used to interpolate the maximum wind deflection
angle.

Insulator File: Set the input vector file for the insulators.
Output Shp File: Select the path of the simulated Shp file to be output after the analysis.
Output Simulation File: Select the path of the simulation file to be output after the analysis.

Note: To execute this function, user needs to set the type of the transmission tower in Mark Tower. If the
power line in continuous segments are incomplete, the simulation analysis cannot be done, and the power
line in the output file will be missing as well.



Tree Growth Analysis

Summary

Usage

Click Early Warning Analysis > Tree Growth Analysis.

Settings

Tree Growth Parameter:
Growth Years (year) (default value is "1"): Set the predicted growth time. The software can record the
user's current settings and automatically restore the settings when opened again.
Constant Growing Speed (default): If this option is checked, “Growth Speed” will be allowed to be set,
and all kinds of trees will be considered to grow at this growth rate.
Growth Rate (meter/year) (default value is "0.3"): Set the tree growth rate. The function can record

Based on the result of individual tree segmentation, calculate and extract the danger points after a
certain period of growth. This function can process multiple data simultaneously. Click to add the
data to be processed. Click to remove the selected data. Click to clear the data list.



the user's current settings and automatically restore the settings when opened again.
Custom Growing Speed for Species: If this option is checked, user can set the growth rate for
different tree species in the table. Tree species files can be generated from Tree Species Classification,
and the default growth rate is 1 meter / year.

Clustering Parameter:
Cluster: This option is unchecked by default. If this option is checked, the software will cluster the result;
otherwise, the software will not cluster the result. The software can record the user's current settings
and automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Clustering Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there
are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be
selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Growth Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Tree Fall Analysis

Summary

Usage

Click Early Warning Analysis> Tree Fall Analysis

Settings

Tree Segmentation Parameter:
Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there

Based on the result of individual tree segmentation, analyze the danger points on the trees during the
falling procedure. The interface of tree fall analysis is shown in the figure below. This function can
process multiple data simultaneously. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



are too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances
greater than this value are used for individual tree segmentation, and less than this value will not be
segmented.

Detection Parameter:
Cluster: This option is unchecked by default. If this option is checked, the software will cluster the result;
otherwise, the software will not cluster the result. The software can record the user's current settings
and automatically restore the settings when opened again.
Cluster Threshold (meter) (default value is "15.0"): The maximum spatial separation distance when
the detection results are clustered. This value should be smaller than the maximum clustering range.
Three-dimensional Euclidean clustering is used to cluster the danger points. The software can record
the user's current settings and automatically restore the settings when opened again.
Max Cluster Range (meter) (default value is "20.0"): After the detection results are clustered, if the
length along the power line direction is greater than this value, they are divided into multiple dangerous
point clusters. The software can record the user's current settings and automatically restore the settings
when opened again.
Safe Distance (meter) (default value is "4.5"): If the distance between the detected point and the
power line point is greater than the minimum distance and less than or equal to the safe distance, the
point is considered to be a danger point. If the xml file is not set, user needs to enter the safety distance;
otherwise, this parameter is extracted from the xml file. When using the xml to set the parameter, user
can set different safety distances for different classes, and for different severity level.
Offset Percentage (default value is "0"): The percentage of the tree's horizontal offset relative to the
height of the tree when falling.
Remove Danger Treetop: Not selected by default. If the detected treetops are already a clearance
danger point, when this option is checked, the tool will not record this point; otherwise, it will be
recognized as a danger point. The software can record the user's current settings and automatically
restore the settings when opened again.

Vector File: Set vector file in shp format. The software can record the user's current settings, and can be
selected through the drop-down menu or selection button when it is opened again.
Simulation File: Set the input simulation file (*.LiSim file).
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Vaule: Restore the default parameter settings.

Note: After the analysis, user can check the result accuracy in Tree Fall Analysis List.

Note: If the individual tree segmentation operation has been performed on the point cloud, this step will not
be performed and the analysis will be performed directly. If user wants to perform individual tree
segmentation again, user needs to clear the segmentation result with the Clear function, and then perform
this operation, or directly execute the Individual Tree Segmentation function.

Note: If user opens the function from the vector real-time working conditions module, user needs to set the
vector file; if user opens the function from the simulation working conditions module, user needs to set the
working conditions simulation file.



Drainage Thread Working Conditions Simulation

Summary

Usage

Click Early Warning Analysis > Drainage Thread Simulation Analysis.

Settings

Voltage Level: Select the voltage level in the drop-down list. The default value is the voltage level in the
settings step.
Drainage Thread Type: Select the drainage thread type from the drop-down list, or user can enter key

According to the input vector of the drainage thread, the working conditions can be simulated for each
isolated segment. The conditions includes strong wind, high temperature, and ice cover. The simulation
interface of the drainage thread condition is shown in the figure below.



words to search. The software can record the user's current settings and automatically restore the settings
when opened again.

Wire Specifications: View the corresponding specifications of the current drainage thread type.
Scanning Conditions: Conditions when the data were collected. The software can record the user's current
settings and automatically restore the settings when opened again.

Wire Temperature (Celsius): Wire temperature during the scanning.
Ice Thickness (mm): The thickness of ice one the wire during the scanning.
Wind Speed (m / s): Wind speed during the scanning.

Simulated Operating Conditions: Simulated operating conditions. The software can record the user's
current settings and automatically restore the settings when opened again.

Wire Temperature (Celsius): The temperature of the wire under simulated conditions.
Ice thickness (mm): The thickness of ice under simulated conditions.
Wind speed (m / s): Wind speed under simulated conditions.

Interpolation Angle (degrees) (default is "5"): Angle used to interpolate the maximum wind deflection
angle.
Input Shp File: Select the shp file for the drainage thread for working condition simulation.
Output Shp File: Select the path of the simulated Shp file to be output after the analysis.



Current Carrying Capacity Analysis

Background

The current carrying capacity and temperature of the power line are important parameters for operation and
design. At present, there are two main methods for increasing the current carrying capacity of high-voltage
overhead transmission lines: static capacity increase and temperature calculation. Based on the thermal balance
equation, the design code of China gives the formula for calculating the allowable current carrying capacity of
overhead transmission line conductors. It is the most commonly used formula for calculating the current carrying
capacity in China. In practical applications, the calculation direction opposite to the above is more applicable in
the design steps of the power transmission project, that is, given the maximum allowable carrying capacity, the
amount to be calculated is the temperature or temperature rise of the power line. Reference of the algorithm: (Lin
et al., 2012)

Summary

The carrying capacity analysis function is mainly used to calculate the temperature rise of the power line under a
certain ambient temperature and carrying capacity. The function interface is shown in the figure below.

Usage

Click Early Warning Analysis > Current Carrying Capacity Analysis.



Settings

Power Line Type: Select the power line type. After selecting any power line type, the electrical parameters
below will change accordingly. Currently, only cored power line types are supported, such as "steel core
aluminum stranded conductor" LGJ-300 / 40, where "300" represents the diameter of the power line and "40"
represents the diameter of the steel core.
Electrical Parameter: Parameters related to the power line. Among them, "DC resistance at 20℃", "inner
diameter of the power line", "outer diameter of the power line", and "calculated cross-sectional area" will be
automatically read from the file according to the selected power line type, without adjustment.



Current Frequency (Hz) (default value is "50.0"): Current frequency of AC resistance.
Environment Parameter: Environment-related parameters. Need to adjust according to the actual situation.
The "radiation heat dissipation coefficient" and "strand surface heat absorption coefficient" are both 0.9, and
no adjustment is required.

Sun Irradiance (W/m^2) (default value is "1000"): Heat from the sun absorbed per square meter of
the power line.
Wind Speed (m/s) (default value is "0.5"): Wind speed of the environment where the power line is
located.
Resistance at 20℃ (per degree Celsius) (default value is "0.004040"): DC resistance of the power
line at 20℃.

Initial Parameter:
Ambient Temperature (Celsius) (default is "40"): The actual temperature of the environment where
the wire is power line.
Input Carrying Capacity(Ampere): The current passing through the power line.
Power Line Temperature Simulated(Celsius): Output the actual power line temperature simulated
under the above environmental conditions.

    @inproceedings{
        author={Lin},
        title={The Calculation of Current Carrying Capacity and Temperature of High Voltage Overhead Lines},
        booktitle={SOUTHERN POWER SYSTEM TECHNOLOGY, 6(4):23-27},
        year={2012},
    }



Generate Image

Summary

Usage

Click Report > Image

Settings

Image Type: Select the type of danger points need to be rendered in the image.
Clearance Danger: Render the clearance danger point detection result in the image.

Generate images based on the detection results of danger points and the results of individual tree
segmentation, including front views, top views, cross-section views of danger points, and tree height
distribution and tree density distribution. The function interface is shown in the figure below. This
function can process multiple data at the same time. Click to remove the selected data. Click to
clear the data list.



Scissors Crossing: Render the crossing danger point detection result in the image.
Water: Render the waterbody detection result in the image.
Tree Growth: Render the tree growth detection result in the image.
Tree Fall: Render the tree fall detection result in the image.
Tree Height Image: Unchecked by default. If this option is checked, the height distribution map of trees
in the file will be drawn.
Tree Density Image: Unchecked by default. If this option is checked, the density distribution map of
trees in the file will be drawn.

Image Parameter:
Scale Factor (default value is "1.0"): Checked by default. The ratio of the image width to the height
scale. Used to control the degree of deformation of the image height.
Color Setting: Unchecked by default. User can set the color for different classes of point cloud in the
generated image. If the option is unchecked, the image is drawn according to the colors of the point
cloud displayed in the window; otherwise the image is generated according to the customized colors.
The software can record the user's current settings and automatically restore the settings when opened
again.
Front View Width (pixels) (default is "1000"): The width of the front view.
Front View Height (pixels) (default is "450"): Height of the front view.
Top View Width (pixels) (default is "1000"): The width of the top view.
Top View Height (pixels) (default is "350"): Height of the top view.
Profile Thickness (m) (default is "1"): Thickness of point cloud profile when generating danger point
image. The software can record the user's current settings and automatically restore the settings when
opened again.
Point Size (default is "1"): The point size of image. The software can record the user's current settings
and automatically restore the settings when opened again.
Prefix of Tower (optional): In the generated front view and top view images, the prefix of the tower
label. Prefix is empty by default.
Suffix of Tower (optional): In the generated front view and top view images, the suffix of the tower
label. Suffix is empty by default.

Resampling Parameter: Point cloud resampling parameter settings. Used to control image generation
quality. The software can record the user's current settings and automatically restore the settings when
opened again.

Resampling: Unchecked by default. Set whether to resample the point cloud.
Grid size X, Y, Z (meters) (default is "0.5, 0.5, 0.1"): Construct a three-dimensional voxel of X Y Z,
one point is reserved in each voxel.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The tree height image and tree density image are generated based on the individual tree
segmentation results. Users can use Tree Growth Analysis, Tree Fall Analysis or individual tree
segmentation tool to perform the individual tree segmentation.

Note: When this function is executed from a different working condition page, images are generated based
on the corresponding data.



International Report

Summary

The international report is the general version report. It can generate the report based on different data type and
detection type. The interface of "generate report" function is shown as follow. This function can process multiple
data simultaneously. Click to add the data to be processed. Click to remove the selected data. Click to
clear the data list.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Crossing Danger: Clear the crossing danger point detection result in the cache folder.
Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.

Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: Line name.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Point Cloud Coordinate: The coordinate system used in the point cloud data.



Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: Data type and detection type are combined to use. If user wants to generate the clearance and
crossing danger points report based on the point cloud data, they need to choose "Data Based on Point
Cloud" in the data type, and "Clearance Danger Point" and "Crossing Danger Point" in the detection type.
Then set the other parameters, and Click "Start" to generate the report.



Merge Report

Summary

Based on the original reports, the software can merge the reports automatically. This is especially suitable for the
scenarios such as batch data processing and data processing in different projection bands. Click  to add the
working directories need to be processed. Click  to remove the selected working directory. Click  to clear
the working directory list. Click the list item to confirm the working directory information.

Confirm information

After adding the working directories, click the list item to confirm the working directory information.

Confirm Working Directory Information
Start Tower Name: The name of starting tower.
End Tower Name: The name of ending tower.
Point Cloud SRS: The coordinate system of the point cloud.

Settings

Data Type: Select the data type to be processed. The data type includes point cloud based data, vector
based data, and data based on working conditions simulation. The software can record the user's current
settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the powerline data from the original point cloud data.
Based on Vector Data: Extract the powerline data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the powerline data from the simulation file, and other classes
objects from original point cloud data.

Detection Type: User can select multiple options. Set the detection type, and generate corresponding
reports.

Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Crossing Danger: Clear the crossing danger point detection result in the cache folder.



Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.

Generate Report: Set the parameters for report generation.
Assessor Company: The company which generates the report.
Electrical Bureau: The name of power supply bureau or company.
Line Name: The name of the power line section.
Voltage Level: Cannot be changed by user.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Simulation File: If user choose to generate the report based on the simulated working conditions data, it is
required to set the simulation file (*.LiSim file).

Note: To ensure the order of automatic merge, please add the working directories in order.



Clear

Summary

Usage

Click Report > Clear

Settings

Clear File: Select the file types need to be clear.
Clearance Danger: Clear the clearance danger point detection result in the cache folder.
Scissors Crossing: Clear the crossing danger point detection result in the cache folder.
Water: Clear the waterbody detection result in the cache folder.
Tree Growth: Clear the tree growth detection result in the cache folder.
Tree Growth Warning: Clear the tree growth warning detection result in the cache folder.
Tree Fall: Clear the tree fall detection result in the cache folder.
Stress Detection: Clear the stress detection result in the cache folder.
Drainage Thread Clearance: Clear the drainage thread creepage distance detection result in the cache

Clear the danger point attributes and the the corresponding file of the point cloud. The interface of clear
function is shown in the figure below. This function can process multiple data simultaneously. Click 
to add the data to be processed. Click to remove the selected data. Click to clear the data list.



folder.
Phase Spacing: Clear the phase spacing detection result in the cache folder.
Sag: Clear the sag analysis result in the cache folder.
Images: Clear the image files in the cache folder.

Clear Attribute: Clear the attribute information of the point cloud.
Clear Danger Attributes: Clear the danger attributes in the point cloud files.
Clear Tree Segmentation: Clear the individual tree segmentation result of the point cloud. And delete
the segmentation result file saved in the cache folder.

Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: When this function is executed from a different working condition page, the corresponding data is
cleared.



Completion Acceptance
Completion Acceptance is suitable for completion analysis of power line and tower. Based on point cloud data,
vector data and working condition simulation data, this module analyzes different components of the line and
generates analysis report. The specific functions are as below:

Add Data

Settings

Mark Tower

Clip and Classify

Classification Tools

Profile Tools

Vector Editing

Sag Analysis

Phase Spacing Analysis

Drainage Thread Clearance Analysis

Spacer Analysis

Tension Tower Rotation Analysis



Add Data

Import LAS/LAZ File

The LAS file is intended to contain LiDAR point data records. The data will generally be put into this format from
software (e.g. provided by LiDAR hardware vendors) which combines GPS, IMU, and laser pulse range data to
produce X, Y, and Z point data. The intention of the data format is to provide an open format that allows different
LiDAR hardware and software tools to output data in a common format.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the LAS file you want to import and click Open for the Open LAS File window where you can do
some initial settings as shown in the figures below:

3. Click tab Header to check general LAS file header information such as Version, Source ID, System ID,
Generating Software, File Creation Day/Year, Header Byte Size, Data Offset, Number of Point Records etc.

4. Click tab Attribute Option to set Crop Option and decide which point attributes you want to import for each
point record. LiPowerline imports all the point attributes by default.

Brief: One of the most useful features of LiPowerline is its ability to interface with data in many file
formats. You can import point clouds (LAS/LAZ, TXT, PLY, ASC, NEU, XYZ, PTS, CSV etc.), tables,
images (JPG, TIF), models (OSG, LiModel, LiTin) or vectors into LiPowerline. It allows you to visualize,
animate and edit your point cloud as well. Point cloud data will be converted into LiData file at the first
time being added. LiData file is the LiPowerline native file format for point cloud and optimized for
viewing.



5. Click tab Coordinate Option to set the coordinate system for your point records.



You can search the coordinate system much more quickly by using regular expressions. For example, the
WGS 84 coordinate system will be displayed instantly when you input EPSG code of WGS 84 system as
shown in the figure below:

You can also import coordinate system form WKT or PRJ by clicking drop-down menu Add Coordinate
System. Recently used coordinate reference systems holds a history list.

6. Click Apply or Apply All when you finish your configuration. Apply implies that you want this configuration for
current point cloud data only. Apply All means all the point cloud data share the same configuration during
the LiPowerline's running and it won't show this configuration window again even you add new data.

Import TXT File

A point cloud is a set of vertices in a three-dimensional coordinate system usually defined by X, Y, and Z
coordinates and other attributes such as color and normal. These attributes can be simply arranged in one line for
each point record and one single TXT file for one-point set.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the TXT file you want to import and click Open for the Open Ascii File window where you can do
some initial settings as shown in the figures below:



3. LiPowerline can automatically detect the delimiters but you can also specify delimiter manually.

4. There are indeed cells that are colored red in the import window if TXT file has a header. Just skip them by
setting Skip line value to 1.

5. Use the drop-downs to give the proper form of your point records.

Import CSV File

The so-called CSV (Comma Separated Values) format is the most common import and export format for
spreadsheets and databases. CSV format was used for many years prior to attempts to describe the format in a
standardized way in RFC 4180. The lack of a well-defined standard means that subtle differences often exist in
the data produced and consumed by different applications. These differences can make it troublesome to
process CSV files from multiple sources. Still, while the delimiters and quoting characters vary, the overall format
is similar enough that it is possible to write a single module which can efficiently manipulate such data.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the CSV file you want to import and click Open for the Open ASCII File window where you can do
some initial settings as shown in the figures below:



CSV file can be opened as table or point cloud.

3. Open as Table is recommended if the CSV file is the resultant product of the Segmentation function. The
CSV table contains the ID of each tree, the x, y coordinate locations, the tree height, the crown diameter, and
the crown area properties. The data type could be Point or Circle. If Point type was selected, you should
specify the X,Y,Z columns additionally.

If Circle type was selected, you should specify the center and radius.

Click Show Label radio button to show/hide label for each point or circle.

4. The Import TXT File section has more detailed descriptions if you Open as Point Cloud.



Import PLY File

The polygon (PLY) file format, also known as the Stanford triangle format stores three-dimensional data from 3-D
scanners. It is a format for storing graphical objects that are described as a collection of polygons. A PLY file
consists of a header, followed by a list of vertices and then, a list of polygons. The header specifies how many
vertices and polygons are in the file. It also states what properties are associated with each vertex, such as (x, y,
z) coordinates, normals, and color. The file format has two sub-formats: an ASCII representation and a binary
version for compact storage and for rapid saving and loading. The header of both ASCII and binary files is ASCII
text.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the PLY file you want to import and click Open for the Open PLY File window where you can do
some initial settings as shown in the figure below:

3. Specify properties that associated with each vertex's coordinates(x,y,z).

4. Specify properties that associated with each vertex's color (r,g,b) if they have any. Otherwise, simply choose
None.

5. Click Apply when you complete your configuration.

Import Raster File

A raster data structure is based on a (usually rectangular, square-based) tessellation of the 2D plane into cells. In
its simplest form, a raster consists of a matrix of cells (pixels) organized into rows and columns (grid) where each
cell contains a value representing information. The geographic location of each cell is implied by its position in the
cell matrix. Accordingly, other than an origin point, e.g. bottom left corner, no geographic coordinates are stored.
Due to the nature of the data storage technique data analysis is usually easy to program and quick to perform.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Raster file and click Open.

Import Vector File

Vector data can be represented at its original resolution and form without generalization. Graphic output is usually
more aesthetically pleasing (traditional cartographic representation). Since most data is in vector form and no
data conversion is required. Accurate geographic location of data is maintained.



1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Vector file and click Open.

Import Model File

LiModel file is the native file format where LiPowerline stores triangulated regular network models generated by
DEM or DSM. LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud.

1. Click File > Data > Add Data to view the Open Data window.

2. Choose the Model file and click Open.

Note: You can drag file(s) into LiPowerline directly. If you can't, click here for more help.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Settings

Summary

Common Settings

The user can set the working directory, point cloud coordinate system, class and detection parameters, detected
line voltage level and add configuration tables. The software can record the user's last 5 input history records in
settings of the working directory, point cloud coordinate system and classes and detection parameters. User can
select the most recently used item in the drop-down list. The working directory is used to manage the project. The
prj.ini file in the working directory records the point cloud coordinate system, classes and detection parameters,
and voltage level of the current project.

Working Directory: Used to save the intermediate and final results.
Input Point Cloud Spatial Coordinate: The coordinate system of the point cloud data.
Classification and Detection Parameters: Set the path of the xml format configuration file.
Detected Line Voltage Level: The voltage level of the detected power line.
Add Configuration Table: If the detection line voltage level list is empty and does not contain the current
voltage level, user can add a new voltage level by adding a configuration table and set its safety distance
detection parameters.

Detection Parameter Settings

Power line module parameter settings include common settings and detection parameter settings.
Common settings include working directory settings, point cloud coordinate systems settings, class and
detection parameters settings, detected line voltage level settings; detection parameter settings include
class settings, detection types, and safety distance settings.



Displays key detection classes and safety distance detection parameters. User can add voltage levels and then
configure their corresponding detection parameters, including clearance distance analysis and crossing analysis.
Clearance distance analysis includes detections for different classes of objects, as well as different safety
distance and distance detection methods. For crossing analysis, user only needs to set the classes to be
detected, and user does not need to set a safety distance.

Select: Whether to detect this class.
Checked (default): Detect the danger point in this class.
Unchecked (default): Do not detect the danger point in this class.

Class: Select the number (from 1 to 32) of the class in the drop-down menu.
Detection Type: Select the detection type in the drop-down menu.

Clearance Distance: Judge the point whether to be a danger point by the clearance distance. If the
distance is less than this value, it is a danger point.
Vertical Distance: Judge the point whether to be a danger point by the vertical distance. If the distance
is less than this value, it is a danger point.
Horizontal Distance: Judge the point whether to be a danger point by the horizontal distance. If the
distance is less than this value, it is a danger point.
Horizontal Distance / Vertical Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the vertical distance.
Horizontal Distance / Clearance Distance: Firstly judge the point whether to be a danger point by the
horizontal distance. If the distance is less than set horizontal value, it is a danger point. If the distance is
larger than set horizontal value, judge the point whether to be a danger point by the clearance distance.
Horizontal Distance / Vertical Distance / Clearance Distance: Firstly judge the point whether to be a
danger point by the horizontal distance. If the distance is less than set horizontal value, it is a danger



point. If the distance is larger than set horizontal value, judge the point whether to be a danger point by
the vertical distance. If the distance is less than the set vertical distance, it is a danger point. If the
distance is larger than the set vertical distance, judge the point whether to be a danger point by the
clearance distance then.

Add Row: Add a new detection class record.
Delete Selected Row: Delete the selected row of detection class.
Add Column: Add a new column for a severity level threshold. I.E., severe, important, and general.
Delete Selected Column: Delete the selected column.
Modify Selected Column Name: Modify the name of selected column.
Save: Save the configuration to the current xml file.
Save as: Save the configuration as a new xml file.

Note: In crossing analysis, if user does not select the detection class, software will only analyze the upper
crossing and lower crossing by default.



Mark Tower

Summary

After clicking in the point cloud data and choosing the tower type, user can save the result into LiTower file. After
adding the position information of the tower, the software will automatically generate the index and name
information of the tower. Index is a number starting from the starting value and incrementing by 1. By default,
name is the same as Index. Tower type includes "None", "Tension Tower", and "Straight Line Tower". Double-
click the row for each tower to jump to that tower in the displaying window. By checking or unchecking the
checkbox in front of "display all tower points" to display or hiding the tower points in the window. Point size can be
modified. By clicking the hot key "S" and "D" on the keyboard to move the edited tower record forward or
backward.

Show All Tower Point (checked by default)：Display the tower names or indexes in the window. Uncheck
this option to hide the all the tower names or indexes.
By Index: Display the tower index.
By Name: Display the tower name.
Point Size (meter) (default value is "5.0"): Set the red marker sphere and text font size of the tower. 



Mark Tower

Add Tower Backward

Add Tower Forward

Delete Tower

Modify Tower Position

Tower Centralization

Click this button to start to pick the tower points. Click again to exit this function and save the current
tower information to the tower.LiTower file in the working directory.

Add a tower record after currently selected record.

Add a tower record before currently selected record.

Delete the current selected tower record.

Modify the position of the selected tower.

Click this button and the centralize tower window will popup. Click to select several points on the tower,
and click calculate button to get the center point of the tower. Click the function button again to exit this
function, and the tower information will be stored in the tower.LiTower file in the working directory.



Import Tower File
Input the tower file and renew the tower list in LiTower, txt, csv, and kml file. If the input file is in kml
format, user can use KML Tower Position Editor to load the tower information. If the input file is in txt or
csv format, user can follow the steps below to load the tower information.



1. Adjust the data type for each column, and select the number of skipped rows and the type of separator.
2. If the input data's coordinates are in latitude and longitude, user can check the “Transform” option in

Conversion tab to convert the geographic coordinates into projected coordinates.
3. Click "Apply" to import the tower file and renew the tower list.

Export Tower File

1. Select the export file format, including LiTower and KML formats. User can choose the export types of point,
line, point and line when selecting KML.

2. Set the output path.
3. Click "OK" to export the tower file.

Batch Edit Tower Name

Export the information in the current tower list to LiTower or kml file.



Right-click on the "Name" column in the tower list, and the popup selection menu is shown in the figure below,
including adding prefixes, adding suffixes, and batch modification. It can be used to add prefixes, suffixes, or both
to the tower names.

Batch Edit Tower Type

Right-click on the "Type" column in the tower list, and the popup selection menu is shown in the figure below,
including setting as a straight line tower and setting as a tension tower. User can modify the tower type as a
straight line tower or a tension tower in batches.



Clip and Classify

Summary

Usage

Click Clip/Classify > Clip and Classify.

Settings

Clipping and classifying the point cloud data into segments. The Classification process will classify the
transmission tower, power line, ground points, and noise in the point cloud. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Output Path: Set the output path.
Clip (Checked by default): Clip the data into segments. If this option is unchecked, the data will not be
clipped.

Channel Width (meter) (default value is "60"): Width extending along both sides of the power line.
The software can record the user's current settings and automatically restore the settings when opened
again.
Segment Buffer (meter) (default value is "10"): Extension distance at both ends of the transmission
tower.
Start Tower Index: Towers with index numbers smaller than this value do not participate in gear
shifting. The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers greater than this value do not participate in gear shifting.
The default value is the maximum Index in the tower file.
Resampling (Unchecked by default): Resampling the processed data.

Classification (Checked by default): Perform classification operations, including shield line, ground point,
power line, tower and building.

Classify Power line and Tower (By Machine Learning is checked by default): Use deep learning
strategy to classify the power line and transmission tower.
Classify Ground Points: Please refer to the classify ground points tool for details.
Classify Building Points: Please refer to the classify building points tool for details.
Use GPU Acceleration(Checked by default): Use GPU to accelerate classification operations.

Filter Noise (Checked by default): Remove the noise in the point cloud. If this option is unchecked, the
software will not remove the noise in the point cloud.

Classify Noise: Please refer to the classify noise tool for details.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default Value: Restore the default parameter settings.

Note: The segmented data will be stored in the output path folder. The name of the file will be (Smaller
Tower Index_Larger Tower Index). In order not to impact the following steps, it is highly recommended not
to change the file name. After the automatic classification, user need to check the accuracy of the result
and manually modify it in the Profile Tools.



Vector Editing

Summary

Usage

Click Vector Editing > Start/End button, a vector editor toolbar will pop up. Click the button again to end editing.
Vector Editor is as below:

File Editor

Editor

Shortcut Settings

Layer Settings

Insulator Vectorization

Power Line Vectorization

Shield Line Vectorization

Drainage Thread Vectorization

Note: Please classify point cloud data into power line and tower before using vector editor.

Vector Editing is mainly used to vectorize and edit insulator, power line, shield line, drainage thread and
tower.



File Editor

Open Files: Open vector files(.shp .tow *.txt).
Save Files: Interface is as below. Tick the vector layer to be saved. Double click to rename the file. Select
output path and click OK to save the file. The file is saved to vector folder in working directory by default.

Export: Export vector file, including power line and tower.
Power Line: Export vector power line file in .dxf format.
Tower: Export vector tower file in .shp format.



Editor

Select:
Window Selection: Left click to draw a rectangle and entities within the rectangle will be selected.
Select Layers: Click and check the corresponding layer in pop-up window. All entities on this layer will
be selected.
Deselect All: Cancel all selection.

Delete:
Delete Entity: Delete selected entity.
Delete Layers: Delete entity on selected layer.

Vertex Editing: Edit node on entity. Left click to select entity and then drag node to other place.
Undo: Go back to last edition. This tool is not availble while editting.
Redo: Redo last edition. This tool is not availble while editting.
Update: Refresh scene.



Shortcut Settings

Clear Current：Clear current shortcut key settings.
Clear All：Clear all shortcut key settings.

Note: Some shortcut keys have been used for specific operation, please set other shortcut keys.

Set shortcut keys for commonly-used functions in verctorization module.



Layer Settings

Show/Hide: Show/Hide the vector in layers.
Color: Color of vector data in layers.
Line Width (Pixel, 2 by default): Width of vector data in layers.
Line Type (Solid line by default): Line type of polyline in layers, such as solid line, dash line, dotted line.

Settings of vector in layers, including Show/Hide, Color, Line Width and Line Type.



Insulator Vectorization
Insulator Vectorization Toolbar is as below, including Hang Insulator, Edit Insulator, Check Insulator.

Hang Insulator

Clip Tower: Untick by default. If tick this function for editing convenience, then the point cloud file will be
cliped into several seperate files by tower mark and buffer size.
Buffer Size (meter, 10 by default): The half length of the XY plane of the cutting bounding box is used to
control the size of the cutting area.
Current Tower Index: Index of tower being edited.
Insulator Length (meter, 3 by default): Insulator length.
Translate X (meter, 0.1 by default): Set translation distance along X-axis of the last drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the last drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the last drawn insulator.

1. Set tower type and enter tower index corresponding to towers in viewer.

Vectorize insulator. Click Hang Insulator button and a window will pop up. The operation steps are as
below:



2. Use length measurement tool to measure the length of insulator and set average length as insulator length.
3. Left click to pick up hang point(point connecting insulator and power line). For tension tower, insulator is

vectorized as point; for straight line tower, insulator is vectorized as line.
4. Vectorize next insulator, or right click to exit insulator vectorization.

Modify Insulator

Translate X (meter, 0.1 by default): Set translation distance along X-axis of the selected drawn insulator.
Translate Y (meter, 0.1 by default): Set translation distance along Y-axis of the selected drawn insulator.
Translate Z (meter, 0.1 by default): Set translation distance along Z-axis of the selected drawn insulator.

1. Click Modify Insulator button, then click and select the insulator to be edited. Set edit parameters in the pop
up window.

2. Click the right mouse button to hide the dialog and continue to modify the next insulator.
3. After the modification is completed, right-click again to exit the function.

Check Insulator

Note: please add in corresponding tower file(*.LiTower) before using insulator vectorization tools.

Edit position of selected insulator, the operation steps are as below:

Check whether there are coincident insulators in the scene, and if so, delete the coincident insulators.



Power Line Vectorization
Power Line Vectorization Toolbar is as below, including Fitting Power Line Based On Insulators, Fitting Power
Line Based On Point Cloud, Check Power Line and Split Power Line.

Fitting Single Power Line Based On Insulators

1. Left click to pick up insulator hang points on small numbered tower, or right click to end fitting power line by
insulator.

2. If hang points on large numbered tower match them correctly, take step3. If match fails or goes wrong, press
"Z" and left click to pick up corresponding insulator hang point on large numbered tower.

3. Left click to pick up the middle point on the power line.
4. Finish fitting. And repeat former steps.

Batch Fitting Power Lines Based On Insulators

Fitting Single Power Line Based On Point Cloud

1. Left click to pick up power line end point, or right click to end fitting power line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the power line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Fitting Multiple Power Lines Based On Point Cloud

Vectorize each power line by insulators. The operation steps are as below:

For multiple power line spans, users can click Batch Fitting button to batch fit power lines. Set split
numbers in the pop up window. Then click to vectorize power lines. The interface automatically exits
when vectorization completed.

Manually pick up three points on the power line and vectorize the power line. The operation steps are as
below:

For each power line span, pick up two end points(e.g. Pick up center point for each tower). Power lines
between the two towers will be fit automatically. The operation steps are as below:



1. Left click to pick up top center point of the tower1 or right click to end fitting multiple power lines by two
points.

2. Left click to pick up top center point of the tower2 or right click to go back to step1.
3. Right click to finish fitting. And repeat former steps.

Check Power Line

Split Power Line

Split and translate vectorized power lines selected in the viewer.

Split Power Line: Split selected power lines into multiple power lines following the settings.
Slant Distance(meter, 1m by default): The distance between two adjacent vectorized power lines after
splitting.
Split Number(2 by default): Power line split number. There are four options: 2, 4, 6, and 8.
Power Line Position: Power line position before being split, from minor tower to major tower.
Split: Perform split power line operation.

Translate Power Line: Translate selected power lines following the settings.
Keep Original Power Line: Untick by default, and original power line will not be kept. Otherwise the
opposite.
Vertical Line Direction(meter, 1m by default): Translation distance along vertical line direction.
Elevation Direction(meter, 0m by default): Translation distance along Z direction.

Check if there is a coincident vectorized power line in the viewer, and if so, delete the coincident power
line.



Translate: Perform translation power line operation.
Select All: Select all vectorized power lines in the viewer.
Deselect All: Cancel selection of all selected power lines.



Shield Line Vectorization
Shield Line Vectorization Toolbar is as below, including Three Points Fitting Single Shield Line and Batch Fitting
Shield Lines.

Three Points Fitting Single Shield Line

1. Left click to pick up shield line end point, or right click to end fitting shield line by three points.
2. Left click to pick up another end point or right click to go back to step1.
3. Left click to pick up middle point of the shield line or right click to go back to step2.
4. Finish fitting. And repeat former steps.

Batch Fitting Shield Lines

Manually pick up three points on shield line and vectorize shield line. The operation steps are as below:

For multiple shield line spans, users can click Batch Fitting button to batch fit shield lines.



Drainage Thread Vectorization
Drainage Thread Vectorization toolbar is as below, including Three Points Fitting Single Drainage Thread.

Three Points Fitting Single Drainage Thread

1. Left click to pick up end point of the drainage thread, or right click to end fitting.
2. Left click to pick up another end point of the drainage thread, or right click to get back to step1.
3. Left click to pick up a middle point of the drainage thread, or right click to get back to step2.
4. Finish fitting and repeat former steps.

Manually pick up three points from a single drainage thread and vectorize the drainage thread. The
opearation steps are as below:



Sag Analysis

Summary

Usage

Click Completion Analysis > Sag Analysis.

Settings

Sag Analysis: This option is checked by default. If this option is checked, the software will calculate the sag,
length, and wind deflection angle information. If this option is unchecked, the analysis will not be done.

Observed Temperature (Celsius): The temperature of the power line when scanning the transmission

According to vector file or simulation file, analyze the sags, the length, and the wind deflection angle of
the power line, shield line, and drainage thread. And then save the analysis result (csv or xls file) and
generate the analysis report. The interface of this function is shown as follow. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
file. Click to clear the data list.



line.
Observed Wind Speed (meter / second): The wind speed when scanning the transmission line.
Power Line File: Set the input power line file for sag analysis, the data format can be .shp or .LiSim.
Shield Line File: Set the input shield line file for sag analysis, the data format can be .shp.
Drainage Thread File: Set the input drainage thread file for sag analysis, the data format can be .shp.
Output Path: The output path for the analysis result. The default path is cache/SagAnalysis/ in the
working directory.

Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Report Name: The title of the report.
Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Number(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.



Phase Spacing Analysis

Summary

Usage

Click Completion Analysis > Phase Spacing Analysis

Settings

Phase Spacing Analysis: This option is checked by default. If it is checked, the software will perform phase
spacing analysis; if not, the function will not be executed.

Profile Thickness (meter) (default value is "5.0"): The thickness of the cross profile of the power line
which is used to extract the point cloud for calculating. The software can record the currently setting and
when the user open this function again, the setting will be kept.

This function is used to calculate and analyze the distances between power lines, and then generate the
analysis report. The phase spacing will change if the distance is too long or too short; the temperature is
too high; or the line is broken. Click to add the data to be processed. Click to remove the
selected data. Click to clear the data list.



Cluster Threshold (meter) (default value is "3.5"): The maximum spatial separation distance when
the point cloud data is clustered. Power line points smaller than the threshold will be clustered into a
cluster. The software can record the currently setting and when the user open this function again, the
setting will be kept.

Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Report Name: The title of the report.
Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Number(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.

Note: After the detection, the software will export the detection result file for each segment. User can check
the accuracy of the analysis in phase spacing anaylsis list. Each row contains a phase spacing. And the
name, coordinates of the target point, and the point cloud it belongs to will be recorded in different
columns.



Drainage Thread Clearance Analysis

Summary

Usage

Click Completion Analysis > Drainage Thread Clearance Analysis.

Settings

This function is used to calculate and analyze the clearance distances between the drainage threads
and the transmission towers, and generate the analysis report. When the clearance distance between
the drainage thread and the transmission tower is too small, it will become very dangerous. Before
executing this function, user needs to classify the drainage thread and transmission tower in the point
cloud. This function can process multiple data simultaneously. Click to add the data to be processed.
Click to remove the selected file. Click to clear the data list.



Drainage Thread Analysis: This option is checked by default. If this option is checked, the software will
perform drainage thread clearance analysis. If this option is unchecked, the analysis will not be done.

Cluster Threshold (meter) (default value is "2.0"): The maximum distance for the point cloud data
clustering. If the distance between two points is less than this value, they will be considered as on the
same drainage thread. Thus, user should input a value that the distances between most of the points on
the same drainage thread are less than. When the clustering splits the same drainage thread into
several ones, user needs to increase this value. When more than one drainage threads are clustered as
one, user needs to decrease this value.
Standard Distance (meter) (default value is "3.0"): The standard distance from the drainage thread to
the transmission tower. It is disqualified if the distance from the drainage thread to the transmission
tower is less than this value. The software can record the currently setting and when the user open this
function again, the setting will be kept.
Shp File: This option is unchecked by default. If this option is checked, the position information of the
drainage threads will be extracted from the input shp file. If this option is unchecked, the position
information of the drainage thread will be extracted from the point cloud. The software can record the
currently setting and when the user open this function again, the setting will be kept.
Distance to Tower Body: This option is unchecked by default. If this option is checked, the clearance
distance from the drainage thread to the tower body (without the cross arms) will be calculated. If this
option is unchecked, the clearance distance from the drainage thread to the tower body (the cross arms
included) will be calculated.

Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Report Name: The title of the report.
Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.
Report Path: The output path of the report.

Threads Number(default value is "4"): Set the number of thread (1 to 32) to run this function. The software
can record the currently setting and when the user open this function again, the setting will be kept.



Tension Tower Rotation Angle Analysis

Summary

Usage

Click Completion Analysis > Tension Tower Rotation Analysis.

Settings

Rotation Angle Analysis: This option is checked by default. If it is checked, the software will perform
tension tower rotation analysis; if not, the function will not be executed.
Generate Report: This option is checked by default. If this option is checked the analysis report will be
generated; if the option is unchecked, the analysis report will not be generated.

Report Name: The title of the report.
Assessor Company: The company which generates the report.
Electrical Transmission Bureau/Company: The name of power supply bureau or company.
Line Name: Line name.
Collection Date: The date on which point cloud was collected.
Target Coordinate: The coordinate system used in the report.

Used to calculate the tension tower rotation angle, and then generate the analysis report. The interface
of this function is shown as follow. This function can process multiple data simultaneously. Click to
add the data to be processed. Click to remove the selected file. Click to clear the data list.



Report Path: The output path of the report.



Measurement
To measure different components of the power line channel such as tower or conductors, based on point cloud
data. And generate anlaysis report. Specific functions are as below:

Measure Minimum Distance

Measure Tower Inclination

Measure Rotation Angle

Measure Cross Arms Height Difference

Measure Tower Nominal Height

Measure Phase Spacing Distance

Fine Tower Account



Measure Minimum Distance

Summary

Measure the minimum distance in horizontal/vertical/space method from the ground object to the power line
and the pylon with smaller index. Choose the type of distance, and left-click in the view window to pick the point
on the target object to measure the minimum distance.

Usage

Click Measurement > Measure Minimum Distance

Note: Note: To use this function, the classification of the power line is required. If the tower file (.LiTower
file) is not set, only the minimum distance to the power line will be displayed.



Measure Tower Inclination

Summary

By selecting the top and bottom points on the tower, calculate the tower inclination rate and the tower
height along the line direction and vertical line direction. And save the result in the specified directory

Usage

Click Measurement > Measure Tower Inclination.



Tower Point List

Calculate

Calculate the tower inclination according to the picked points. And display the result in the result list.

Add top tower points.

Add bottom tower points.

Delete all the tower points.

Modify the selected tower point.

Clear tower points. This function includes "Clear Top Points", "Clear Bottom Points", and "Clear All
Points".



Result List

Parameters

Tower Name: Name of the target tower.
Tower Height (meter): The tower height information fetched from the point cloud data.
Tilt Rate of Line Direction: The inclination of the transmission tower along the main direction connecting
with the next transmission tower.
Tilt Rate of Vertical Line Direction: The inclination of the tower along the direction perpendicular to the
main direction of the line connecting to the next tower.
Standard Value: If tower tilt rate is lower than this value, this tower is consider qualified.

Tower Inclination Report

Save the tower inclination file and generate the report.

Open the tower inclination file.

Save the tower inclination file. The default position to save the information is the "TowerInclination.txt"
file in the tower analysis folder in the working directory.

Delete the selected record.

Clear the records in the list.



Parameters

Please refer to Report Parameters for details.

Note: Before using this tool, user needs to classify the transmission tower in the point cloud.

Note: The tower tilt rate is the percentage of the ratio of the tower tilt value S to the height above the
ground H; that is, the tilt rate = the tilt value / the entire height of the tower.



Measure Rotation Angle

Summary

Usage

Click Measurement > Measure Rotation Angle。

Steps

1. After starting the "Measure Rotation Angle" tool, select power line points on the left and right sides of the
tension tower and tower points, and the result will be displayed in the scene in real-time. Rotation angle will
be displayed in "degree" rather than "radian". The result is the angle less than 180 degrees.

2. Right-click to call the menu, and choose "Back One Point" in order to cancel the last point picking; choose
"Clear Measurement" to cancel the point picking of all the points; and choose "Quit" to quit the measurement.

This function is used to measure the rotation angle of the tension tower, as is shown below:



Measure Cross Arms Height Difference

Summary

Usage

Click Measurement > Measure Cross Arms Height Difference

By selecting the cross arm points on the transmission tower, calculate the hight difference between the
left and right cross arms. And save the measurement result to the specified directory.

Open the height difference of cross arms file.

Save the height difference of cross arms file. The default output path is the tower analysis folder in the
working directory. The default file name is "CrossArmsHeightDifference.txt".

Delete the selected record in the result list.



Parameters

Please refer to Report Parameters for details.

Clear the results in the result list.

Height difference of cross arms report.



Measure Tower Nominal Height

Summary

Usage

Click Measurement > Measure Tower Nominal Height.

Open

Nominal height is the vertical distance from the tower cross arms (the lowest cross arms) to the
construction base surface of the tower center pile (the longest tower leg footplate or the top surface of
the foundation). By select the bottom cross arms point on the pylon, calculate the nominal height and
save to the specified directory.

Open the nominal height file.



Save

Delete Selected Record

Clear Result

Open the nominal height file.

Save the nominal height file. The default location to save the result is the "NominalHeight.txt" file in the
tower analysis folder in the working directory.

Delete the selected record in the result file.

Clear the result list.



Measure Phase Spacing Distance

Summary

Usage

Click Measurement > Measure Phase Spacing Distance

Select any point on the power line, create a profile with this point, calculate the phase distance (the default profile
distance is 10m, that is, 5m to the left and right of the selected point), and display the result on the user interface
in real time.

Profile Thickness (meter) (default value is "5.0"): The thickness of the cross profile of the power line
which is used to extract the point cloud for calculating. The software can record the currently setting and
when the user open this function again, the setting will be kept.
Cluster Threshold (meter) (default value is "3.5"): The maximum spatial separation distance when the
point cloud data is clustered. Power line points smaller than the threshold will be clustered into a cluster. The
software can record the currently setting and when the user open this function again, the setting will be kept.
Default: Default value will be set when click this button;

This function is similar to the "Phase Spacing Analysis" function. Phase spacing analysis is used to
calculate the all the phase spacing of all the phases between each two transmission tower. While the
measure phase spacing distance function can measure the phase spacing at any position in between
each two transmission towers.



Note: To use this function, the classification of the power line is required.



Fine Tower Account

Summary

Usage

Click Measurement > Fine Tower Account.

Tower Point List

Select the point on the tower leg to generate the fine tower account.

Open the tower leg point file.

Save the tower leg point file. The default output path is the tower analysis folder in the working directory.
The default file name is "TowerLegBottomPoint.txt".

Add tower leg points. The method of adding is to add a line on the outside of the four tower legs, and the
intersection point of the line and the ground is the tower leg point. As shown below:



Generate Fine Tower Account

Save tower leg file and generate fine tower account.

Delete the selected tower leg point.

Clear the tower leg points.



Note: Before using this tool, user needs to classify the ground points in the point cloud.



Toolbox
Toolbox contains point cloud processing, result finishing, and other tools, which is used to process and analyze
the point cloud data. The toolbox includes the following tools.

Point Cloud Processing

Strip Clip

Individual Tree Segmentation

Sample and Convert

Merge Point Cloud and Vector Data

Export Mixed Color Point Cloud

Result Finishing

Export Danger Points to KML File

Extract Danger Point Clouds

Extract Danger Trees

Tower Account

Section Map

Other Tools

Open Working Directory



Strip Clip

Summary

Usage

Click Toolbox > Point Cloud Processing > Strip Clip

Settings

Channel Width (meter) (default is "60"): Width extending to both sides of the power line. The software can
record the user's current settings and automatically restore the settings when opened again.
Segment Buffer (meter) (default value is "10"): Extension distance at both ends of the transmission tower.
Start Tower Index: Towers with index numbers smaller than this value are not involved in the calculation.
The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The

Input a point cloud has not been segmented and the tower information, and this tool will clip the point
cloud data into several parts along the power line. The function interface is shown in the figure below.
This function can process multiple data at the same time. Click to add the data to be processed.
Click to remove the selected data. Click to clear the data list.



default value is the maximum Index in the tower file.
Output File: The output path of the result file.



Individual Tree Segmentation

Summary

Usage

Click Toolbox > Point Cloud Processing > Individual Tree Segmentation

Settings

Smoothing Factor (default value is "1.5"): Individual tree segmentation smoothing coefficient. If there are
too many trees, increase the smoothing factor, otherwise, decrease the smoothing factor.
Height Above Ground (meter) (default value is "1.0"): Point clouds above ground by distances greater
than this value are used for individual tree segmentation, and less than this value will not be segmented.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: If the point cloud has been segmented, user must clear the result of individual tree segmentation
before redoing the segmentation.

Perform individual tree segmentation for the input point cloud data. The function interface is shown in
the figure below. This function can process multiple data at the same time. Click to add the data to
be processed. Click to remove the selected data. Click to clear the data list.



Sample and Convert

Summary

Usage

Click Toolbox > Point Cloud Processing > Sample and Convert

Settings

Grid Size X, Y, Z (meters) (default is "0.1, 0.1, 0.1"): Construct a three-dimensional voxel of X by Y by Z.
Each voxel retains one point after the sampling.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

　Diluting the point cloud data based on the set parameters of sampling, and convert the las file to the
LiData file. The result will be stored in the sibling folder of the las file. The function interface is shown in
the figure below. This function can process multiple data at the same time. Click to add the data to
be processed. Click to remove the selected data. Click to clear the data list.



Merge Point Cloud and Vector Data

Summary

Merge the input point cloud and vector data, and generate the point cloud in the specified format. This function is
used to improve the point cloud quality when the power line point cloud is thin or partially missing. The function
interface is shown in the figure below. This function can process multiple data simultaneously. Click </img>to
add the data to be processed. Click to remove the selected data. Click to clear the data list.</p></div>

Usage

Click Toolbox > Point Cloud Processing > Merge Point Cloud and Vector Data

Settings

Delete Original Power Line Points: Unchecked by default. If this option is checked, the newly generated
point cloud will not contain the power line class points in the original data; otherwise, the power line points in
the original data will be kept.
Line Width (millimeter) (default value is "30"): The width of the power line generated from the vector data.
Point Spacing (meter) (default value is "0.01"): The spacing of each two adjacent power line points
generated from the vector data.



Discrete Points Number (default value is "10"): The discrete points number generated for each point in
the vector data. The larger this value is, the more dense the result point cloud will be.
Vector File: Set the path of the vector file.
Output Path: Set the path of output file.
Output File Format: The output format of the result, supporting lidata and las format.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.



Export Mixed Color Point Cloud

Summary

This function is used to generate the point cloud with color mixed by class and RGB color information of the
ground objects. The function interface is shown in the figure below. This function can process multiple data at the
same time. Click </img>to add the data to be processed. Click to remove the selected data. Click to
clear the data list.</p></div>

Usage

Click Toolbox > Point Cloud Processing > Export Mixed Color Point Cloud

Settings

Output Path: Set the path of the output file.
Classification: The class(es) of the points that need to be export with the color of those class(es). In the
result, the points with selected class(es) will be displayed in the color of those classes, and the other points
will be displayed in RGB, when the data is set to Display by RGB.
Output File Format: The output format of the result, supporting lidata and las format.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: The input data must have attribute of RGB color.



Export Danger Points

Summary

Usage

Click Toolbox > Result Finishing > Export Dangerous Points

Settings

Clearance Data Type: Select the data type to be processed. The data type includes point cloud based data,
vector based data, and data based on working conditions simulation. The software can record the user's
current settings and automatically restore the settings when opened again.

Based on Point Cloud: Extract the power line data from the original point cloud data.
Based on Vector Data: Extract the power line data from the vector file, and other classes objects from
original point cloud data.
Based on Simulation Data: Extract the power line data from the simulation file, and other classes
objects from original point cloud data.

Output File: The output path of the kml file.

Export the clearance danger points into kml file, which can be viewed in Google Earth.



Extract Danger Point Clouds

Summary

Usage

Click Toolbox > Result Finishing > Extract Danger Point Clouds

Settings

Output Path: Set the output path of the result file.
Output File Format: The output format of the result, supporting lidata and las format.

Note: The new point cloud will only be generated when the original point cloud contains danger points;
otherwise, no point cloud will be generated.

After the clearance danger point detection, extract the points marked as "dangerous point" and generate
a new point cloud file. The function interface is shown in the figure below. This function can process
multiple data simultaneously. Click to add the data to be processed. Click to remove the selected
data. Click to clear the data list.



Extract Danger Trees

Summary

Usage

Click Toolbox > Result Finishing > Extract Danger Trees

Settings

Output Path: Set the output path of the result file.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.

Note: It is required to perform clearance danger point detection and individual tree segmentation before
executing this function.

Based on the result of clearance danger point detection and individual tree segmentation, extract all the
trees with danger points as parts of them. The function interface is shown in the figure below. This
function can process multiple data simultaneously. Click to add the data to be processed. Click 
to remove the selected data. Click to clear the data list.



Tower Account

Summary

Usage

Click Toolbox > Result Finishing > Tower Account

Settings

Power Line Name: Set the name of transmission line.
Output File: Set the output path of the tower account.

Note: The input point cloud must contain the point in transmission tower class. The tower file (LiTower file)
corresponding to the transmission line must be in the project folder (working directory).

Generate the tower account (xls file) based on the point cloud data and the tower file (LiTower file). The
function interface is shown in the figure below. This function can process multiple data simultaneously.
Click to add the data to be processed. Click to remove the selected data. Click to clear the
data list.



Section Map

Summary

Usage

Click Toolbox > Result Finishing > Section Map

Generate the power line section map based on the point cloud data. The function interface is shown in
the figure below. This function can process multiple data simultaneously. Click to add the data to be
processed. Click to remove the selected data. Click to clear the data list.



Settings

Power Line Name: Set the name of transmission line. The software can record the user's current settings
and automatically restore the settings when opened again.
Start Tower Index: Towers with index numbers smaller than this value are not involved in the calculation.
The default value is the minimum Index in the tower file.
End Tower Index: Towers with index numbers larger than this value are not involved in the calculation. The
default value is the maximum Index in the tower file.
Top View Zoom Ratio (default value is "1"): Set the top view zoom ratio.
Side View Zoom Ratio (default value is "1"): Set the side view zoom ratio.
Top View Font Size (default value is "15"): Set the top view font size.
Side View Font Size (default value is "20"): Set the side view font size.
Grid Row Spacing (meters) (default value is "30"): Set the grid row spacing.
Grid Column Spacing (meters) (default value is "30"): Set the grid column spacing.
Horizontal Scale (default value is "1/2000"): Set the horizontal scale.
Vertical Scale (default is "1/2000"): Set the vertical scale.
Left Line Color: Set the color of the left line.
Middle Line Color: Set the color of the middle line.
Right Line Color: Set the color of the right side line.
Output Path: Set the output path of the section maps.
Logo File: Set the logo file path.
Threads Number (default value is "4"): Set the number of thread (1 to 32) to run this function. The
software can record the currently setting and when the user open this function again, the setting will be kept.



Open Working Directory

Summary
Open the working directory of the current power line project.



Detection Result List
Detection result lists include clearance danger point list, crossing analysis list, tree growth analysis list, tree
growth warning analysis list, tree fall analysis list, drainage thread clearance analysis list, phase spacing analysis
list, and sag analysis list. User can use these tools to view the results of detection and check the accuracy of the
results.

Clearance Danger Points List

Scissors Crossing Analysis List

Tree Growth Analysis List

Tree Growth Warning Analysis List

Tree Fall Analysis List

Allowable Stress Analysis List

Drainage Thread Clearance Analysis List

Phase Spacing Analysis List

Sag Analysis List



Clearance Danger Points List

Summary

Clearance danger points list contains the result of the clearance danger points analysis. The interface of this tool
is shown as follow. Double-click the row of the danger point record to zoom to that point in the 3D scene.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Data Type

Choose the data type, and the software will list the detection result of the corresponding data type.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point

Load or renew the detection result list.



cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.



Scissors Crossing Analysis List

Summary

Scissors crossing analysis list contains the result of the scissors crossing analysis. The interface of this tool is
shown as follow. Double-click the row of the danger point record to zoom to that point in the 3D scene.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Tree Growth Analysis List

Summary

Tree growth analysis list records the result of tree growth analysis, as is shown below. Each row contains the
coordinates of the danger treetop point and coordinates of the point on the power line which is closest to the
treetop.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: When the option "Customize the growth rates of different tree species" is checked, tree growth
analysis tool will not be applicable to those tree with unknown species information. But those trees which is
tall enough to be the "danger tree" will be marked as "danger tree" anyway.

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Tree Growth Warning Analysis List

Summary

Tree growth warning analysis list records the result of tree growth warning analysis, as is shown below. Each row
contains the coordinates of the danger treetop point and coordinates of the point on the power line which is
closest to the treetop.



Settings

Critical Time (year) (default value is "2"): Set the critical time. When the warning time is less than the
critical time, the record will be marked as red. This function is used to quickly view the distribution of danger
treetops.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Tree Fall Analysis List

Summary

Tree fall analysis list records the result of the tree fall analysis. The interface of this tool is shown as follow.
Double-click the row of the danger point record to zoom to that point in the 3D scene.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, view details in the detection result list. Double-click the row of the danger point
record to zoom to that point in the 3D scene and display the distance between the danger point and the
power line. And judge if the danger point is misclassified due to the error in the classification of the point
cloud. If so, user can use Profile Tools to modify the classification result first, then Clear the detection
results. Finally redo the detection to correct the error.

Load or renew the detection result list.



Allowable Stress Analysis List

Summary

Allowable stress analysis list records the result of allowable stress analysis, as is shown below. Double-click the
row to zoom to that power line in the 3D scene.



Load Data
Load or renew the analysis result list.



Drainage Thread Clearance Analysis List

Summary

Drainage thread clearance analysis list records the result of drainage thread clearance analysis, as is shown
below. Each row records the coordinates of the closest point on a single drainage line to the tower and the
coordinates of the corresponding point on the tower.



Settings

Suspected Distance (meter) (default value is "2"): Suspected danger point distance. The danger points
with clearance distance less than this threshold will be marked as red in the danger points list. This
parameter is used to filter out the invalid danger points which is misclassified because of the error in the
classification process of the point cloud.

Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Load or renew the detection result list.



Phase Spacing Analysis List

Summary

Phase spacing analysis list records the result of phase spacing analysis, as is shown below. Different rows record
the point cloud name and the coordinates and the names of the starting and ending point with different phase
spacing.



Load Data

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: After the detection, the details can be viewed in the phase spacing analysis list. Double-click the
detection record to zoom to that phase spacing location and the phase spacing will be highlighted
simultaneously.

Load or renew the detection result list.



Sag Analysis List

Summary

Sag analysis list records the result of sag analysis, as is shown below. Double-click the row of any record to
zoom to that point in the 3D scene.



Sag Analysis File List



Select the sag analysis file, and renew the detection result list. Sag analysis file list is loaded from the csv file in
the path of the sag analysis. The default path of the sag analysis is the working directory of the sag analysis
folder.

Load Data

Set Sag Analysis Directory

Note: Click the header of the detection result table to switch between ascending and descending display by
the selected attribute values in the table.

Note: If there is no angle of wind deflection, the angle of wind deflection records will not be displayed in the
list and scene.

Load or renew the detection result list.

Set the directory of the sag analysis and renew the sag analysis file list.



Appendix
This chapter introduces some key terms, file formats and ways of high-performance graphics mode adjustment.

Key Terms

File Formats

LiData

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Clip by Circle File Format

Clip by Rectangle File Format

Extract by Time File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Tower File

Simulation File

Homologous Points File Format

Individual Tree Segmentation Result File

Shortcut Keys

Menu Shortcut Keys

Viewer Shortcut Keys

Point Editing Shortcut Keys in Profile Window

High-Performance Graphics Mode Adjustment



Key Terms
Workflow – A sequence of steps to produce the final products.
Clipping – Extracting a subset of points from point cloud using an extent.
Extracting – Extracting a subset of points from point cloud using a specific point attribute.
Return Number – The Return Number is the pulse return number for a given output pulse. A given output
laser pulse can have many returns, and they must be marked in sequence of return. The first return will have
a Return Number of one, the second a Return Number of two, and so on up to five returns.
Intensity – The intensity value is the integer representation of the pulse return magnitude. This value is
optional and system specific. However, it should always be included if available.
Outlier – A point or group of points isolated from other points of interest that are considered noise or
extraneous objects.



File Formats
This section introduces the data formats supported by LiPowerline and the specific file formats involved in various
functional modules, such as POS file, control point file, seed point file and so on.

LiData

LAS

LiModel

LiTin

Clipping Point Cloud File Format

Clip by Circle File Format

Clip by Rectangle File Format

Extract by Time File Format

POS File

OUT File

Control Point File Format

Notes Elevation Points File

Sample Data File

Seed Points File

Tower File

Simulation File

Homologous Points File Format



LiData
LiData is a point cloud data file format defined by LiPowerline. It consists of a public header block, variable length
records, and point data records.

This format can be exchanged with other common point cloud data format files, including LAS, LAZ, PLY, ASCII,
etc.

When loading common point cloud data formats (including: LAS, LAZ, PLY, ASCII, etc.) into LiPowerline, a
LiData file named after the same name will be generated, and the subsequent operations are based on LiData.



LAS
The LAS file format is a public file format for point cloud data.

To download LAS specifications please go to:

LAS 1.1

LAS 1.2

LAS 1.3

LAS 1.4

https://www.asprs.org/committee-general/laser-las-file-format-exchange-activities.html
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/asprs_las_format_v12.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_3_r11.pdf
http://www.asprs.org/wp-content/uploads/2010/12/LAS_1_4_r13.pdf


LiModel
LiModel file stores triangulated regular network models generated by DEM or DSM. It saves regular grid nodes
and block-organized triangulated regular network models according to quadtree. DOM texture information can be
superimposed on the model. LiModel could be transformated from massive data of DEM or DSM. It supports
editing operations including flatten height, smooth height, noise points removal and so on. After editing, it can be
exported to Tiff file for generating contours.



LiTin
The LiTin file is generated by the irregular 2.5D triangulation model based on the point cloud. It can improve
quality of contour lines by editing operations including flatten height, smooth height, vertex addition and removal,
etc. It organizes data in full memory mode, which takes up large memory and causes low rendering efficiency. So
it is suggested to generate LiTin file into tiles.



Clipping Point Cloud File Format

Brief

The file is a text file that contains a list of scopes used to load multiple circles or rectangles.

Clip by Circle File Format

Each circle consists of three values separated by commas: the X coordinate, the Y coordinate and the radius of
the center.

The following table is an example of a circular extent file:

322610.51, 4102305.22, 50

322685.86, 4102400.5, 50

322820.45, 4102510.21, 100

322850.35, 4102655.33, 100

323000.00, 4103000.00, 60

The above values can be stored in a text file (such as "extents.txt") and loaded into the LiPowerline software.

Clip by Rectangle File Format

Each rectangle consists of four values separated by commas: X minimum, X maximum, Y minimum and Y
maximum.

The following table is an example of a rectangular extent file:

322601.255, 322801.255, 4102309.655, 4102409.655

322548.966, 322600.110, 4102310.180, 4102360.180

322539.155, 322600.255, 4102309.655, 4102359.655

322745.950, 322780.110, 4102204.660, 4102250.180

322875.224, 322975.224, 4102028.660, 4102128.660

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiPowerline software.



Extract by Time File Format
Each extraction range consists of two values separated by commas: starting GPS time and ending GPS time.

The following table is an example of extracting range files by GPS time:

526494.500,527494.500

527494.500, 528494.500

527494.500, 528494.500

528494.500, 529494.500

529494.500, 530494.500

The above values can be stored in a text file (such as "extents.txt ") and loaded into the LiPowerline software.



Homologous Points File Format
Homologous points file is a comma separated text file. The first row is a file header. Each row consists of 9
columns: ID, reference coordinate (X,Y,Z), reference source file, alignment coordinate(X,Y,Z) and alignment
source file.

 ID     ref_X        ref_Y        ref_Z           file                align_X       align_Y    align_Z  file
P01, 322500.1100, 4102499.9600, 2613.1400, E:/data/LiForest.LiData, 322500.0089, 4102499.9856, 0.0000, null
P02, 322999.8400, 4102499.7900, 2614.3400, E:/data/LiForest.LiData, 322999.9283, 4102499.9585, 0.0000, null
P03, 322999.8300, 4102000.3200, 2554.4100, E:/data/LiForest.LiData, 322999.8738, 4102000.1457, 0.0000, null
P04, 322500.3700, 4102000.1600, 2490.7400, E:/data/LiForest.LiData, 322500.1140, 4102000.0595, 0.0000, null



POS File
The POS File contains information such as GPS time, longitude, latitude, height, roll, pitch, heading, GridX and
GridY. GPS time, longitude, latitude, height, roll, pitch and heading must be necessary, while GridX and GridY
are optional. If POS file doesn't include GridX and GridY, we need to set projection coordinate system when we
input trajectory files. GridX and GridY can be calculated according to projection coordinate system, longitude and
latitude in strip alignment module.

The trajectory information stored in its file is structured as follows:

Data Units Type

GPS time seconds double

longitude degree double

latitude degree double

height meters double

roll degree double

pitch degree double

heading degree double

GridX(Optional) meters double

GridY(Optional) meters double

The examples the POS file is shown below. Example 1(not including GridX，GridY):

 380954.000,112.5311950876, 26.8969520123,378.543,  7.1701230000,  3.0890110000,-39.4065340000
 380954.008,112.5311938923, 26.8969533249,378.537,  7.2001860000,  3.0914780000,-39.4034150000
 380954.016,112.5311926975, 26.8969546376,378.531,  7.2368710000,  3.0936380000,-39.4011190000
 380954.024,112.5311915034, 26.8969559507,378.525,  7.2683090000,  3.1015050000,-39.3975470000
 380954.032,112.5311903098, 26.8969572641,378.518,  7.3007560000,  3.1115160000,-39.3929590000
 380954.040,112.5311891169, 26.8969585779,378.512,  7.3269790000,  3.1179720000,-39.3878260000
 380954.048,112.5311879247, 26.8969598920,378.506,  7.3525870000,  3.1180460000,-39.3804020000
 380954.056,112.5311867331, 26.8969612065,378.500,  7.3745730000,  3.1151630000,-39.3713830000

Example 2(including GridX，GridY):

383207.336,112.5421590662,26.9034172036,313.865,3.538615,2.660518,-67.848653,653147.099716932,2976670.62354689
383207.344,112.5421572108,26.9034177865,313.861,3.533299,2.659177,-67.840828,653146.914649722,2976670.68587654
383207.352,112.5421553554,26.9034183697,313.857,3.522385,2.658042,-67.828619,653146.729582108,2976670.74823943
383207.36,112.5421535001,26.9034189529,313.854,3.512757,2.659231,-67.816251,653146.544524429,2976670.81060244
383207.368,112.5421516447,26.9034195363,313.85,3.502656,2.662677,-67.807435,653146.35945655,2976670.87298749
383207.376,112.5421497892,26.9034201198,313.846,3.502243,2.664987,-67.803265,653146.174378605,2976670.9353835
383207.384,112.5421479336,26.9034207035,313.843,3.500293,2.668456,-67.80232,653145.989290462,2976670.99780155
383207.392,112.5421460783,26.9034212874,313.839,3.501546,2.671267,-67.797563,653145.804231844,2976671.06024212
383207.4,112.5421442231,26.9034218713,313.835,3.496569,2.674773,-67.789195,653145.619183163,2976671.12268281
383207.408,112.542142368,26.9034224554,313.832,3.483849,2.676885,-67.774991,653145.434144147,2976671.18514579
383207.416,112.5421405129,26.9034230395,313.828,3.471533,2.676137,-67.765536,653145.24910513,2976671.24760876
383207.424,112.5421386577,26.9034236237,313.824,3.47028,2.675779,-67.760612,653145.064056049,2976671.3100827
383207.432,112.5421368024,26.9034242079,313.82,3.475101,2.677064,-67.761833,653144.878997039,2976671.37255652
383207.44,112.5421349471,26.9034247923,313.817,3.476053,2.681571,-67.761664,653144.69393776,2976671.43505249



OUT File
Out file is a binary file that stores trajectory information. The following table shows the format of the POSPac
SBET file provided by Applanix. For details, refer to the PosPac quick start guide.

The trajectory information stored in its file is structured as follows:

Data Units Type

time seconds double

latitude radians double

longitude radians double

altitude meters double

x velocity meters/second double

y velocity meters/second double

z velocity meters/second double

roll radians double

pitch radians double

platform heading radians double

wander angle radians double

x body acceleration meters/second² double

y body acceleration meters/second² double

z body acceleration meters/second² double

x body angular rate radians/second double

y body angular rate radians/second double

z body angular rate radians/second double

https://www.applanix.com


Control Point File Format
The control point file contains a list of control points in TXT format. The first row is the file header, while other
rows store comma separated X, Y, Z coordinates of control points. The following table is an example of a control
point file:

X, Y, Z
473575.563, 291005.332, 127.244
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317
473576.899, 291004.245, 126.328
473576.899, 291004.243, 126.317



Notes Elevation Points File
The notes elevation points file is a comma-delimited CSV file. The first row is the file header, while other rows
store X, Y, Z and Label (separated by comma).

The following figure shows an example of notes elevation points file:

X, Y, Z, Label
322539.46, 4102000.01, 2489.21, 2489.21
322551.33, 4102009.72, 2489.55, 2489.55
322562.85, 4102000.03, 2489.74, 2489.74
322563.16, 4102019.38, 2489.98, 2489.98 
322511.58, 4102056.04, 2492.86, 2492.86



Sample Data File
The sample data file is a text file (*.txt) delimited by commas that contains a file header in the first row. The first
two columns of each row are the X and Y coordinates, followed by a number of dependent variables. Multiple
dependent variables can be stored, but only one is used for each regression analysis.

The dependent variable is tree height in the following example of a sample data file:

X,Y,Height
322859.25,4102463.86,33
322862.25,4102459.35,31.5
322864.56,4102462.49,32
322874.58,4102463.50,35
322655.52,4102192.25,21.1



Seed Points File
Seed points file is a comma-separated CSV file. The first row is the file header, while other rows contain a
number of seed points. Each row contains four columns: tree ID, tree location X coordinate, tree location Y
coordinate and tree location Z coordinate.

The following table shows an example of a seed points file:

TreeID,TreeLocationX,TreeLocationY,TreeLocationZ    
1,322971.5,4102497.5,47.387
2,322549.5,4102496.5,49.42    
3,322678.5,4102495.5,48.456    
4,322716.5,4102494.5,34.366    
5,322516.5,4102489.5,23.726



Tower File
Tower file is a customized text format file (*.LiTower). The first row is the file header, while other rows store X, Y,
Z, type, and name of each tower (separated by comma). The index is assigned automatically by the software,
while the name is set the same as the index by default. Type "N" represents the tension tower, type "Z"
represents the straight line tower.

Here is an example of part of tower file:

Index,X,Y,Z,Type,Name
11,740662.360000,2688164.090000,79.850000,N,1
12,740750.560000,2688525.920000,82.040000,Z,2



Simulation File
The working condition simulation file is in text format (*.LiSim), and contains working condition information and
power line coordinate information. The first line indicates the power line type, the second line indicates the
detected line voltage level, and the third and fourth lines indicate power line temperature, ice thickness, and wind
speed information (separated by "\t") for scanning and simulated conditions. The fifth line indicates the number of
power lines, and the sixth row to the last row indicate the power line coordinate information. The coordinate
information includes 17 columns (separated by "\t"), 1-3 columns indicate the X, Y, and Z coordinates of the start
point of the power line , 4-6 columns indicate the X, Y, and Z coordinates of the end point of the power line , and
columns 7-9 indicate the X, Y, and Z coordinates of the middle point of the power line , the columns 10-12
indicate the X, Y, and Z coordinates of the intersection of the start insulator and the tower body, and the columns
13-15 indicate the X, Y, and Z coordinates of the intersection of the end insulator and the tower body, 16-17
indicates whether the start and end insulators are offset under simulated conditions (0 means no offset, 1 means
offset).

Here is an example of part of simulation file:

LGJ-240/30
500
0.0000    0.0000    0.0000
0.0000    0.0000    15.0000
5
666863.9100    2716344.4400    269.0700    667120.0300    2716612.3100    184.3700    666991.9700    2716478.3750    
212.5901    666863.9100    2716344.4400    269.0700    667120.0300    2716612.3100    184.3700    0    0
664593.8598    2712726.3097    200.0400    664939.7626    2712980.7251    273.4400    664766.8112    2712853.5174    
219.8623    664593.8598    2712726.3097    200.0400    664939.1500    2712981.5597    276.4400    0    1
664939.7626    2712980.7251    273.4400    665273.5201    2713225.1898    279.0200    665106.6413    2713102.9574    
260.7851    664939.1500    2712981.5597    276.4400    665273.5201    2713225.1898    279.0200    1    0
665281.4701    2713230.9998    279.7300    665553.3276    2713435.1702    357.2400    665417.3988    2713333.0850    
305.7610    665281.4701    2713230.9998    279.7300    665552.7100    2713436.0000    360.2400    0    1
665553.3276    2713435.1702    357.2400    665680.6977    2713530.4203    382.0800    665617.0127    2713482.7952    
366.9125    665552.7100    2713436.0000    360.2400    665680.0801    2713531.2501    385.0800    1    1



CHM Segmentation Result
The CHM segmentation result contains a comma-separated CSV table file and a polygon-type shp vector file.

The CSV table contains the attributes of tree ID, x, y coordinate position, tree height, crown diameter and crown
area.

The following table shows an example of the segmentation result of CHM:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownArea
1, 322716.24, 4102494.69, 36.165, 8.982, 63.36
2, 322751.21, 4102499.9, 41.282, 4.491, 15.84
3, 322519.35, 4102499.3, 32.008, 4.708, 16.64
4, 322742.15, 4102497.7, 26.956, 8.347, 54.72
5, 322892.26, 4102499.5, 45.493, 7.792, 47.68

The SHP file contains the boundary range of each tree. The attribute table contains the ID, x, y coordinate
position, tree height, crown diameter and crown area attributes of each tree.



ALS Forest results of point cloud segmentation & PCS
with Seeds
The ALS Forest results of point cloud segmentation and PCS with seeds are comma-separated CSV table files
containing the attributes of tree ID, x, y coordinate position, tree height, crown diameter, crown area and crown
volume.

The following table shows an example of the results of the ALS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, CrownDiameter, CrownArea, CrownVolume
1, 322511.52, 4102089.78, 60.606, 10.85, 92.04, 3240.171
2, 322511.81, 4102015.14, 53.785, 13.15, 135.09,4358.651 
3, 322537.43, 4102062.51, 46.667, 12.45, 126.76, 3272.472
4, 322529.42, 4102073.12, 45.197, 4.071, 13.019, 342.992 
5, 322525.07, 4102101.07, 43.861, 3.105, 7.57, 107.672

TLS Forest results of point cloud segmentation & PCS
with Seeds
The TLS Forest results of point cloud segmentation and PCS with seeds are comma-separated CSV table files
containing the attributes of tree ID, x, y coordinate position, tree height and DBH.

The following table shows an example of the results of the TLS individual tree segmentation:

TreeID, TreeLocationX, TreeLocationY, TreeHeight, DBH
1, 136547.147, 289995.532, 6.498, 0.081
2, 136562.037, 289985.496, 5.652, 0.112
3, 136543.853, 290001.586, 6.115, 0.078
4, 136547.766, 289997.909, 5.868, 0.081
5, 136547.127, 289980.102, 5.217, 0.097



Shortcut Keys
This section introduces the shortcut keys associated with menus, viewers and point editing in profile windows.

Menu Shortcut Keys

Viewer Shortcut Keys

Point Editing Shortcut Keys in Profile Window



Menu Shortcut Keys

Shortcut Key Meaning

Ctrl+Shift+O Open files supported by LiPowerline

Alt+F4 Exit LiPowerline

Ctrl+F3 Add New window

Ctrl+F4 Close Current Window

F11 Full Screen

F3 Orthogonal/ Perspective Projection

F1 Help



Viewer Shortcut Keys

Shortcut Key Meaning

A Anticlockwise Rotation

G Clockwise Rotation

C Front Rotation

E Back Rotation

T Tips

W Show Model/Triangle/Points

P Adjust lighting (improve the display effect of LiModel, LiTin, OSGB and other model files)

↑ Up

↓ Down

← Left

→ Right

+ Zoom in

- Zoom out

Left Button Rotation

Right Button Pan

Middle Wheel Zoom

Space Default

Delete Delete Label/Delete Seed Points



Point Editing Shortcut Keys in Profile Window

Shortcut
Key Meaning

0-9 Modify the currently selected points to the new classification indicated by the number key
pressed

L Activate the "Line Above Selection" tool

Shift+L Activate the "Line Below Selection" tool

Shift+R Activate the "Rectangle Selection" too

Shift+P Activate the "Polygon Selection" tool

Shift+C Activate the "Circle Selection" tool

Q Switch between different selection tools in order

R Activate / deactivate rotation tool

Ctrl+Shift+Z Clear Selection

Ctrl+Shift+S Save

↑ Move the cross-section/profiling area forward

↓ Move the cross-section/profiling area backward

→ Rotate the cross-section/profiling area clockwise

← Rotate the cross-section/profiling area counter-clockwise



High-Performance Graphics Mode Adjustment
Follow the procedure below to optimize graphics for LiPowerline (for NVIDIA graphic cards).

1. Right click on desktop and select NVIDIA Control Panel.

2. Select Manage 3D settings > Program Settings > Add to add LiPowerline.exe to high-performance
graphics mode list.





FAQ
This chapter introduces the frequently asked questions and solutions in the use of LiPowerline. It contains
Installation and License Activation FAQ, Platform FAQ, Strip Alignment FAQ, Terrain FAQ, Forestry FAQ and
Power Line FAQ.

Installation and License Activation FAQ

Platform FAQ

Power Line FAQ



Hardware requirements and supported operating
systems

RAM: at least 8G or more.
CPU: Intel® Core™ i5/i7; Dual-core processor.
Display Adapter: NVIDIA graphics card recommended, video memory no less than 2GB.
Operating Systems: Windows 7 (64 bit), Windows 8 (64 bit), Windows 10 (64 bit) or Windows Server 2012
or later.

After successful installation on my computer, why does
the software crash when I try to open or load data?

Please check whether the software installation environment satisfies the recommended hardware
configuration. If yes, please check the following two things. (1) Whether the graphic card is working properly.
Right click on My Computer, select the device manager, find the corresponding graphic card in the Display
Adapter, and view the graphic card properties status. If it shows "this device is working normally", it means
that the graphic card device is running properly. (2) Update the graphic card driver to the latest version, and
then use the high-performance graphic mode to run the software. For the operating procedure, see adjust
the graphics mode to high performance.
Please contact us by email info@greenvalleyintl.com to check the reason remotely if you still get an error.

How to activate LiPowerline?
Send Activation Information: Run the software as administrator, click Help > Activate License in the
menubar, or double-click the License.exe in the installation directory.

mailto:info@greenvalleyintl.com


Fill in Name (Mandatory);
Fill in Company (Mandatory);
Select the appropriate module(s);
Click Copy;
Send an email with the copied content to info@greenvalleyintl.com.

Activate License：
Copy the license code to your local drive. Pleaser refer to the License Manager for license activation.

Does LiPowerline support Windows Server System?
Windows Server is supported.

Please install and activate LiDAR360 using the administrator account. The software must be installed in
the folder to which all users have access.

mailto:info@greenvalleyintl.com


How to check the version information of LiPowerline
software?

You can check the version information of LiPowerline in Help > About, 2.0 is the software version and 1019
is the build date.

How to change the menu language?
Click Display > Language in the menubar. Currently the supported languages are English and Chinese.

Why does the software exit abnormally?
Based on our experience, the major two reasons of abnormal exits are the insufficient disk space or memory
space in your computer and the existence of opened instance of screen word capturing software. If you meet
any other scenarios that lead to abnormal exits, please contact us info@greenvalleyintl.com.

What are the supported data formats in LiPowerline?
LiPowerline can import the following data formats:

Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII File(*.txt, *.asc, *.neu, *.xyz,
*.pts, *.csv), PLY File(*.ply).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp).
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File*.LiTin), OSG Model File(*.osgb, *.ive,
*.desc, *.obj).

mailto:info@greenvalleyintl.com


LiPowerline can export the following data formats:

Point Cloud: Proprietary LiData File(*.LiData), LAS File(*.las,*.laz), ASCII File(*.txt, *.asc, *.neu, *.xyz,
*.pts, *.csv), PLY File(*.ply).
Raster: Image File(*.tif,*.jpg).
Vector: Vector File(*.shp, *.dxf)
Table: Table File(*.csv)
Model: Proprietary Model File(*.LiModel), Proprietary TIN File(*.LiTin).

If the color scheme of the data displayed in the viewer
window is not correct, how can I correct this?

First, right click on the desktop. Select NVIDIA Control Panel.
Second, select manage 3D settings > program settings > add to add LiPowerline software to the list of
high-performance graphics mode. Refer to adjust high-performance graphics mode.

How to fix drag and drop in windows 8 and windows 10?
Go to RUN, or search "regedit.exe" then run as administrator. On Registry Editor go to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System, double click
"EnableLUA", and change the value from 1 to 0. Restart windows, and the problem will be solved.
Reference.

Why is the EDL visual effect not obvious if multiple data
are added in the same window?

It's recommended to show distant multiple data in separate windows with EDL effect. Or remove unwanted
data in the current window.

What is the unit of point cloud data in LiPowerline?
The unit is meter. If users have point clouds with foot or other units, they can be converted by Data
Management > Point Cloud Tools > Transformation. An example is shown in the following figure. X, Y, Z
coordinates are multiplied by 0.3048 to be coverted from foot to meter.

https://answers.microsoft.com/en-us/windows/forum/windows_10-files/how-to-fix-drag-and-drop-in-windows-10/0ea16377-dfcf-4a28-9e38-c35f4113202b?page=13&auth=1


Is LiPowerline capable to handle the point cloud
generated by photogrammetry software?

Yes, it is.

How does LiPowerline perform seven parameter
transformations?

Click Data Management > Point Cloud Tools > Reproject.
Check Use Seven Parameters.
Input seven parameters: translations X, Y, Z; rotations Rx, Ry, Rz; and scale λ.
Select target coordinate reference system. (You have to define projection for the point cloud if it doesn't have
source coordinate reference system)



How to subsample the point cloud uniformly?



LiPowerline provides subsampling methods by Minimum Points Spacing, Sampling Rate, or Octree. The
subsampling by Octree is an uniform method.

Click Data Management > Point Cloud Tools > Subsampling, then select the sampling type Octree.

How to Pick Rotation Center while using the Pick Multi-
Point tool?

Hold the Ctrl key and pick rotation center by left-click.

Why are point cloud transformation results incorrect in
LiPowerline?

This is because different units are used in each program. In LiPowerline degree units are used. In order to
carry out a correct transformation, the units must be degrees.



Can I modify the name of a point cloud file generated by
clip?

No, the point cloud file name is associated with the tower file.

After completing clip, can you edit the tower file?
No, this may cause that the point cloud file did not match with the tower file.



LiPowerline Version Release Notes

v1.0 - 16/10/2016
First version release of LiPowerline

v2.2.0 - 20/1/2019
1. Interface design logic is based on data processing flow. Each tab stands for a processing step.
2. Add infrastructure acceptance analysis module.
3. Provide deep learning algorithm for point cloud classification.
4. Add more data analysis report options, supporting .html and .docx.
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End User License Agreement
PLEASE READ CAREFULLY BEFORE USING THIS SOFTWARE PRODUCT: This End-User License
Agreement ("EULA") is a contract between (a) you (either an individual or the entity you represent) and (b)
Greenvalley International Inc ("GVI") that governs your use of the software product (“Software”). This EULA
does not apply if there is a separate license agreement between you and GVI or its suppliers for the Software,
including a license agreement in online documentation. The term "Software" may include (i) associated media, (ii)
a user guide and other printed materials, and (iii) "online" or electronic documentation (collectively “User
Documentation”).

RIGHTS IN THE SOFTWARE ARE OFFERED ONLY ON THE CONDITION THAT YOU AGREE TO ALL
TERMS AND CONDITIONS OF THIS EULA. BY INSTALLING, COPYING, DOWNLOADING, OR OTHERWISE
USING THE SOFTWARE, YOU AGREE TO BE BOUND BY THIS EULA. IF YOU DO NOT ACCEPT THIS
EULA, DO NOT INSTALL, DOWNLOAD, OR OTHERWISE USE THE SOFTWARE. IF YOU PURCHASED THE
SOFTWARE BUT DO NOT AGREE TO THIS EULA, PLEASE RETURN THE SOFTWARE TO YOUR PLACE OF
PURCHASE WITHIN FOURTEEN DAYS FOR A REFUND OF THE PURCHASE PRICE; IF THE SOFTWARE IS
INSTALLED ON OR MADE AVAILABLE WITH ANOTHER GVI PRODUCT, YOU MAY RETURN THE ENTIRE
UNUSED PRODUCT.

1. THIRD PARTY SOFTWARE. The Software may include, in addition to GVI proprietary software (“GVI
Software”), software under licenses from third parties (“Third Party Software” and “Third Party License”). Any
Third-Party Software is licensed to you subject to the terms and conditions of the corresponding Third-Party
License. Generally, the Third-Party License is in a file such as “license.txt” or a “readme” file. You should
contact GVI support if you cannot find a Third-Party License.

2. LICENSE RIGHTS. You will have the following rights provided you comply with all terms and conditions of
this EULA:

a. Use. GVI grants you a license to Use one copy of the GVI Software. "Use" means installing, copying,
storing, loading, executing, displaying, or otherwise using the GVI Software. You may not modify the GVI
Software or disable any licensing or control feature of the GVI Software. If this Software is provided by GVI
for Use with an imaging or printing product (for example, if the Software is a printer driver, firmware, or add-
on), the GVI Software may only be used with such product (“GVI Product”). Additional restrictions on Use
may appear in the User Documentation. You may not separate component parts of the GVI Software for
Use. You do not have the right to distribute the GVI Software.

b. Copying. Your right to copy means you may make archival or back-up copies of the GVI Software,
provided each copy contains all the original GVI Software's proprietary notices and is used only for back-up
purposes.

3. UPGRADES. To Use GVI Software provided by GVI as an upgrade, update, or supplement (collectively
“Upgrade”), you must first be licensed for the original GVI Software identified by GVI as eligible for the
Upgrade. To the extent the Upgrade supersedes the original GVI Software, you may no longer use such GVI
Software. This EULA applies to each Upgrade unless GVI provides other terms with the Upgrade. In case of
a conflict between this EULA and such other terms, the other terms will prevail.

4. TRANSFER. You may not rent, lease or lend the GVI Software or Use the GVI Software for commercial
timesharing or bureau use. You may not sublicense, assign or otherwise transfer the GVI Software except as
expressly provided in this EULA.



5. PROPRIETARY RIGHTS. All intellectual property rights in the Software and User Documentation are owned
by GVI or its suppliers and are protected by law, including applicable copyright, trade secret, patent, and
trademark laws. You will not remove any product identification, copyright notice, or proprietary restriction
from the Software.

6. LIMITATION ON REVERSE ENGINEERING. You may not reverse engineer, decompile, or disassemble the
GVI Software, except and only to the extent that the right to do so is allowed under applicable law.

7. CONSENT TO USE OF DATA. GVI and its affiliates may collect and use technical information you provide in
relation to (i) your Use of the Software or the GVI Product, or (ii) the provision of support services related to
the Software or the GVI Product. All such information will be subject to GVI’s privacy policy. GVI will not use
such information in a form that personally identifies you except to the extent necessary to enhance your Use
or provide support services.

8. LIMITATION OF LIABILITY. Notwithstanding any damages that you might incur, the entire liability of GVI and
its suppliers under this EULA and your exclusive remedy under this EULA will be limited to the amount
actually paid by you for the Product. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN
NO EVENT WILL GVI OR ITS SUPPLIERS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR
CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR LOST PROFITS, LOST DATA, BUSINESS
INTERRUPTION, PERSONAL INJURY, OR LOSS OF PRIVACY) RELATED IN ANY WAY TO THE USE OF
OR INABILITY TO USE THE SOFTWARE, EVEN IF GVI OR ANY SUPPLIER HAS BEEN ADVISED OF
THE POSSIBILITY OF SUCH DAMAGES AND EVEN IF THE ABOVE REMEDY FAILS OF ITS ESSENTIAL
PURPOSE. Some states or other jurisdictions do not allow the exclusion or limitation of incidental or
consequential damages, so the above limitation or exclusion may not apply to you.

9. U.S. GOVERNMENT CUSTOMERS. Software was developed entirely at private expense. All Software is
commercial computer software within the meaning of the applicable acquisition regulations. Accordingly,
pursuant to US FAR 48 CFR 12.212 and DFAR 48 CFR 227.7202, use, duplication and disclosure of the
Software by or for the U.S. Government or a U.S. Government subcontractor is subject solely to the terms
and conditions set forth in this End User License Agreement, except for provisions which are contrary to
applicable mandatory federal laws.

10. COMPLIANCE WITH EXPORT LAWS. You will comply with all laws, rules, and regulations (i) applicable to
the export or import of the Software, or (ii) restricting the Use of the Software, including any restrictions on
nuclear, chemical, or biological weapons proliferation.

11. RESERVATION OF RIGHTS. GVI and its suppliers reserve all rights not expressly granted to you in this
EULA.
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