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1 Application Characteristics 
TcpScancyr for Tunnels is program used to calculate cross sections, surfaces and 

volumes based on points taken from a 3D scanner. 

2 Requirements 
Due to the complexity of some of the calculations, we recommend you use a computer 

with at least a double core processor. 

Minimum requirements: 

• Operating system: Windows XP / Vista / 7 / 8 in 32 and 64 bits 

• Graphics card: minimum resolution of 1024x768 pixels, memory of 256  Mb and 

compatible with OpenGL™  

• Processor: Intel Dual Core 2 GHz or higher 

• Memory: minimum of 2 Gb 
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3 Main window 
When the program has loaded the main window appears. You will see that the window 

is divided into various parts, from left to right and from top to bottom these are: 

• Program menu 

• Toolbar 

• Project tree 

• Data display window 

• Status bar 

 

Figure 1 - Main window 

Menu bar:. Allows you to access all program options 

Toolbar: Quick access to the main application options. 

Project Window Features a project tree showing the various parts that make up the 

project. Each node can be expanded by clicking on the ‘+’ symbol. You may access the most 

common actions by using the context menu for each node by right clicking with the mouse. 
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Data display window: Features four windows which allow you to view the horizontal 

alignment in plan, vertical alignment, superelevations, bases and the view tab that that shows 

the last selected element. 

Status bar: Situated at the bottom of the screen, this shows information regarding 

cursor coordinates and the current state of the program.  

To create a new project, follow the steps below: 

1. Create a new project. 

2. Assign the plan, height and superelevation alignment, manually uploading the 

relevant data 

3. Create the tunnel template by importing a DXF or TcpTunnel file - these can also 

be created manually using the keyboard. 

4. Import the scanner points, after import they will be automatically analyzed. 

5. Calculate cross sections 

The order of steps 3 and 4 can be swapped around; you may even define the tunnel 

template section after calculating the cross sections. Nevertheless, it is important to create the 

alignment before importing points. If they are imported without the alignments, use the 

option “Points -> Analyze”. If not, the program will not know the position of the points with 

respect to the alignment and it won’t calculate cross sections, nor will it correctly draw the 

points cloud with the alignment. 

4 Project 
In order to work with the application you need a number of elements as alignments, 

type sections, points etc. which are saved within the project file. 

The main project options can be found in the menu “File”. 

New: Create a project from zero. A dialog box will open allowing you to select the main 

project elements. 

Open: Open the file selector in order to choose a project file (*.PRO). If there is 

already a project open and it has been modified, you will be asked if you wish to save it. 

Save: Save the current project in its project file. This option will only be enabled if the 

project has been previously saved, or is a loaded project. 

Save As: Opens the file selector to save the project in a project file. From this point 

you may only save the project using the “File -> Save” menu 

Properties: This opens a project dialog box which allows you to change the name, 

alignments or the file of the bases that make up the project. 
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Import: This option gives the ability to import horizontal and vertical alignment from 

different types of files.  

 

Figure 2 - Alignment import menu 

This is the dialog box that appears when you create a new project or edit an existing 

one. 

 

Figure 3 -Project dialog box 

Name: The project name will appear at the head of the lists. 

Horizontal alignment: The project alignment can be left blank in order to create one 

from start. The file should be compatible with the MDT (*.EJE) format. If the alignment is in 

another format, leave this field blank and use the import option. 

Vertical alignment: The project gradient can be left blank in order to create one from 

zero. The file should be compatible with the MDT (*.RAS) format. If the alignment is in another 

format, leave this field blank and use the import option. 

Superelevations: The superelevations file should be compatible with the MDT (*.PER) 

format. 



TcpScancyr for Tunnels       Reference Manual 

© APLITOP 2015        10 

Stations: Stations File. 

Cross Sections: Project cross sections files, you can include as many as you need. 

By clicking on Ok, the application will load the corresponding files and include them 

within the project. 

4.1 Horizontal Alignment 
The application allows files in the alignment format MDT (*.EJE), as well as permitting 

files to be imported in other formats using the “File -> Import” option. 

You may also key in the alignment data in the main window, activating the “Horizontal 

Alignment” tab. 

The alignment editing window is divided into two parts - in the upper area there is a 

toolbar whose use will be explained later. A table showing access data appears at the bottom 

of the window. 

To add an alignment, the data must be entered from left to right. An alignment will 

only be inserted or modified after entering the “Length” field. 

If you key insert or click on new, the previous alignment will split in two, respecting the 

same parameters of the azimuth, parameter and radius so that the alignment is not affected. If 

you click on the first line you will not be able to insert a new alignment. 

 

Figure 4 - Horizontal Alignment 

On the toolbar there are two extra icons, the first optimizes the alignment joining 

consecutive straight sections with the same azimuth. The next icon displays a list of tangency 

errors at each individual point. 
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If you click on the vision tab you will see a graphic representation of the horizontal 

alignment. 

When you move the cursor the application will analyze coordinates and show 

information from the analysis on the status bar. 

 

Figure 5 - Horizontal alignment 

 

4.2 Vertical alignment 
The application allows gradients in the alignments format MDT (*.RAS), as well as 

permitting alignments to be imported in other formats using the “File -> Import” option. 

You may also key in the gradient data in the main window, activating the “Vertical 

alignment” tab. 

To enter a gradient, first add the “Station” and the “Heights”, and the application will 

automatically move the cursor in these two columns. You may then change the agreement 

data. 

The application will calculate if there is any overlap lapel between the different 

sections, and the cell where the overlap occurs will be shown in red. 

To add more data, go to the last row and click on “Cursor down”, and a new line for 

adding more data will appear. If you leave the new line without changing anything, it will be 

deleted automatically. 
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Figure 6 - Gradient alignment with overlap 

If you click on the vision tab you will see a graphic representation of the vertical 

alignment. 

When you move the cursor the application will analyze coordinates and show the 

height and incline which corresponds to the cursor position on the status bar. 

The following layers appear in the representation: 

Short marks: Draws a vertical line from the minimum height to the gradient height. 

The distance between these marks is configurable. 

Long marks: Draws a vertical line from the minimum height to the gradient height. 

The distance between these marks is configurable. 

Unique points: Draws a vertical line at the following points: 

• Station - tangent 

• Station + tangent 

• Station if the tangent equals zero. 

Guitar: Layer showing separation lines and legend. 

Upper ground spot height: Represents the maximum height of the intersection of 

the vertical that passes through the alignment and cross sections. 

Lower ground spot height: Represents the minimum height of the intersection of 

the vertical that passes through the alignment and cross sections. 

Gradient: Graphic representation of the gradient. 

Real gradient: Graphic representation of the gradient calculated from cross sections 

and the tunnel template. 
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Figure 7 - Vertical alignment 

4.3 Superelevations 
A superelevations file for the project can be included, assigning a file or keying in data 

in the “Superelevations” tab in the main window. 

By clicking on “New” or “Edit”, a dialog box will appear allowing  you to enter 

superelevations data. If you accept the superelevations they will be reordered in “Station” 

order. 

By clicking Insert you can add a new row before the current row. The Station new row 

should be assigned to the mid-point between the previous and the current row, with the 

superelevations are inserted between the two rows. 

To add more data, go to the last row and click on “Cursor down”, and a new line for 

adding more data will appear. If you leave the new line without changing anything, it will be 

deleted automatically. 

 

Figure 8 - Superelevations Alignment 

If you click on the vision tab you will see a graphic representation of the 

superelevations. 
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When you move the cursor the application will analyze coordinates and show 

information from the analysis on the status bar. 

 

Figure 9 - Graphic representation of superelevations 

4.4 Bases 
You may include base coordinates which correspond to scanner positions when tunnel 

samples are taken. 

When you apply a distance filter or symbol, it can always be applied using the centroid 

of the points. If you have included a base file, you will be able to apply the filter or symbol 

using the base of each file. 

The bases are shown as a cylinder with a cone on the top, centered and supported by 

coordinates.  

 

Figure 10 - Point file and its base 
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5 Project Points 
After creating a new file you will need to include a file containing the points taken from 

the scanner. 

 

Figure 11 - Project with a number of analyzed files 

In order to include points, use the "Open" option which will display a file selector. Here 

you can select more than one file at the same time. Using Percentage control we can reduce 

how many points are read from each file, by default is set to 100 to read all points. 

The application can handle any number of files as long as there is enough disk space 

available. About 50 MB are needed for each million points. 

As well as the file name, the table also displays a number of fields which are not filled 

in until you accept this dialog box and the points are analyzed. In order that this analysis is 

correct there must be a defined horizontal alignment. 

Table description. 

File: File name. In the event that there are a number of files in different locations, only 

the final, distinct part of each file is shown. 

Description: Date and time the file was created. 

Initial Station: Minimum station for the points that make up the file 

Final Station: Maximum station for the points that make up the file. 



TcpScancyr for Tunnels       Reference Manual 

© APLITOP 2015        16 

Length: Points cloud length. 

Nº Points: Number of file points. 

Percentage: Percentage of points imported from original file. 

In the statistics file, the initial and final station for all points appears, as well as total 

number of points. 

 

5.1 Points File Format 
The application accepts a number of format types for pointes files. If a specific 

manufacturer's format is not chosen, the default points format will be the following: 

A text file, with one point per line and the line in the following format: 

ID 
(Optional field) 

X, Y, Z Coordinates 
(Obligatory field) 

Intensity. 
(Optional field) 

Color RGB 
(Optional field) 

 

ID: Point identifier 

X, Y, Z Coordinate: Point Coordinates 

Intensity: Point intensity, it can be a real number [0..1] or an integer value depending 

on file format. 

Color RGB: Three whole values which correspond to red, green and blue channels, 

with whole values in the range [0, 255] 

Fields must always appear in the same order, although only the coordinates are 

obligatory. In the event that none of the color fields appear, points will be assigned the color 

white by default. 

The formats that can be imported are: 

Cyclone Format: These files have the extension “.PTX” and “.PTS”. The difference 

between the two formats is that in the former, the points are relative to the base, meaning 

that after reading each point, the absolute coordinates have to be defined, whilst in the case 

of the latter format they are expressed as absolute coordinates. The files for this format admit 

more than one sample per file. The application will create a file for each sample, adding a 

number as a suffix. 

FARO Format:  The main advantage of this format is that as the data is in binary 

format, import is significantly quicker.  At this time only “*.FLS” files are supported. 

Leica HDS 4500/6000 Format:  These files have the extension “.FZS”. The format of 

the points includes two whole values, the row and the column. These two numbers are 

ignored and only the coordinates of each point are read. 
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Leica Nova MS50 Format: These files have the extension “.XCF”. 

LAS Format: These files have the extension “.LAS” or “.LAZ” if the files are 

compressed. 

E57 Format: These files have the extension “.E57”. 

 

 

Figure 12 - Imported points with color 

5.2 Analysis of points 
In order to accelerate calculations you need to have imported all points from the 

scanner that have been analyzed with respect to the horizontal alignment. If you follow the 

normal order when creating a project, the points will be analyzed on exiting the point’s 

management dialog box. 

In the event of changing the alignments, or if you have imported the points before 

establishing the project alignments, you should use the option “Points -> Analyze” in order to 

analyze the points with respect to the horizontal alignment. 
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Figure 13 - Window for analyze points 

 [TcpScancyr Advanced]  If you check “Analyze height” and “Analyze offset”, the 

program will not analyze the points out of this intervals. These options are used for some cases 

where the tunnel has different heights or irrelevant points.  

If you do not analyze the points, the application will not know what set of points fall 

within a specific station and you will not be able to calculate cross sections. 

Once the project has been defined with the alignments and points files analyzed, you 

can use the project tree displayed on the left of the main window in order to view the points. 

By selecting a node which corresponds to a points file you will activate the “Vision” 

tab, allowing you to view the selected file. By using this view you can independently apply 

filters at each file. 

If you activate the projection with perspective, this window will appear in order to help 

you move over the alignment. If you have calculated and enabled the cross sections (using 

layer control) it will be easier to filter by selecting the points that distort cross sections 

calculation. 

If no horizontal alignments have been defined, this window will not appear. 

 

Figure 14 - Help window for positioning the camera 

Changing the station allows you to move over the alignment. 

Station: The station where the camera is located. You can write a specific station or 

use the space bar to move in real time. If you write a value, press ENTER in order to apply the 

changes 

Height: The height of the camera with respect to the vertical alignment. 
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Turn the camera with the alignment: If you have this option checked, when you 

change the station by using the controls, the camera will position itself at the azimuth of the 

alignment.  

The following options indicate where the camera will be positioned on changing the 

station.  

Position over alignment: Place the camera on the alignment at the indicated height - 

if you have moved, the camera displacement will be cancelled. 

Position relative to the alignment: Here you move by following the alignment but 

by maintaining the existing relative distance. 
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6 Filtering points 
The point cloud obtained from the scanner normally contains as many object points 

that were close to the scanner on taking the sample. As these are not tunnel points, you can 

apply filters in order to mark them, and therefore not need to consider them when calculating 

cross sections. Each filter puts a different mark on each point. 

You can apply two different types of filter, manual filter or visual filter. In order to 

access manual filter, use “Points -> Manual Filter”. 

 

Figure 15 - Manual filter 

You can choose initial and final station, offset and height using the manual filter 

window. 

In order to access visual filters, use the “Points -> Filters” menu, or the corresponding 

icon on the toolbar. 

When you apply a filter, a green filter symbol may appear on the points. The filter will 

only be applied to the points within the area marked in green. 

On the right side of each slider there’s a button to enter values manually. 

The bottom of the screen shows the following icons. 

Restore: Eliminate the selected filter for all the points in the files you are viewing. 

Invert: For each point on the selected files, the mark of the current filter will be 

inverted. 

Delete: Marks the points within the filter parameters. The marked points will not be 

used to calculate cross sections. 
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Include: Eliminate the mark on the points within the filter parameters. You may set 

the information area to see how many filtered points remain once the selected filter has been 

applied. If you want to include all points, you may also use the “Restore” option. 

By checking “Manual Station” on applying a filter you will be asked for a station range. 

You can therefore apply a filter to a whole points cloud or a greater range of points without 

the need for them to be visible. 

6.1 Filter by distance from the template 

 

Figure 16 - Filter by distance from the template. 

In order to apply for the filter by distance from the section you will need to have a 

section, a horizontal alignment, a vertical alignment and the analyzed points with respect to 

the alignment. 

Station: Station interval where the filter will be applied. Coincides with the points 

cloud’s limits you are viewing. 

Int/Ext: Values for the inner and outer offset of the template. 

Layers: Opens a dialog box to select the layer to be used on the filter. Only one layer 

may be selected per section. 

With the maximum and minimum values a band will be created that will surround the 

template. If you go around the section in a clockwise direction, the negative values represent 

the area to the left or the outside of the section, whilst the positive values represent the area 

to the right or the inner points. 
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Figure 17 - Filter by distance from the section. 

 

Figure 18 - Filter by selection, values [0, 5], have been eliminated 

6.2 XYZ Filter 

 

Figure 19 - Filter by station 

Applies a station, offset and height filter. 
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Station: Station interval of the filter. 

Disp: Maximum and minimum offset for the filter. 

Height: Maximum and minimum height differences for the filter. 

 

 

Figure 20 - Representation of filter by displacement 

6.3 Filter by angle 

 

Figure 21 -Filter by angle 

X/Z: X, Z position of the circle with respect to the alignments. 

Station: Station interval of the filter. 

Angle: You can vary the start angle and the angle taken by the filter. 

Radius: Radius of the circumference or circular sector. 
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Figure 22 - Filter by angle, X=0, Z=3.0, Start=55, Arc=37 

6.4 Filter by selection 

 

Figure 23 - Filters by selection 

This filter is always applicable, you do not need an alignment, nor to have analyzed the 

points, as only point coordinates are used.  It can also be applied whilst you look at the cross 

sections.  

Select: When you activate the selection mode, you can select points by drawing a 

rectangle within the window displaying the points without the view or perspective you are 

using mattering. 

The first click of the mouse marks the corner of the drawing, whilst the second will 

mark out the points within the rectangle. 
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Figure 24 -Example of filter by selection 
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7 Symbology 
You have the option to apply a symbology to point’s files, allowing you to see the 

relationship between points based on the symbols chosen. 

In order to apply such symbols, use the “Points -> Symbology” menu or the 

corresponding icon on the utility toolbar. 

 

Figure 25 - Symbols showing height differences 

If you do not have the necessary data to apply the selected symbology, the OK option 

will be disabled. 

Symbols available: 

Delete: Eliminates the symbology from the selected file. Points will be drawn using the 

first color from the selected range. 

Angle: Colors points based on the angle formed between the vertical and its 

coordinates.  

Scanner Color: Applies the color from each point. Points files should include 

information on color; if this is not the case all will appear in the same color. 

Offset: Colors the points based on distance to the alignment. 

Distance to the base: If a base is not defined for the file, calculations will be based on 

the centroid of the points. The distance is measured on the XY plane, with point height not 

taken into consideration. 

Height difference: Colors the points based on the difference between the point 

height and gradient height at the point station. 

Distance to the template: Colors the points based on distance to the template. When 

you set this option, an icon will be enabled which allows you to select the layers you wish to 

use in calculations. 
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Intensity: Maps points intensity to the color gradient, if intensity information is 

missing all points are mapped to the first gradient color. 

Inside/Outside: These symbols are similar to previously (Distance to the template) 

although points only come in two colors, depending on their position with respect to the 

template. 

File: Assigns a color to each file as part of the series of symbols. If you have ten files 

and you apply this symbol to the seventh of them, the seventh color from the selected range 

will be assigned to all points. 

Station: Colors the points based on the station. 

Using the “Range” control you can change the colors that are applied to the points. If 

you want to change it without changing the symbols applied, you can use the corresponding 

control in the application's main window. 

Activating the “Distance to selection" symbols, click on “Select” which will open a 

dialog box to choose the layer to be used. 

 

Figure 26 - Symbology by distance to the template 
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8 Export Points 
To export a points cloud using the menu “Points -> Export”. A dialog box will appear 

allowing you to choose the files and points to export. 

 

Figure 27 - Export points 

The dialog box is divided into 3 sections: 

⚫ Files 

You can choose the files you want to export by checking them in the file list. The points 

cloud files that you are viewing will be checked on by default. You will also have the following 

options available:  

All: Marks all files 

None: Removes the mark from all files. If no files are selected, the Accept icon will 

not be enabled. 

Selected: Marks all the active points cloud files. 

⚫ Filters 
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Using the filter options you can choose the files you wish to export. If no files are 

marked, the points for which no filter is marked will be exported. If one or more filters are 

marked, points will be exported if there is any mark in common with those marked. 

⚫ Options 

Choose Export Color box to include color information on each point. Also you may 

choose a station interval, and only the points within will be selected for export. 

⚫ Output 

After selecting the files and the points you wish to export, you should select a location 

where points are to be written. 

There are two output file formats, choosing ASCII (*.xyz) format each source file will be 

written to a different destination file. When we use Cyclone (*.pts) format the selected files 

will be written into a single file. 

 

9 Export percentage 
 

Dialog to export a given percentage of the points contained in the project.  

 

 

Figure 28 - Export percentage dialog 
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10 Cross Sections 
The application can handle various cross sections files at the same time. For this 

reason, every time you select a command that affects the cross sections you will be asked for a 

cross sections file to be used. Depending on the necessary data there are dialog box fields that 

are hidden. 

 

Figure 29 -Selection of cross sections and templates 

Using the “Cross Sections” control, you can select the cross sections file that you wish 

to use as input data, whilst with the “Template” you can select the cross sections you wish to 

use as a reference, you can use the template or a cross sections file. Finally, the “Type” field 

allows you to choose the complete cross sections or the cut corresponding to the heading or 

bench section. 

10.1 Cross Sections Calculation 
When you have established the alignments and points you may then calculate the 

cross sections from the points cloud. The algorithm only uses points that are not filtered out. 

The application features two methods to calculate cross sections. The first of these is 

accessed via the menu “Cross Sections -> Calculate Cross Sections" and can be used in points 

cloud taken with a scanner. You should use the menu “Cross Sections -> Calculate Cross 

Sections by regression” in case the points come from a station (low-density points cloud). The 

two methods use the same input parameters, except the second one the filter is not 

applicable. 

When you select the calculation of cross sections, the following dialog box will be 

shown which allows you to alter the following parameters. 
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Figure 30 - Calculate cross sections 

Initial Station: The station from which you will begin to calculate cross sections. The 

default value is the minimum station of the points cloud. 

Final Station: The last station from which you will calculate cross sections. The 

default value is the maximum station of the points cloud. 

Interval: Indicates the separation of each cross sections. 

Unique points: To create a cross section on the unique horizontal or vertical 

alignment points depending on the mark. 

Manuals: To create cross sections on specific stations. 

Gradient perpendiculars: when enabled the cross sections will be perpendicular to 

the vertical alignment, if they are disabled they will be perpendicular to the XY plane, or the 

deviation you have defined in the cross sections (only for manual cross sections). 

Manual Centre: This is used to change the origin of sorting algorithm. The values are 

relative to the horizontal and vertical alignment. 

Bandwidth: The band of points taken in order to measure cross sections, using points 

within the following range: 

Station point  [Station - Bandwidth / 2, Station + Bandwidth / 2] 
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10.2  Quick Profile: 
This option provides the possibility of create a cross section from a selection in the point 

cloud.  

The selection of a crossing plane is asked when you select the “Quick Profile” menu. The 

program will show the intersection between the point cloud and the plane with the 

bandwidth selected.  

 

Figure 31 – Bandwidth selection 

 

 

Figure 32 – Crossing plane selection 
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Figure 33 – Quick profile result 

 

10.3 Manual Cross Sections: 
 Using the manual cross section option, a dialog box will appear, indicating a station 

and deviation list for each cross section. 

 The current horizontal alignment deviation is not known. 

 

10.4 Open/Close Cross Sections 
With this command you can open or close a cross sections range. When you open a 

cross sections range also you can tell how to open it. There are two options: 

Stone Key:  It erases the cross sections edge over the horizontal alignment. 

Maximum edge: It erases the longest cross sections edge. 
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10.5 Parallel Cross Sections 
If you need to create cross sections which are parallel to those from a project, use the 

menu “Cross Sections -> Parallel Cross Sections”.  

 

Figure 34 -Calculation of Parallel cross sections 

 First select the input file (which must belong to the project) and the station range 

where you wish to calculate the parallel cross sections, using the field “Thickness”. To indicate 

the distance from the parallel cross sections, use a positive value to move the cross sections 

outside and a negative value to move it inside. 

 With the bench cut value you may cut the cross sections at a height relative to the 

gradient, always keeping the upper part of the cross sections resulting from the cut. 

 Finally you should add an output file allowing the application to create parallel cross 

sections. This file will automatically be added to the project. 

10.6 Joining Cross Sections 
You have the option to join two cross sections files by using the “Cross Sections -> Join 

Cross Sections” menu 

 

 

First select the cross sections file you wish to modify (these should pertain to the 

project). Next, set the station range which affect the modification. Finally, select the cross 

sections files to be joined. 
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The application will go through the cross sections files to be joined. If there are cross 

sections that fall within the specified station range, the project's cross sections files will be 

included. For two cross sections at the same station the old one will be overwritten by the new 

cross section. 

10.7 Elements to be Represented 
Features options which change the representation of the cross sections on the screen. 

There are options that are only available if there is a station-defined template for the cross 

sections you are viewing. 

 

Figure 35 - Cross Sections viewing options 

Points color You change the points band that you wish to take using the Edit box on 

the right. To show or hide the point cloud you must use the layer control. 

Dimensions: Activate this option if you want to show dimensions between the 

template and the calculated cross sections. By selecting the option “Section -> Cross Section” 

or “Cross Section -> Section” you can choose the direction of these heights. In the first 

instance, the straight line from the section to the cross sections is used, whilst in the second, 

the minimum distance from the cross sections points to the section are displayed. 

Inside: Fills in the cross sections areas that are within the template or reference cross 

sections. 

Outside: Fills in the cross sections areas that are outside the template or reference 

cross sections. 
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Figure 36 - Cross Sections showing all active heights and surfaces 

10.8 Cross Sections Options 
Features options for the selected cross sections. 

 

Figure 37 - Options for the selected Cross Section 

Station: The cross section that is being viewed can be changed by writing its station or 

by dragging the scroll bar. 

Recalculate: If you see a poorly defined cross section, you may click on this icon, to 

open a dialog box which will allow you to recalculate using a greater bandwidth. 

Edit: If you have not cleaned up the points cloud, the cross section may appear with 

false peaks or segments. By clicking on this button you will be able to access the cross section 

editor. 

Export DXF: Access the dialog box in order to export one or more cross sections. 

Discarded: The cross sections that are marked as discarded are not considered when 

calculating volume, alignment deviations, exporting cross section etc. 
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10.9  [TcpScancyr Advanced]  Create Alignment 
Creates a new alignment from points selected on the cross sections. This option can be 

accessed from “Tools -> Create alignment from Cross Sections ” or from the Cross Section 

Options dialog with the button “Create alignment”.  

 

Station interval: You can define an interval and the cross sections will be 

showed with this step. 

Horizontal alignment: Create the horizontal alignment from the selected 

points. 

 Vertical alignment: Create the vertical alignment from the selected points. 

Superelevations: If this option is checked the program will create a parallel 

alignment searching the points with a X displacement of the gauge selected and the 

most high one in a selection range. This option is very useful to create railway 

alignments. 

 

 

 

10.10 Cross Sections Filters 
When you view an individual cross sections you can see if it has errors because the 

cross sections has points that should be marked as filtered. Instead of going to the points cloud 

containing the cross sections, eliminating the points and recalculating the cross sections, you 

may access the selection filters, using the corresponding toolbar. The difference is that the 

cross section will be recalculated automatically by eliminating and including points. 
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Here you can see a faulty cross section because there were points which should have 

been filtered. The points correspond to the roof of a van that was close to the scanner. 

 

Figure 38 - Cross Section with errors 

Click on “Select” in the “Cross Sections -> Filter” window, and draw a selection box on 

the points that damage the cross section. 

 

Figure 39 - Selecting the points to be eliminated 

A sample of points marked. 

 

Figure 40 - The selected points appear marked in green 
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Click on “Delete” and mark the point as filtered by selection. The cross section will be 

automatically recalculated. As you can see in the image, the cross section is now correct. 

 

Figure 41 - After deleting the points 

 

10.11 Importing Cross Sections 
To import a cross sections file form MDT (*.TRA), you must supply the file, horizontal 

and vertical alignments because the application needs the position and orientation of each 

cross section to show it in 3D. 

10.12 Exporting Cross Sections 
You can export cross sections in 2D to MDT (*.TRA) file format, or as a points file with 

the coordinates of each vertex in the 3D. 

This command exports cross sections as cross-section files compatible with MDT 

(*.TRA). First, you will be asked for a station range in order to be able to export the cross 

sections within the range. 

Access is via the “Cross Sections -> Export Cross Sections…” menu. 
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Figure 42 - Window for export cross sections 

 [TcpScancyr Advanced]   There are two types of exporting 3D Vertex from the cross 

section. If you check “All”, the program will export all the points contained in the polyline.  If 

you check “Number of points”, you will choose the number of points that you want to export. 

These points will be calculated with the intersection of the cross section and radial lines from 

the center. 

10.13 Export Profiles  
From a cross section file we can generate profiles compatibles with MDT (*.LON). 

Select a range stations and then choose if we take the upper and lower ends of each 

profile or dimensions for an offset chosen. 

Then choose the output files to store data. It is not required to specify both files, only 

those who are interested. 

 

10.14 Export Cross Sections to DXF 
This command exports a cross sections file to a DXF. In order to set up the export, you 

will see the following dialog box: 
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Figure 43 - Dialog box used for exporting Cross Sections 

⚫ Dimensions 

The cross sections can be exported in 2D or 3D. In 3D many of the options will not be 

available. 

⚫ Export 

Here you can indicate the various elements that make up the cross section you wish to 

export. All the layers you have defined are always exported. Each element to be exported 

(heights, surfaces, control points) has the name of the layer of which it is part as its prefix. 

Points: Export the points that are close to the cross section, bandwidth is the same as 

in “Cross Section -> View -> Points cloud” 

Template: Exports the templates that are applied to the cross section. 

[TcpScancyr Advanced]   3D alignment : Exports the 3D alignment. 

Surfaces: Included the various polylines that make up the under-excavation and over-

excavation surfaces. 

Dimensions: Includes a layer with the dimensions from the template to the cross 

section. 

Control Points: Includes a layer with defined control points. 

Text Height: Changes the size of the text showing cross sections information. 

⚫ Cross Sections 
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You can export a single cross section, indicating its station, or a range indicating the 

initial and final station. You may also stipulate their color. 

If you have calculated single-point or manual cross sections, these will be marked 

separately on export. 

⚫ Format 

Here you can specify the output format of the cross sections, in either continuous or 

sheet mode.  You can also change the scale to adjust the drawing to the paper by using the 

corresponding control. 

When you change values, a line will appear showing information as to how many cross 

sections fit on a sheet. 

⚫ Information 

For each cross section you can indicate the data you wish to appear, as well as 

controlling its position with respect to the drawing using the left, right, up and down icons. 

Station: Cross Section station 

Azimuth: Orientation of the alignment in the station where the cross section was 

calculated. 

Slope: Inclination of the vertical alignment in the cross section position. 

Coordinates: X and Y coordinate of the alignment. 

Gradient Spot Height: Vertical alignment height of the station. 

Superelevations: Left and right superelevations value of the station. 

Surfaces: Under-excavation and over-excavation surface values for each layer of the 

template. 

⚫ Output file 

Write or select a DXF file where cross sections may be drawn. If you do not specify an 

output file the Accept icon will be disabled. 

It is important that the selected file is not being used by any other application, nor it’s 

write protected. 

10.15 [TcpScancyr Advanced] Export Inner points 
Export the cross section points that are inside the template. 
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Figure 44 - Export inner points 
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11 Templates 
In order to calculate excavation surfaces and volume you will need to define a 

template. The application does not set limits on the number of templates, although for a 

specific station there can only be one applicable template. 

Each template contains an undetermined number of layers, and it is these that contain 

a polyline with the definition of the section. 

Under the toolbar, the window is divided into two parts. On the left there is a project 

tree showing sections and their layers created for the tunnel. On the right you can see an 

editor used to alter the sections. 

At the bottom is a toolbar with coordinates and current status information. 

The editor menu features undo and redo commands, as well as the clipboard 

commands. They work the same as they do with any application. 

 

Figure 45 - Template editor 

You can create as many sections as you wish, although these should not overlap. Use 

the “Section -> New Section” menu to create a new section, “Section -> Edit Section…” to edit 

section parameters or delete a section with all its layers via the “Section -> Delete Section". 

You may also use the context menu which appears when you select a section from the 

section tree. 
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The dialog box used to create or edit a section is the following.  

 

Figure 46 - Template Data 

Name: Name of the section - no two sections may have the same name. 

Station Range: Minimum and maximum values for the station where this value is to 

be applied. Minimum and maximum values for the project horizontal alignment are displayed.. 

These values may not overlap with already created sections. 

Horizontal alignment Position: Coordinates where the horizontal and vertical 

alignment will pass. With this point you may displace the position of the section with respect 

to the alignments. 

Superelevations Positions: Superelevations application point. This application point 

is supposedly the position of the section with respect to the axis origin (0.0). 

Destroy Height: Indicate whether or not there is a destroy height and its position with 

respect to the gradient. 

If you wish to displace all the created layers and control points, use the “Section -> 

Move Section” menu. Displays a dialog box where you may locate the horizontal and vertical 

offsets to be applied.  

The positive values move the layers and points from the right and from the top, whilst 

the negative values in the opposite direction. If you wish to displace the control points you 

should check the corresponding box. 

 

Figure 47 - Moving Section Layers and Points 
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11.1 Section Layers 
You can assign any number of layers to a section. Use the “Layers” menu, or the 

context menu to select a layer within the tree in order to access the following options. 

New Layer: Creates a new layer in the current section, also creates a new tab in which 

the layer can be drawn. A dialog box will be displayed allowing you to enter the layer name. 

Edit Name: Edits the name of the current layer. 

Edit Layer: Opens a new tab allowing you to edit the layer. 

Delete layer:  Deletes the current layer. If a tab is open, it will be closed. 

11.2 Import Templates 
Templates can be imported from TcpTunnel (*.TNL) and DXF files. It is recommendable 

that DXF files are not too complex, if possible containing only the template as the application 

does not recognize all DXF file entities. 

Having imported a section, this will appear in a tab featuring the name of the file. You 

may use cut and paste commands to assign it to a specific layer. In the case of importing a 

TcpTunnel file, as it may contain more than one section, the application will open a tab for 

each file section. 

In order to pass the imported sections to a layer, you will have to use the clipboard, 

using cut and paste options. You may also use... 25.13 

 

Figure 48 - Imported DXF File 
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[TcpScancyr Advanced] It is also possible import cross sections from the MDT format (“.TRA”). 

This option can be accessed from the “Tunnel” menu, in the principal window. When you 

select the “Tunnel-> Import templates”   the program will ask you for a template file, a vertical 

alignment file and you will can choose between open or closed templates. 

 

Figure 49 – MDT templates import dialog 

 

11.3 Section Elements 
If you wish to apply superelevations to the template, you should check the different 

parts of the section, in order that the application knows how to modify the section. You can 

change the type of each part from the table that defines the template or use the 

corresponding icon on the toolbar. 

Superelevations: Part of the section that is modified on applying the superelevations. 

Fixed: Part of the section that is not modified, but is moved to coincide with the parts 

of sections that are connected. 

Variable: Part of the template that is lengthened or shortened to coincide with the 

fixed part or superelevations from the earlier or subsequent part of section. A template may 

only have one or two variable parts. 

In general, the lower part should be marked as a sup height, if there is a pavement it 

should be fixed and the vertical sections that make up the wall of the tunnel should be marked 

as variable. Examples: 
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11.4 Manual Section Input 
It is also possible to include a template by writing the coordinates and the radii of each 

vertex. In order to access the numerical input window, use the “Numerical editing of the 

section” icon. 

The numerical input window is divided into two parts - in the upper area there is a 

toolbar whose use is the same as in other areas of the application. 

Below the icons there is a table which allows us to fill in data. If a row has a radius 

other than zero, it will form an arc from this point to the point in the following row. If it is the 

last row, it will be linked to the first vertex. The final column shows the section type. 

All sections should have the vertexes in the clockwise direction, and should also be 

closed. This means that the program will always join the last point to the first one, and the last 

point does not have to be the same as the first one.  

 

Figure 50 - Section Numerical Input 

 

11.5 Radius Criteria 
Given two points and a radius, there are four possible arcs. The program will 

determine what arc should be used based on the degrees they cover and the radius sign. 

Supposing that you have an edge AB and a radius R, of the four possible solutions 

those which cover more than 180 degrees can be discarded. Of the two arcs that remain, if the 
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radius is positive, the arc to the left of the AB segment will be used. If it is negative, the arc to 

the right of the heading is used. 

Another way to see how the arc sign affects the program is that the positive values 

create arcs toward the outside of the section, whilst negative values create arcs toward the 

inside. 

 

Figure 51 - Radius Sign Criteria 

11.6 How to create a section from scratch 
If you have opened a numerical input with an empty layer, or you have deleted a 

section, the table will appear empty. The editor is used as follows: 

• Click on the icon again and a row will appear with all values to 0.0 if the table is 

empty. If it has elements, a row will be inserted before the cursor, with the same 

data as in the current row (where the cursor is at present). 

• After keying in the radius and clicking on Enter, a new row will be created with the 

same values that you have entered, in this case, as the final row. 

• When you modify the radius of an intermediate row, the program will calculate if 

it is possible to reach the limits of the arc. If this is not possible, a message will 

appear and the value changed to a minimum radius that joins the two extreme 

points of the arc. 

• When leaving the last row, if this was created automatically (by setting a radius) 

or clicking on cursor down on the last row, it will be automatically deleted if it has 

not been modified. 

11.7 Control points 
For each created layer you can define a series of control points which will be used to 

calculate alignments deviations and to calculate the distances from these points to the cross 

sections. 
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Depending on the type of the point they can be used to calculate the horizontal 

alignment, the vertical alignment or both of them. More than one point must already have 

been defined or the calculations will not be correct. 

Further on it will be explained how to use these points to calculate alignment 

deviation. 

 

Figure 52 - Control Points 

You can also generate control points automatically using the “Layers -> Generate control 

points…” menu. 

 

Figure 53 - Window to generate control points 
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In order to generate the control points, you will have to choose two points over the template, 

start and end point. The control points will be generated with a step separation. 

 

11.8 Assign Templates 
Once the templates are created we must define the template that we want to use in one 

or more station intervals. 

We can assign the same template for different intervals and leave templates with no 

intervals assigned. 
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12 Tunnel Route 
You may render the route of the tunnel by following the alignment. You may also 

export the route to an AVI file. 

Routing the tunnel is carried out from the points cloud’s minimum station to the 

maximum station, although if there are areas without calculated cross sections, or sections 

without points. 

The lower part of the window is divided into three panels, which will be described 

later. 

⚫ Options 

You may set up a number of viewing options - these values can be changed when you 

are in continuous advance mode. 

 

Figure 54 - Route Options Panel 

Observer Height: The height of the observer with respect to the vertical alignment. 

Light by distance: If enabled, the furthest points will appear as the darkest, 

depending on the maximum vision distance. 

Speed: The speed at which the camera advances on the route by clicking on the 

advance or return icons in continuous mode. 

Maximum distance: Maximum vision distance from the camera position. 

Initial and Final Station: Station range covered by using automatic advance. 

⚫ Route 

Panel used to move the camera following the alignment. 

 

Figure 55 - Route Panel 

The icons from left to right are: 
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First Moves the camera to the points cloud's initial station. 

Previous: Moves the camera back a meter, following the alignment. 

Return: Returns the camera in continuous mode, it will move following the alignment 

at the speed indicated on the corresponding control. 

Stop: Stops the camera in continuous advance or return mode. 

Advance: Advances the camera in continuous mode, it will move following the 

alignment at the speed indicated on the corresponding control. 

Next: Moves the camera forward a meter, following the alignment. 

Last: Moves the camera to the points cloud's final station. 

Station: Station where the camera is located. This can be written as a value or the 

scroll bar can be used. 

 

Figure 56 - Route showing points and cross sections 

⚫ View 

This panel allows one to display or hide the different layers that make up the scene. 

The available layers will depend on the data you have calculated  

⚫ Export to AVI 

You may use the menu option File -> Export in order to create an AVI file with the 

route. The route will be created with the current speed, lighting and active layer parameters. 
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The quality of the created video will depend on the output format used and the data 

shown. 

The output format will depend on the codecs installed on the computer, you also must 

know that you may have a codec installed which allows you to reproduce video media but not 

create it. 
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13 Area and volume report 
Once the cross sections have been calculated and you have defined the sections the 

tunnel will be made up of, you may calculate the list of volume enabling you to view the 

volume of excavation excess or defect. This may be accessed from the “Tools -> Area Reports” 

menu. 

 

In the general data section, choose the cross sections file to be used, as well as 

indicating the station range to be used. If you choose the “Only Terrain” option a volume 

report will be calculated without comparison with any other template. 

By selecting the “Top Heading” and “Bench” options, columns will be added with the 

cross sections cut at the assigned benching height. 

 

Figure 57 - Area and Volume Report 

13.1 Cross Sections Comparisons 
You can compare two cross sections files; both files should be included in the project. 
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The following dialog box will appear: 

 

You will need to specify two cross sections files, the station range will be taken from the 

first cross sections file. You may also set the benching height and a offset (positive outwards, 

negative inwards) for the second cross sections file. 

By clicking on “Preview”, an Export Cross Sections dialog box will open, allowing you to 

configure the fields you wish to export. Accepting the dialog box will create a preview of the 

cross sections comparison. 

Accepting the dialog box will also show a report outlining the surface and volume 

differences between cross sections A and B. 

14 Alignment deviation report 
If you have the cross sections and templates defined, you can calculate the position of 

the alignment, based on the cross sections. If you select this option, a dialog box will appear 

enabling you to select the method to be used and a layer for each section of the defined 

alignment. 

When you have calculated a deviation, this is represented on a horizontal and vertical 

alignment. 

Select the method to be used and its parameters on the left-hand side. Underneath, 

select the layer to be used for the calculations. After choosing everything, click the “Calculate” 

button to calculate the deviation. 
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Figure 58 - Dialog box used for calculating the real alignment 

Once calculated, the right-hand side of the dialog box will display a list with the points 

through which the alignment passes for each station where we have a calculated cross 

sections. The columns are as follows: 

Station: Station from which a sample has been taken - coincides with the stations of 

the calculated cross sections. 

Real X, Real Y, Real Z: Absolute coordinates for the calculated alignment. 

Hor. Diff: Horizontal offset of the alignment with respect to the theoretical horizontal 

alignment. 

Ver. Diff Vertical offset of the alignment with respect to the theoretical vertical 

alignment. 

In the lower part you can select an output file in order to create a horizontal alignment 

file including details of offset. 

The tree ways of calculating alignment offset are as follows: 

14.1 Calculation based on cross sections points 
You should only use this method if you have a circular section. The calculation method is 

as follows: 

1. Identify the points which are highest, most to the left and most to the right for 

each cross section. 

2. Using these three points the circle which passes through them can be 

calculated. 
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3. The displacement from the center of the circle and the center of the section can 

be calculated. 

14.2 Calculation based on control points 
This method first calculates the minimum rectangle that encompasses all cross section 

points. Within this rectangle the program looks for the best position for control points, trying 

to minimize the following values: 

1. The distance from each point to the cross section. This enables the section to 

be positioned as close as possible to the cross section. 

2. The variation in point distances. It is not enough to say that points are close to 

the cross section; the distance should also be as similar as possible in all 

control points. 

If you do compensate for the positions of the control points, you can make the 

alignment disappear as the points “pull” in one direction. In the following figure we have 

calculated the alignment offset with the three control points (marked with an x). 

The cross section can be seen in red, the position of the template over the alignment 

in white, and in green the calculated position of the template using the control points. 

It will appear as displaced upwards, because if you lower the axis, the points on the 

sides will have a worse evaluation (they will be distanced from the cross section) because the 

cross section is widened. 

 

Figure 59 - Three Control Points 

By adding a fourth point can make the point “pull away” upwards from the calculated 

position. 
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Figure 60 - Four Control Points 

14.3 Calculation using the template 
This method is based on dividing the template into 'x' number of parts and internally 

creating x' number of control points. These created points are passed on to the earlier 

algorithm in order to calculate alignment deviation. 

You can use the “Divisions” control in order to create more or less points along the 

template - the greater the number of divisions, the better the results. 
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15 Cross Sections Points Report 
Using the command “Tools ->Cross Sections Points Report” you can create lists where you 

will see the distance from each cross section point to the template. 

16 Control Points Report 
Using the “Tools -> Control Points Report” menu you can create lists where you will see 

the distance from each control point to the template. 

The program will calculate the projection of the control point on the template, and will 

use a straight line to this to calculate the distance to the cross section. 

Using the context menu you can access the graphic representation of the cross section. 

 

17 Gauge Report 
Using the cross sections and the template you will be able to calculate the gauge 

report. This consists of calculating to confirm whether or not each cross section is within the 

template. 

For each cross section that does not pass the gauge control, it will be added to a list 

that appears below a list of cross sections in the project window. This list is not saved with the 

project 

18 Bolts Report 
This report lets you see areas that remain to be excavated and can export the data 

calculated as 3D point or points to stake (station, offset and elevation). 

The parameters to set are the range of stations. The minimum height regarding  the 

vertical alignment over to where we analyze the cross section to find areas that need to be 

excavated. 
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Figure 61 - Bolts calculation 

The minimum thickness control this value for the area to be excavated. If we have a 

vertex with a thicker area to which it belongs it will be included in the report. 

With the step parameter control vertices that we generate within each area to be 

excavated. 

The report shows the bolts with its position regarding the development of the theoretical 

section. To export the data we use the button "Export bolts". 
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19 Circle fit 
In case of a circular tunnel can generate a report by fitting a circle in each cross section. 

saving for each one the horizontal and vertical displacement, as well as radius. 

The minimum height parameter is used to cut the cross section and thus disregard the 

bottom. Using this cut-off cross section the program search for side and top extents in order to 

calculate a circle passing through these three points. 
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20 Inspection map 
With this command you can export an image with the representation of the tunnel 

projected on the theoretical section. 

The generated image is the result of taking each point, measuring their distance from 

the theoretical section and its development, giving color and Y coordinate respectively. In the 

resulting image, the points below the alignment correspond to the points to the right of this 

(positive displacement). 

 

Figure 62 - Maps inspection parameters 

The parameters to set are the range of stations, the minimum and maximum values to 

color.  They represent the distance to the theoretical section and the size of the output image. 

If you use the button “Apply”, the program will show you the image result without 

closing the “Inspection map” window.  

It is possible to choose different range of colors for positive values and negative values, 

edit the range colors and the value intervals. 
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The resulting image will always be a little bigger to draw the color scales on each side. 

 

Figure 63 - Inspection map 

21 Orthoimage 
Just like Inspection map command, but this time using color or intensity of each point. 

22  [TcpScancyr Advanced]  Import DXF 
Gives the possibility of import a DXF and show it in the point cloud. 
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23   [TcpScancyr Advanced]  Draw 3D Polylines 
Draw 3D polylines over the point cloud. To draw the polylines, first we have to create a 

new user layer and select it like the current one. Then we use the “Draw polyline” option from 

the toolbar.  

 The user layers and its polylines will be saved in a DXF file linked to the project with 

name <project>_user.dxf, in the same folder of project file. 

 

 

24 Cross Section editor 
The program includes a cross section editor which can be used to modify any project 

cross section. If you have defined the template, this will appear with a cross section to be 

edited. However, you will not be able to make any alterations, is only displayed as a point of 

reference.  

The central part of the editor has a tab at the top that indicates the cross section being 

edited. If there is an asterisk at the end, the cross section has been modified since the last time 

it was saved.  

Next the editor's operational mode is displayed. This is common to the cross section 

editor and the template editor. You should pay attention to the status bar, which will show 

information on the current state. 

• If you click on the cross section, this will be marked as selected. You will see the 

position of each vertex in a green square. 

• If you click on vertex or an edge, you will move on to the “Modify” state. Now you can 

use the cursor to drag the selected element to the desired position. If you double left 

click you can stop dragging the selection and return to the Selection state. 

• Keying “Esc” will enable you to exit the current state. 
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o If you are in the Selection state and have selected a selected a cross section, 

this will be deselected. 

o If you are modifying a figure, the modification will be cancelled and you will 

return to the Selection state. 

 

Figure 64 - Editing a Cross Section 

On closing the editor you will be asked if you want to save any changes you might have 

made to the cross section. 
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25 Tool Bars 
In order to access the application's various options use the toolbars beneath the menu 

bar. Depending on the part of the program you have active, these bars may appear as disabled. 

The application’s tool bars are as follows: 

25.1 File 
In order to access the most common file menu options there is a toolbar in the main 

window. 

 

Figure 65 - Project File Toolbar 

The icons from left to right are: 

New Project: Opens a dialog box in order to create a new project. 

Open Project: Opens the file selector to load an existing file. 

Project Properties: Opens a dialog box in order to change certain areas of the 

project. 

Save Project: Saves the current project without asking the user for the name. For this 

option to be enabled, the project should already be located on the computer. 

 

25.2 View 
Allows you to change the projection type and drawing view. If you are viewing a 2D 

drawing, these options will be disabled: 

 

Figure 66 - View Toolbar 

The icons from left to right are: 

Projection Type: This option will be enabled in the case of 3D drawings. When 

enabled, orthographic projection will be applied. With this projection, the size of objects will 

not be based on their distance from the camera. If the option is disabled, a perspective 

projection will be applied. In this case, the size of the object will depend on their distance from 

the camera. 

Front View Points the camera toward the Y axis 
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Top view: Points the camera toward the Z axis 

Side view: Points the camera toward the X axis 

Rotation center: Select a point into the drawing area (there must be something 

drawn) to change the rotation center. 

 

25.3 Drawing 
With this toolbar you can control the position and enlargement of the drawing. 

If perspective projection is enabled, the zoom in, zoom out, enlarge extension and 

enlarge windows icons will be disabled. 

 

Figure 67 - Standard 

The icons from left to right are: 

Zoom in: Zooms out of the drawing from its middle. One can also use the mouse 

wheel by moving it forward, but in this case the zoom point will be the position of the mouse. 

Zoom out: Zooms out of the drawing from its middle. One can also use the mouse 

wheel by moving it forward, but in this case the zoom point will be the position of the mouse. 

Zoom Extension: The view is enlarged or reduced so as to see all the items in the 

drawing, only taking into account the visible layers. 

Zoom Window: To zoom in on an area of the drawing, the first click of the mouse 

marks a corner of the window, and the second marks the opposite corner. 

Pan: The drawing can be moved by clicking on the window and moving the mouse 

without letting go of the window. 

25.4 Layers 
You may hide or display the layers that make up the drawing. For this reason you need 

to open Layer Control and select the light bulb icon. The name of the layer cannot be altered. 

 

Figure 68 - Layers 

 [TcpScancyr Basic] By clicking on the Set Up icon you can change the background 

color, the reference axes and the zoom and selection windows. 
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[TcpScancyr Advanced] Pressing configuration button we can see the list of layers 

sorted by group. This dialog allows also to hide layer groups, remove layers from groups “Dxf” 

and “User”, as well as create new layers in this group. 
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25.5 Grid 
Includes buttons for enabling or disabling the references on the drawing currently 

being viewed. They will only be enabled when it is a 2D drawing. 

 

Figure 69 - Grid 

The icons from left to right are: 

Axes: Draws the XY axes on the drawing if they are available. 

Grid: Enables or disables grid view on the drawing. 

Grid properties: Displays a dialog box allowing grid values to be changed. 

25.6 References to Figures 
References to objects allow you to quickly select exact geometrical points in existing 

figures, without having to know the exact coordinates of those points. References to objects 

can be used to select the end point of a line or arc, the midpoint of a circle, or any other 

geometrically significant position. 

When more than one reference is activated, the closest of all the enabled ones will be 

displayed. 
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Figure 70 - References to Figures 

The icons from left to right are: 

Point: Marks a point as a reference. 

Close: Marks the point closest to the cursor position, applicable to any figure, except 

the points. 

End point: Marks the edge of the figure, or of one of its parts that is closest to the 

mouse position. Does not apply to circles. 

Midpoint: Marks the midpoint of the figure. 

Centre: Marks the center of the figure closest to the mouse. 

Quadrant: Marks the four extremities of a circumference. 

25.7 Points Selection 
When viewing a points cloud or cross sections you may select the points to be marked 

as filtered or remove this mark. 

Having selected the points, these will appear marked. The right-hand icon will open a 

context menu, allowing you to filter points (Eliminate Selection), or remove the filter mark 

(Include Selection). 

In the case of being selected by polyline you may use the option “Select” in order to 

finish the polyline and select the points that are within. 

 

Figure 71 - Points Selection 

The icons from left to right are: 

Remove: Removes the points selection mark. 

Window: Select the points via a rectangular window. 

Circle: Select points via a circular window by first marking the center of the circle, 

moving the mouse to select the radius. 

Polyline: Select the points via a polyline. By clicking on the left-hand icon you may add 

vertices, in order to finish the polyline, open the context menu with the right icon and select 

the corresponding option. 
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25.8 Scale 
Depending on the drawing you are viewing, you will be able to change the vertical 

scale factor. 

 

Figure 72 -  Scales 

The applicable values range from x1 (normal scale) to x10, if you need a greater value 

you may write it in Control. 

25.9 Help 

 

Figure 73 - Help 

The icons from left to right are: 

Measure distances: This command allows one to measure distances between two 

points, by first selecting the initial point of the measurement, and then the final point. The 

distance measured will be displayed in the status bar. It is advisable to activate the most 

necessary references to figures, or else the application may return incorrect data if it does not 

use the coordinates of the point you believe has been selected. 

After the second point is selected, the next window appears. 

 

Figure 74 - Measurement between Two Points 

The values of the initial and final point in row XY, XYZ represent the distance from the 

origin to the point on the XY or XYZ plane respectively. 

Number Edit: Displays the following window, where the coordinates can be entered 

manually. If it is a 2D drawing, the Z coordinate control will be disabled. 
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Figure 75 - Manual Coordinates 

After entering the coordinates, press OK. In absolute coordinates mode, the entered 

coordinates will be added. In relative coordinates mode, the entered coordinates will be 

considered increments since the last point entered. 

25.10 Points 
Change points size, the value is unique for all points 

 

25.11 Modify 
Commands which allow you to modify polylines. 

 

Figure 76 - Tools Used to Modify Figures 

Insert vertex: Inserts a vertex at the selected point. It must be near an edge. 

Eliminate vertex: Eliminates the selected vertex. It is advisable to have selected the 

polyline to see where the vertices are. 

Eliminate range of vertices: Marks two vertices, with all the vertices between them 

deleted. 

Eliminate vertices window: Marks a checkbox with the mouse and the vertices 

inside it will be deleted. 

Join Polylines: This command allows you to join two polylines. Firstly you will need to 

draw a polyline that intersects the cross section at two points. You can then use this tool to 

select the cross section and then the polyline you have created. 

Due to the fact that the points that make up the cross section are ordered by angle, 

there are cross sections that will emerge badly. Using this tool to join polylines you can repair 

these cross sections. 
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Figure 77 - Cross Section with errors 

Draws a polyline that intersects the cross section. For the intermediate vertices you can use 

the reference tool in order to ensure that the same vertices are used as for the original cross 

section but taking them in the correct order. 

 

Figure 78 - Polyline Manual in Purple 

Using the Join cross sections tool, first select the cross section and then the polyline. The 

program will automatically join the two polylines. 
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Figure 79 - Corrected Cross Section 

25.12 Shapes 

 

Figure 80 - Create Shapes 

 Using this toolbar you may create figures to add them to the drawing. From left to 

right these are lines, polylines and circles. 

 It is currently only possible to create polylines in order to join them to the cross section 

and thus correct any angle-ordering errors. 

 In future versions these tools and other new additions may be used to graphically 

create template. 

25.13 Move 
Commands used to move figures. 

 

Figure 81 - Move Figures 

From left to right, these are as follows. 

Move figure: First select the figure to move, then select a point as the origin, and 

lastly select a point as the destination. The figure will be moved by the vector formed by 

destination - origin. 

Move figure to the origin: First select a figure, then assign a point of origin. The 

figure will be moved by the vector coordinate origin - point of origin. 
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Copy with reference point: This command functions as previously (Move figure to 

the origin), but the figure will be copied to the clipboard. Then go to the layer that is to be 

modified and paste in the figure using Ctrl+V. 

The best way to assign the origin or destination coordinates is to use the references to 

figures, or enter the coordinates manually, using the Coordinates command. 

25.14 Utility toolbar 
In order to make the application more comfortable there is a toolbar displaying the 

most-used points options. This bar will only be enabled if you are viewing a points cloud. 

 

Figure 82 - Points Tools 

From left to right these are, information, auxiliary windows, filters, symbols, color 

range. 

Use the Information icon to consult details on any point on the points cloud. An 

information window on the selected point, depending on the available data (alignment, 

gradient), some of the field will be disabled. 

 

Figure 83 - Information Associated to a Point 

The "Color Range" control is used to change the colors applied to a symbol without 

having to recalculate it. 

If you have closed any of the floating windows (except filters) you can bring them up 

again by clicking on “Auxiliary Windows”. 
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26 Data Tables 
You will then see a number of elements which appear in different areas of the 

program. These function in the same way, adapting the application to the data in question. 

In various parts of the program you will see a table featuring a series of icons. In 

general the type of data displayed will vary (horizontal alignment, list of volume), although the 

way they function will be the same. 

Depending on the associated data, some of these options may be hidden or disabled. 

 

Figure 84 - Generic icons, all visible and enabled 

The action which correspond to each icon are as follows, from left to right. 

Open: Opens a file in order to change data. If you are in "Horizontal alignment" you 

can load an alignment. 

Save: Saves file data. The format will depend on table data. 

New: Creates a new data entry. A dialog box will appear allowing the various fields to 

be filled in. 

Edit: Edits the selected row. A dialog box will appear allowing fields to be altered. 

Delete: Deletes selected table elements. 

Search: Opens a dialog box allowing you to search for data. 

When you carry out a search, the corresponding element will be marked so that it 

coincides exactly with the given parameters. If there is no corresponding element, the nearest 

element will be marked. 

More than one parameter may be specified per search. For example if you wish to 

carry out a search on the horizontal alignment, writing a radius = 150, station 1000, the 

application will search for the curve or clothoid with a radius close to 150 and a station close to 

1000. 
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Figure 1 – Search for an element with radius 150 

 

Delete All: Deletes all the data from the table. 

Export: Exports data to a number of formats. Firstly a dialog box will be displayed, 

allowing you to select the data to be exported and its format. The tool also allows you to 

delete the fields to be exported without changing the order. 

Depending on the table to be exported, the group of columns will vary. As an example, 

the list to export a horizontal alignment is shown. 

 

Figure 85 - Exporting Surface and Volume Lists 
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27 Configuration 
The following are the various Configuration dialog boxes. 

By clicking on “Restore” you can change the current values to the default values. This 

change will only affect the page you have selected. 

 

27.1  [TcpScancyr Advanced] Drawing 
It allows to change background and axes colors. 

 

Figure 86 – Drawing configuration 

 

27.2  [TcpScancyr Advanced] Windows 
It allows to change selection, capture and zoom window colors.  
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Figure 87 – Windows configuration 

 

27.3 Horizontal Alignment 
Allows one to change the colors and distances of the short and long marks, as well as 

the color of the unique points. 

 

Figure 88 - Alignment Configuration 

Short mark interval: The distance in meters between the short marks. Alongside is 

an icon for assigning them a different color. The “Options” icon can be used to configure the 

format of the marks. 

Long mark interval: The distance in meters between the short marks. The mark color 

and format can also be configured. 

Singular points: Only the color and format of the unique points can be configured. 

Line, Curve, Clothoid: The color of each type of alignment section. 
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Real alignment: The color of the alignment calculated with cross sections and 

sections. 

⚫ Format of the marks and unique points. 

 

Figure 89 - Format of the Short and Long Marks 

Mark length: Length of the mark. The line will be perpendicular to the alignment. 

Extension length: If one draws texts, this value marks the extension of the mark 

towards the attached text. 

Align texts: Texts can be aligned to the left, the right or not aligned at all. 

 

Figure 90 - Format of Unique Points 

The options available for the unique points are the same as for the short and long 

marks. One can also indicate if the text is inside or outside. 

27.4 Vertical Alignment 
Allows the appearance of vertical alignment to be changed. 
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Figure 91 – Vertical alignment options 

The vertical alignment colors can be changed, as can the previous gradient, vertical 

lines and text. 

Text Height: Height of text in meters. 

Short mark interval: The distance in meters between the short marks. 

Long mark interval: The distance in meters between the short marks. 

Unique points: Color of the unique points. These are drawn on the following points: 

• Station - tangent 

• Station + tangent 

• Station if the tangent equals zero. 

Guitar: Color of the separation lines and legend. 

Gradient: Color and thickness in pixels of the horizontal alignment: 

Real gradient: The color of the alignment calculated with cross sections and the 

template. 

Upper ground: The color of the maximum height between the intersection of the 

vertical line that passes through the alignment and the cross section. 

Lower ground: The color of the minimum height between the intersection of the 

vertical line that passes through the alignment and the cross section. 

27.5 Superelevations 
Allows the color of the left and right superelevations, as well as the size of the text in 

pixels. 
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Figure 92 - Superelevations Configuration 

27.6 Cross Sections 
You can change the color of the elements which appear when you are viewing the 

cross sections. As you can see, no control appears to change the color of the points as these 

will appear with the color of the applied symbols. 

 

Figure 93 -  Cross sections Configuration 

 

 


